This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Author Message
HJ66Offline
Post subject: Kaffeine dvb Tv works fine vith 686, but does not with AMD64  PostPosted: 19.10.2010, 12:08



Joined: 2010-10-19
Posts: 3

Status: Offline
Using the firmware dvb-usb-dib0700-1.20.fw with the usb device "AVerMedia AVerTV DVB-T Volar" on aptosid-686, all is OK :

henri@aptosidbox:~$ dmesg | grep dvb
[ 6.899356] dvb-usb: found a 'AVerMedia AVerTV DVB-T Volar' in warm state.
[ 6.899680] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 8.267795] dvb-usb: schedule remote query interval to 50 msecs.
[ 8.267798] dvb-usb: AVerMedia AVerTV DVB-T Volar successfully initialized and connected.
[ 8.268453] usbcore: registered new interface driver dvb_usb_dib0700
henri@aptosidbox:~$

and then Kaffeine works perfectly.

****************************

With aptosid-amd64 it begins well but when I want to see the Tv with Kaffeine, Kaffeine freezes :

henri@aptosidbox:~$ dmesg | grep dvb
[ 5.942554] dvb-usb: found a 'AVerMedia AVerTV DVB-T Volar' in warm state.
[ 5.942874] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 7.616858] dvb-usb: schedule remote query interval to 50 msecs.
[ 7.616861] dvb-usb: AVerMedia AVerTV DVB-T Volar successfully initialized and connected.
[ 7.617618] usbcore: registered new interface driver dvb_usb_dib0700
henri@aptosidbox:~$ kaffeine
kaffeine(2374) DvbManager::readDeviceConfigs: can't open "/home/henri/.kde/share/apps/kaffeine/config.dvb"
henri@aptosidbox:~$ kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed
kaffeine(2374) DvbDevice::frontendEvent: tuning failed

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325277] Oops: 0000 [#1] PREEMPT SMP

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325283] last sysfs file: /sys/devices/pci0000:00/0000:00:02.1/usb1/1-2/idProduct

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325488] Stack:

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325513] Call Trace:

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325683] Code: c4 18 c3 66 66 66 2e 0f 1f 84 00 00 00 00 00 41 57 b8 a1 ff ff ff 41 56 41 55 41 89 d5 41 54 49 89 f4 55 53 48 89 fb 48 83 ec 18 <48> 8b 57 10 48 83 3a 00 0f 84 9d 00 00 00 65 48 8b 04 25 00 cc

Message from syslogd@aptosidbox at Oct 19 11:35:15 ...
kernel:[ 157.325749] CR2: 0000000000000012

henri@aptosidbox:~$


Question
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Kaffeine dvb Tv works fine vith 686, but does not with A  PostPosted: 19.10.2010, 23:03



Joined: 2010-08-25
Posts: 737

Status: Offline
That looks like a kernel oops, dmesg (or syslog in retrospect) will know more details. In order to debug it further, we'd need that info to determine which modules causes the oops and where/ why.
 
 View user's profile Send private message  
Reply with quote Back to top
HJ66Offline
Post subject:   PostPosted: 20.10.2010, 05:28



Joined: 2010-10-19
Posts: 3

Status: Offline
dmesg after the freezing of kaffeine :


253.721418] Modules linked in: powernow_k8 mperf cpufreq_powersave cpufreq_ondemand cpufreq_stats freq_table cpufreq_conservative cpufreq_performance sco bnep rfcomm l2cap crc16 bluetooth ppdev lp af_packet fuse dm_crypt nvidia(P) usblp mt2060 dvb_usb_dib0700 dib7000p dib0090 dib7000m dib0070 dvb_usb dib8000 dvb_core snd_intel8x0 snd_ac97_codec dib3000mc dibx000_common arc4 ecb ac97_bus snd_pcm rt61pci rt2x00pci snd_seq snd_timer snd_seq_device psmouse edac_core rt2x00lib led_class snd i2c_nforce2 i2c_core rtc_cmos mac80211 soundcore cfg80211 snd_page_alloc rtc_core rfkill serio_raw k8temp eeprom_93cx6 parport_pc tpm_tis edac_mce_amd pcspkr tpm rtc_lib parport tpm_bios button evdev processor ext3 jbd mbcache dm_mod sg sr_mod cdrom sd_mod pata_acpi ohci_hcd ata_generic sata_nv pata_amd ssb ehci_hcd mmc_core libata fan firewire_ohci usbcore scsi_mod floppy firewire_core crc_itu_t pcmcia thermal forcedeth nls_base pcmcia_core [last unloaded: scsi_wait_scan]
[ 253.721529]
[ 253.721535] Pid: 2391, comm: kaffeine Tainted: P 2.6.35-4.slh.9-aptosid-amd64 #1 NF4-INF/
[ 253.721541] RIP: 0010:[<ffffffffa053f75c>] [<ffffffffa053f75c>] i2c_transfer+0x1c/0x100 [i2c_core]
[ 253.721554] RSP: 0018:ffff880024d79b68 EFLAGS: 00010292
[ 253.721559] RAX: 00000000ffffffa1 RBX: 0000000000000002 RCX: 0000000000000000
[ 253.721564] RDX: 0000000000000002 RSI: ffff880024d79bb8 RDI: 0000000000000002
[ 253.721569] RBP: 0000000000000000 R08: 0000000050000d80 R09: dead000000200200
[ 253.721573] R10: dead000000100100 R11: 0000000000000005 R12: ffff880024d79bb8
[ 253.721578] R13: 0000000000000002 R14: ffff88003d094580 R15: ffffc90011db5000
[ 253.721585] FS: 00007f08635d3760(0000) GS:ffff880001800000(0000) knlGS:0000000000000000
[ 253.721590] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 253.721595] CR2: 0000000000000012 CR3: 0000000024db5000 CR4: 00000000000006f0
[ 253.721600] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 253.721605] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 253.721611] Process kaffeine (pid: 2391, threadinfo ffff880024d78000, task ffff88003ce67860)
[ 253.721615] Stack:
[ 253.721618] ffff880037f30c00 0000000000009a38 0000000000000020 00000000000000eb
[ 253.721624] <0> 0000000000000000 0000000000000001 ffffc90011c96000 ffff88003d094580
[ 253.721632] <0> ffffc90011db5000 ffffffffa06bf12f ffff000200000010 ffff880024d79be8
[ 253.721640] Call Trace:
[ 253.721650] [<ffffffffa06bf12f>] ? dib7000p_read_word+0x6f/0xd0 [dib7000p]
[ 253.721660] [<ffffffffa06c00e0>] ? dib7000p_pid_filter_ctrl+0x20/0x90 [dib7000p]
[ 253.721669] [<ffffffffa069d4b2>] ? dvb_usb_ctrl_feed+0x142/0x160 [dvb_usb]
[ 253.721681] [<ffffffffa067341b>] ? dmx_ts_feed_start_filtering+0x5b/0xe0 [dvb_core]
[ 253.721691] [<ffffffffa066fc0b>] ? dvb_dmxdev_start_feed+0xcb/0x140 [dvb_core]
[ 253.721702] [<ffffffffa06711ae>] ? dvb_dmxdev_filter_start+0x2ce/0x3d0 [dvb_core]
[ 253.721712] [<ffffffffa0671c30>] ? dvb_demux_do_ioctl+0x590/0x680 [dvb_core]
[ 253.721722] [<ffffffff81100f30>] ? chrdev_open+0x0/0x210
[ 253.721729] [<ffffffff810fc14c>] ? __dentry_open+0x26c/0x340
[ 253.721739] [<ffffffffa066f441>] ? dvb_usercopy+0xa1/0x190 [dvb_core]
[ 253.721748] [<ffffffffa06716a0>] ? dvb_demux_do_ioctl+0x0/0x680 [dvb_core]
[ 253.721756] [<ffffffff8110bc19>] ? do_filp_open+0x219/0x650
[ 253.721766] [<ffffffffa06703e6>] ? dvb_demux_ioctl+0x46/0x80 [dvb_core]
[ 253.721773] [<ffffffff8110d215>] ? vfs_ioctl+0x35/0xd0
[ 253.721780] [<ffffffff8110d3d8>] ? do_vfs_ioctl+0x88/0x530
[ 253.721787] [<ffffffff8110d900>] ? sys_ioctl+0x80/0xa0
[ 253.721794] [<ffffffff810fbe4b>] ? do_sys_open+0xfb/0x140
[ 253.721803] [<ffffffff81009f02>] ? system_call_fastpath+0x16/0x1b
[ 253.721807] Code: c4 18 c3 66 66 66 2e 0f 1f 84 00 00 00 00 00 41 57 b8 a1 ff ff ff 41 56 41 55 41 89 d5 41 54 49 89 f4 55 53 48 89 fb 48 83 ec 18 <48> 8b 57 10 48 83 3a 00 0f 84 9d 00 00 00 65 48 8b 04 25 00 cc
[ 253.721860] RIP [<ffffffffa053f75c>] i2c_transfer+0x1c/0x100 [i2c_core]
[ 253.721870] RSP <ffff880024d79b68>
[ 253.721873] CR2: 0000000000000012
[ 253.721878] ---[ end trace d213a5fc1a7a93d2 ]---
henri@aptosidbox:~$
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 20.10.2010, 12:32



Joined: 2010-08-25
Posts: 737

Status: Offline
I'm afraid with nvidia loaded, there isn't much opportunity for debugging. However I notice that you're running a rather old kernel, while several v4l related bugfixes went into recent updates.
 
 View user's profile Send private message  
Reply with quote Back to top
HJ66Offline
Post subject:   PostPosted: 20.10.2010, 17:38



Joined: 2010-10-19
Posts: 3

Status: Offline
But with aptosid386 and nvidia driver loaded all works well.
Ill try to upgrade for a up-to-date kernel.

Thanks for your interest and felicitations for your job !
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio