Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
prozektorOffline
Post subject:   PostPosted: 23.10.2010, 11:34



Joined: 2010-10-23
Posts: 4
Location: Russia, Lipetsk
Status: Offline
Yes ,i have a separate /boot partition
 
 View user's profile Send private message  
Reply with quote Back to top
bmorencyOffline
Post subject:   PostPosted: 23.10.2010, 12:04



Joined: 2010-10-22
Posts: 71

Status: Offline
The solution posted by prozektor worked for me too.
Thanks


I also have a separate boot partition. And I do have the latest kernel. My inital post was a typo.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 23.10.2010, 12:11



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
its kinda obvious (although i had overseen it)
/boot points to the boot directory on /
no initrd or kernel there.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
bmorencyOffline
Post subject:   PostPosted: 23.10.2010, 12:18



Joined: 2010-10-22
Posts: 71

Status: Offline
I do not know where to make this change so it will be permanent next time I reboot. Does anyone know what file I need to change?

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
prozektorOffline
Post subject:   PostPosted: 23.10.2010, 12:35



Joined: 2010-10-23
Posts: 4
Location: Russia, Lipetsk
Status: Offline
/boot/grub/grub.cfg
 
 View user's profile Send private message  
Reply with quote Back to top
bmorencyOffline
Post subject:   PostPosted: 23.10.2010, 14:43



Joined: 2010-10-22
Posts: 71

Status: Offline
oh ok.I went to change that file but at the top it says not to change it as it is generated by other programs. if there is a kernel upgrade will it change back?
 
 View user's profile Send private message  
Reply with quote Back to top
schlimmOffline
Post subject:   PostPosted: 23.10.2010, 16:03



Joined: 2010-10-23
Posts: 6

Status: Offline
I changed grub.cfg, but a grub-update changed it back! Is there a lasting solution?

Greetings
 
 View user's profile Send private message  
Reply with quote Back to top
dark_rayOffline
Post subject:   PostPosted: 23.10.2010, 16:16



Joined: 2010-09-11
Posts: 3
Location: Saint-Petersburg
Status: Offline
Yes, it will change back.
/boot/grub/grub.cfg is affected (during update-grub) by general settings in /etc/default/grub and various scripts in /etc/grub.d.
And in scripts there is "10_linux" witch "Locates kernels based on the distributor".
So u need to change (temporarily) this common script to generate correct lines
      Code:

/etc/grub.d/10_linux

105  rel_dirname=`make_system_path_relative_to_its_root $dirname`
to
105  rel_dirname=""

Then run as root update-grub. I have checked this solution but without reboot Smile
Use it on your own risk!
 
 View user's profile Send private message  
Reply with quote Back to top
GranjowOffline
Post subject:   PostPosted: 25.10.2010, 06:58



Joined: 2010-10-25
Posts: 1

Status: Offline
      prozektor wrote:
I am change from grub (select menu entries and press e):

      Code:
linux /boot/vmlinuz-2.6.35-7.slh.1-aptosid-amd64 root=UUID=73fc2ebd-ea3a-4169-b469-a14bd311f066 ro single vga=791
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.35-7.slh.1-aptosid-amd64


on:

      Code:
linux /vmlinuz-2.6.35-7.slh.1-aptosid-amd64 root=UUID=73fc2ebd-ea3a-4169-b469-a14bd311f066 ro single vga=791
echo 'Loading initial ramdisk ...'
initrd /initrd.img-2.6.35-7.slh.1-aptosid-amd64


and problem solved


Man, thank you!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
belzeOffline
Post subject:   PostPosted: 25.10.2010, 08:38



Joined: 2010-09-13
Posts: 100

Status: Offline
changing the boot option in grub at system start did not work for me. I had to use systemrescuecd to boot into my system and thanks to a grup update avaible today my system is now up and running.
 
 View user's profile Send private message  
Reply with quote Back to top
darthwonkaOffline
Post subject:   PostPosted: 25.10.2010, 14:37



Joined: 2010-10-25
Posts: 1
Location: Boulder, Colorado USA
Status: Offline
      GdV87 wrote:
The solution posted by prozektor worked flawlessly for me too.
Thanks
GdV87

p.s. I've a separate boot partition


Same problem here.. Separate /boot partition. How often will we need to hand fix the problem after fixing grub.cfg? What changed?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 25.10.2010, 18:01



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
not at all, its fixed in grub-pc_1.98+20100804-7
in detail:
http://packages.debian.org/changelogs/p ... /changelog
it broke with:
      Code:
 zfs_fix_mkrelpath.patch: Fix grub-mkrelpath for non-root ZFS. (Closes: #600578)

and was fixed with:
      Code:
* zfs_fix_mkrelpath.patch: Replace with proper fix from upstream Bazaar. (Closes: #601087)


greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio