Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
tqkOffline
Post subject: hwclock UTC: aptosid ignores /etc/default/rcS  PostPosted: 03.11.2010, 22:13



Joined: 2010-11-03
Posts: 14
Location: I'd go pretty much anywhere.
Status: Offline
This's annoying. I've been running Debian since the late '90s, but I can't make sense of my hardware clock atm.

I think it may all be working, but aptosid-xfce thinks I'm in UTC. I just want hwclock set to UTC, and OS ought to know I'm MSTMDT. How to fix?

http://pastebin.com/SMhsz8LF
 
 View user's profile Send private message Visit poster's website Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: hwclock UTC: aptosid ignores /etc/default/rcS  PostPosted: 03.11.2010, 22:29



Joined: 2010-08-25
Posts: 746

Status: Offline
rcS(5) is working as documented in its manpage and assorted documentation. While actual preconfiguration might differ slightly, there is no functional difference to plain Debian.

At this moment, there is no aptosid specific bug known in this regard, neither can it be reproduced.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: hwclock UTC: aptosid ignores /etc/default/rcS  PostPosted: 03.11.2010, 22:45



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
moving to software, not a release bug

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
tqkOffline
Post subject: Re: RE: hwclock UTC: aptosid ignores /etc/default/rcS  PostPosted: 03.11.2010, 23:30



Joined: 2010-11-03
Posts: 14
Location: I'd go pretty much anywhere.
Status: Offline
      slh wrote:
rcS(5) is working as documented in its manpage and assorted documentation. While actual preconfiguration might differ slightly, there is no functional difference to plain Debian.

At this moment, there is no aptosid specific bug known in this regard, neither can it be reproduced.

So, if my Mom's looking for help here, solution's to re-install, taking care for stuff that I've never seen affect me before. Okay.

Not helpful, but I'll try that.
 
 View user's profile Send private message Visit poster's website Yahoo Messenger  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 03.11.2010, 23:53



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
It happened that I got a new SSD for my netbook (Toshiba NB205), so I installed aptosid fresh, from the 2010-02 CD.

One thing I noticed -- even after I clearly set the timezone to "New York" and/or "Montreal", the clock was 1 hour too early (Central Time). I ran "dpkg-reconfigure tzdata" and got aggravated -- it would not change to the correct time. That all happened on Saturday. I thought maybe there was some confusion about the conversion to Standard Time (in the US, this happens 7 NOV).

On Sunday I booted my netbook. It came up the correct time. It has been correct ever since.

I dunno ..... go figure .... funny things happen, sometimes.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 05.11.2010, 21:57
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Not sure how to do in xfce since i don't use it anymore but in kde you can go to ...

system settings > regional & language > country/regional & language > time & dates > time format > change to pH:MM:SS AMPM then go to > other > measure system > and change that to imperial


sorry couldn't help with xfce

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
tqkOffline
Post subject: Re: hwclock UTC: aptosid ignores /etc/default/rcS [SOLVED]  PostPosted: 05.11.2010, 23:00



Joined: 2010-11-03
Posts: 14
Location: I'd go pretty much anywhere.
Status: Offline
      tqk wrote:
      slh wrote:
rcS(5) is working as documented in its manpage and assorted documentation. While actual preconfiguration might differ slightly, there is no functional difference to plain Debian.

At this moment, there is no aptosid specific bug known in this regard, neither can it be reproduced.

So, if my Mom's looking for help here, solution's to re-install, taking care for stuff that I've never seen affect me before. Okay.

Not helpful, but I'll try that.

Solution: "dpkg-reconfigure tzdata"
 
 View user's profile Send private message Visit poster's website Yahoo Messenger  
Reply with quote Back to top
tqkOffline
Post subject:   PostPosted: 05.11.2010, 23:03



Joined: 2010-11-03
Posts: 14
Location: I'd go pretty much anywhere.
Status: Offline
      dibl wrote:
It happened that I got a new SSD for my netbook (Toshiba NB205), so I installed aptosid fresh, from the 2010-02 CD.

One thing I noticed -- even after I clearly set the timezone to "New York" and/or "Montreal", the clock was 1 hour too early (Central Time). I ran "dpkg-reconfigure tzdata" and got aggravated -- it would not change to the correct time. That all happened on Saturday. I thought maybe there was some confusion about the conversion to Standard Time (in the US, this happens 7 NOV).

On Sunday I booted my netbook. It came up the correct time. It has been correct ever since.

I dunno ..... go figure .... funny things happen, sometimes.

Damn, I just reported that as my solution. Sorry I didn't read this. Thanks.
 
 View user's profile Send private message Visit poster's website Yahoo Messenger  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 07.11.2010, 21:49
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
"dpkg-reconfigure tzdata"

sometimes *here, it takes 5-6 reboots for that command to take effect, what I posted above is instant (once on 64 bit had to restart kde) and have used that method since kde4 and hasn't failed me yet

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio