Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
muchan
Post subject: 2010-11-09 growisofs got dpkg error  PostPosted: 09.11.2010, 00:53
Moderator


Joined: 2010-09-11
Posts: 468

      Code:

Unpacking growisofs (from .../growisofs_7.1-8_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/growisofs_7.1-8_i386.deb (--unpack):


just doing "#apt-get install-f" fixed the problem
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: 2010-11-09 growisofs got dpkg error  PostPosted: 09.11.2010, 15:22



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Workaround works for me
 
 View user's profile Send private message  
Reply with quote Back to top
sx9Offline
Post subject: RE: 2010-11-09 growisofs got dpkg error  PostPosted: 10.11.2010, 13:11



Joined: 2010-09-12
Posts: 219
Location: Wiesbaden,Germany
Status: Offline
Got the same problem.

Does apt becomes stupid, now?

Only some packages had to be additionaly downloaded!

_________________
My new self-made computer:
Intel Core i7-2600k
ASUS Maximus IV Gene-Z (Mainboard)
2x4GB DDR3 RAM
ATI Radeon HD 6770
OCZ Vertex 3 60GB (SSD)
Western Digital Caviar Green WD20EARX 2TB (HDD)
...
aptosid x86_64
 
 View user's profile Send private message Send e-mail Yahoo Messenger  
Reply with quote Back to top
DonKultOffline
Post subject: Re: RE: 2010-11-09 growisofs got dpkg error  PostPosted: 10.11.2010, 18:25
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
      sx9 wrote:
Does apt becomes stupid, now?

(trying hard to take it not as an offense)

No, its the fault of the package maintainer(s) who forgot to add a
proper "Replaces: dvd+rw-tools ( << 7.1-8 )" to growisofs after moving files around in the package…
dpkg complains then that two packages want to own the same file - which is impossible.

That a second run fixes it is just because apt installs the new versions of both packages (and leaves them in a broken state after the first run) and in the new version of the dvd+rw-tools the file is gone, so only one package includes the file and dpkg is happy.
A replaces had hinted APT that it should install the new version of dvd+rw-tools before growisofs -- or if this is impossible it has told dpkg at least that it is okay that it overrides files of the other package.

An upload fixing this issue is in the archive already btw.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio