Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
IsraelOffline
Post subject: Dist-Upgrade just a black screen after rebooting  PostPosted: 23.11.2010, 03:02



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
I changed my repositories in /etc/apt/sources.list.d/sidux.list to:

deb ftp://ftp.spline.de/pub/aptosid/debian/ sid main fix.main

Downloaded and installed aptosid-archive-keyring. Ran apt-get update, then apt-get dist-upgrade and rebooted. I noticed for whatever reason GRUB had a selection for aptosid and sidux. I selected aptosid and the screen just went black and just stays that way.

Thank God I can still boot back into my old Sidux, but I would like to get this running.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
eQuackyOffline
Post subject:   PostPosted: 23.11.2010, 07:34



Joined: 2010-09-12
Posts: 5

Status: Offline
Hi,

if you're using a radeon card, maybe that thread could be useful:

http://aptosid.com/index.php?name=PNphp ... highlight=

greetz

Thomas
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 23.11.2010, 08:33



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
a black screen has nothing to do with changing mirrors.
was that the initial upgrade from sidux to aptosid?
if you have sidux and aptosid in grub menue, do you have 2 installs?

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
IsraelOffline
Post subject:   PostPosted: 23.11.2010, 19:32



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
I don't believe I have Raedon card. I ran lspci and it just says...

      Code:
Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller


Yes, it was the initial upgrade from Sidux to Aptosid. Its odd, I didn't do anything to specify 2 installs. I figured it was just like how GRUB usually offers to boot into different kernel versions. I don't know...
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 23.11.2010, 19:44



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
well, if its just an old kernel version, then thats ok.
in the aptosid kernel, add
      Code:
i915.modeset=0
and see if that helps. if it does, we can write it into the grub config.
you can edit the grub2 kernel line by hitting e in the bootscreen. that takes you to the editor. add the stanza behind 'quiet'. then hit ctrl-x to boot it.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
IsraelOffline
Post subject:   PostPosted: 25.11.2010, 00:16



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
Hmmm.... I assumed you were talking about editing this in /boot/grub/menu.lst

I went to the /boot/grub/ directory and it wasn't there? I searched for hidden files to. Is this file called something else in Sidux?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 25.11.2010, 02:16



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
sidux is dead, aptosid alive.
grub-legacy had a menu.lst, grub2 has grub.cfg

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 25.11.2010, 02:22



Joined: 2010-08-25
Posts: 736

Status: Offline
...and grub.cfg must not be edited by hand, all configuration happens through /etc/default/grub (or /etc/grub.d//etc/grub.d/). If grub.cfg gets touched by hand, it won't be adapted upon subsequent kernel updates anymre, which would be fatal.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 25.11.2010, 08:15
Moderator


Joined: 2010-09-11
Posts: 468

Read this before start editing:
Aptosid manual: GRUB2
http://manual.aptosid.com/en/sys-admin- ... .htm#grub2
 
 View user's profile Send private message  
Reply with quote Back to top
IsraelOffline
Post subject:   PostPosted: 25.11.2010, 20:22



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
Ok since you've described this process as so delicate, where should I put "i915.modeset=0"

Here are the contents of my /etc/default/grub
      Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="vga=791"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Thanks!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 25.11.2010, 20:30
Moderator


Joined: 2010-09-11
Posts: 468

you should not edit grug.cfg manually. Read the manual!
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 25.11.2010, 20:35



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
first you try it out on the grub menue while booting. just add it to the line after quiet.
if it works you put it in GRUB_CMDLINE_LINUX_DEFAULT="quiet" (after quit,into the brackets that are there)

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
IsraelOffline
Post subject:   PostPosted: 25.11.2010, 20:53



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
      Quote:
you should not edit grug.cfg manually. Read the manual!


First off I didn't edit grub.conf manually. I just posted the contents of /etc/default/grub as I understood that was the file slh was talking about editing instead. I didn't touch a thing without asking though.

Secondly, I did read the link to the manual you sent me and decided to follow these instructions first:

      Quote:
Read this before start editing:
Aptosid manual: GRUB2
http://manual.aptosid.com/en/sys-admin- ... .htm#grub2


I followed those instructions to the letter and after the last reboot I now all I have is a screen that says this:

      Code:
GRUB loading
Welcome to GRUB!

error: file not found.
Entering rescue mode...
grub rescue>


Not only that I'm 500 miles from home for a holiday and left all my live-cd's at home. So yes, I read the manual and regret it dearly.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 25.11.2010, 21:30
Moderator


Joined: 2010-09-11
Posts: 468

      Israel wrote:
      Quote:
you should not edit grug.cfg manually. Read the manual!


First off I didn't edit grub.conf manually. I just posted the contents of /etc/default/grub as I understood that was the file slh was talking about editing instead. I didn't touch a thing without asking though.

Secondly, I did read the link to the manual you sent me and decided to follow these instructions first:


sorry, it was my mistake... I didn't not read your post carefully.
 
 View user's profile Send private message  
Reply with quote Back to top
IsraelOffline
Post subject:   PostPosted: 25.11.2010, 22:45



Joined: 2010-11-23
Posts: 11
Location: Hades
Status: Offline
Well sorry is nice, but how about helping me fix my machine now that I followed the instructions in your link and wrecked it.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio