Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
HennROffline
Post subject: How to configure AMD Radeon HD 4670 (r700)  PostPosted: 01.12.2010, 21:44



Joined: 2010-09-27
Posts: 55

Status: Offline
Hi there,

I have an AMD Radeon HD 4670 which has a r700 chipset on it.

I can't get good results neither for 2D nor for 3D performance.

I currently run the radeon xserver driver with firmware-linux installed but 2D sucks as much as 3D does.

The proprietary fglrx driver is currently not installable at all...


Does anyone has the same card and can give me hints on how to configure my system to get proper performance with this card?

Thanks in advance.
Henner
 
 View user's profile Send private message  
Reply with quote Back to top
ikeinthaiOffline
Post subject: should be nice.  PostPosted: 02.12.2010, 14:26



Joined: 2010-09-22
Posts: 119
Location: bigannastybkk
Status: Offline
i have a radeon 4670 and i'm really happy with the performance... think a nonagon with a different hd fullscreen video on each side, spinning on a full hd 32" monitor and another old vga monitor whenever i want it in whichever config, all with a few mouse clicks.

maybe start with infobash -v3.

sounds more like you did radeon.modeset=0 and you're still running off that driver without the firmware being properly installed.

if you speak german there are a couple regulars on the german forum with the same graphics card that would help you. they helped me when they used to frequent this forum.

ike.

ps you need firmware-linux-nonfree as well as firmware-linux-free (so nonfree repositories must be enabled): http://manual.aptosid.com/en/hw-dev-hw- ... -free-3d-2

      Code:
ike@moros:~$ dpkg --status firmware-linux-nonfree
Package: firmware-linux-nonfree
Status: install ok installed
Priority: optional
Section: non-free/kernel
Installed-Size: 952
Maintainer: Debian Kernel Team <debian>
Architecture: all
Source: firmware-nonfree
Version: 0.27
Replaces: firmware-linux (<< 0.19)
Suggests: initramfs-tools, linux-image
Conflicts: firmware-linux (<< 0.19)
Description: Binary firmware for various drivers in the Linux kernel
 This package contains the binary firmware for  various drivers in the
 Linux kernel.  This is a collection of firmware blobs which are not
 individually large enough to warrant a standalone package.
 .
 Contents:
  * 3Com Typhoon firmware, version 03.001.008 (3com/typhoon.bin)
  * AdvanSys ASC-3550 firmware (advansys/3550.bin)
  * AdvanSys ASC-38C0800 firmware (advansys/38C0800.bin)
  * AdvanSys ASC-38C1600 firmware (advansys/38C1600.bin)
  * AdvanSys SCSI controller microcode (advansys/mcode.bin)
  * Agere/Prism/Symbol Orinoco firmware (AP mode), version 9.48 Hermes I (agere_ap_fw.bin)
  * Agere/Prism/Symbol Orinoco firmware (STA mode), version 9.48 Hermes I (agere_sta_fw.bin)
  * Chelsio T3 optical EDC firmware (AEL2005 PHY) (cxgb3/ael2005_opt_edc.bin)
  * Chelsio T3 twinax EDC firmware (AEL2005 PHY) (cxgb3/ael2005_twx_edc.bin)
  * Chelsio T3 twinax EDC firmware (AEL2020 PHY) (cxgb3/ael2020_twx_edc.bin)
  * Chelsio T3B protocol engine firmware, version 1.1.0 (cxgb3/t3b_psram-1.1.0.bin)
  * Chelsio T3C protocol engine firmware, version 1.1.0 (cxgb3/t3c_psram-1.1.0.bin)
  * Chelsio T3 main firmware, version 7.4.0 (cxgb3/t3fw-7.4.0.bin)
  * DAB-USB FPGA bitfile (dabusb/bitstream.bin)
  * DAB-USB firmware (dabusb/firmware.fw)
  * Xceive 5000 tuner firmware, version 1.6.114 (dvb-fe-xc5000-1.6.114.fw)
  * DiBcom dib0700 USB DVB bridge firmware, version 1.20 (dvb-usb-dib0700-1.20.fw)
  * Intel 82559 D101M microcode (e100/d101m_ucode.bin)
  * Intel 82559 D101S microcode (e100/d101s_ucode.bin)
  * Intel 82551-F and 82551-10 microcode (e100/d102e_ucode.bin)
  * kaweth/new_code.bin
  * kaweth/new_code_fix.bin
  * kaweth/trigger_code.bin
  * kaweth/trigger_code_fix.bin
  * Matrox G200 WARP engine microcode (matrox/g200_warp.fw)
  * Matrox G400/G550 WARP engine microcode (matrox/g400_warp.fw)
  * Multi-Tech USB CDMA modem firmware (mts_cdma.fw)
  * Multi-Tech USB EDGE modem firmware (mts_edge.fw)
  * Multi-Tech USB GPRS modem firmware (mts_gsm.fw)
  * Rage 128 CCE microcode (r128/r128_cce.bin)
  * Radeon HD 5400-family ME microcode (radeon/CEDAR_me.bin)
  * Radeon HD 5400-family PFP microcode (radeon/CEDAR_pfp.bin)
  * Radeon HD 5400-family RLC microcode (radeon/CEDAR_rlc.bin)
  * Radeon HD 5800/5900-family ME microcode (radeon/CYPRESS_me.bin)
  * Radeon HD 5800/5900-family PFP microcode (radeon/CYPRESS_pfp.bin)
  * Radeon HD 5800/5900-family RLC microcode (radeon/CYPRESS_rlc.bin)
  * Radeon HD 5700-family ME microcode (radeon/JUNIPER_me.bin)
  * Radeon HD 5700-family PFP microcode (radeon/JUNIPER_pfp.bin)
  * Radeon HD 5700-family RLC microcode (radeon/JUNIPER_rlc.bin)
  * Radeon R100-family CP microcode (radeon/R100_cp.bin)
  * Radeon R200-family CP microcode (radeon/R200_cp.bin)
  * Radeon R300-family CP microcode (radeon/R300_cp.bin)
  * Radeon R400-family CP microcode (radeon/R420_cp.bin)
  * Radeon R500-family CP microcode (radeon/R520_cp.bin)
  * Radeon R600 ME microcode (radeon/R600_me.bin)
  * Radeon R600 PFP microcode (radeon/R600_pfp.bin)
  * Radeon R600-family RLC microcode (radeon/R600_rlc.bin)
  * Radeon R700-family RLC microcode (radeon/R700_rlc.bin)
  * Radeon HD 5500/5600-family ME microcode (radeon/REDWOOD_me.bin)
  * Radeon HD 5500/5600-family PFP microcode (radeon/REDWOOD_pfp.bin)
  * Radeon HD 5500/5600-family RLC microcode (radeon/REDWOOD_rlc.bin)
  * Radeon RS600 CP microcode (radeon/RS600_cp.bin)
  * Radeon RS690 CP microcode (radeon/RS690_cp.bin)
  * Radeon RS780 ME microcode (radeon/RS780_me.bin)
  * Radeon RS780 PFP microcode (radeon/RS780_pfp.bin)
  * Radeon RV610 ME microcode (radeon/RV610_me.bin)
  * Radeon RV610 PFP microcode (radeon/RV610_pfp.bin)
  * Radeon RV620 ME microcode (radeon/RV620_me.bin)
  * Radeon RV620 PFP microcode (radeon/RV620_pfp.bin)
  * Radeon RV630 ME microcode (radeon/RV630_me.bin)
  * Radeon RV630 PFP microcode (radeon/RV630_pfp.bin)
  * Radeon RV635 ME microcode (radeon/RV635_me.bin)
  * Radeon RV635 PFP microcode (radeon/RV635_pfp.bin)
  * Radeon RV670 ME microcode (radeon/RV670_me.bin)
  * Radeon RV670 PFP microcode (radeon/RV670_pfp.bin)
  * Radeon RV710 ME microcode (radeon/RV710_me.bin)
  * Radeon RV710 PFP microcode (radeon/RV710_pfp.bin)
  * Radeon RV730 ME microcode (radeon/RV730_me.bin)
  * Radeon RV730 PFP microcode (radeon/RV730_pfp.bin)
  * Radeon RV770 ME microcode (radeon/RV770_me.bin)
  * Radeon RV770 PFP microcode (radeon/RV770_pfp.bin)
  * Tehuti network card firmware (tehuti/bdx.bin)
  * Broadcom BCM5703/BCM5704 TSO firmware (tigon/tg3_tso.bin)
  * Broadcom BCM5701A0 firmware (tigon/tg3.bin)
  * Broadcom BCM5705 TSO firmware (tigon/tg3_tso5.bin)
Homepage: http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git
ike@moros:~$

_________________
aptosid: magic in action, the point of the spear. bleedin pearls before swine? lets hope not. freesoftware/freedomsoftware=a chance at freedom. participants, engage your vehicle. . . avatar by zenren
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 02.12.2010, 17:59



Joined: 2010-09-27
Posts: 55

Status: Offline
Hi ike,

I have the nonfree firmware installed (in version 0.27 as you have) and I have modeset=1 set for the radeon driver as well:

      Code:
# cat /etc/modprobe.d/radeon-kms.conf
options radeon modeset=1


Did you change anything else? I really run out of ideas.

Ah, here's my infobash output:


      Code:
$ infobash -v3
Host/Kernel/OS  "workstation" running Linux 2.6.36-1.slh.2-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - xfce - (201009132215) ]
Videocard       ATI RV730XT [Radeon HD 4670]  X.Org 1.9.2  [ 1680x1050@0.0hz ]
Network cards   VIA VT6102 [Rhine-II]
Processes GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v3.34


Pleas note that I run the radeonhd driver currently which is responsible for the software rendering. SR gives me much better results than the hardware "accelerated" stuff that radeon tries to give me.
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 03.12.2010, 16:11
Team Member


Joined: 2010-08-26
Posts: 247

Status: Offline
radeonhd is essentially dead and not compatible with kernel mode setting. It is exactly 1 year today since there was a real change to the Debian package (1.3.0-1 uploaded to experimental, 1.3.0-2 was uploaded to sid with minor changes on the 8th of January). 15th May was the last change, again minor, when 1.3.0-3 was uploaded and it's changelog points to 575226 if you really want to read a little more about the (in)sanity of using radeonhd now.
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 17:04



Joined: 2010-09-27
Posts: 55

Status: Offline
Hi bfree,

I know that radeonhd is not developed any longer.

Anyhow, as I said it "enables" SR which works better than broken hardware acceleration for me.

If anybody has hints regarding the setup of the radeon driver I am still very interested because I can't run any 3D stuff ATM.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject:   PostPosted: 03.12.2010, 17:15



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Online!
Without a look at /var/log/Xorg.0.log wit radeon as driver, no one kan help you!
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 18:03



Joined: 2010-09-27
Posts: 55

Status: Offline
Hi towo,

please find my xorg log with only xserver-xorg-video-radeon (without xserver-xorg-video-ati) installed attached.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject:   PostPosted: 03.12.2010, 18:09



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Online!
remove vga=791 from /etc/default/grub
update-grub
reboot
be happy
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 18:10



Joined: 2010-09-27
Posts: 55

Status: Offline
I attached another log with xserver-xorg-video-ati and xserver-xorg-video-radeon installed.
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 18:18



Joined: 2010-09-27
Posts: 55

Status: Offline
      towo wrote:
remove vga=791 from /etc/default/grub
update-grub
reboot
be happy


Nope, I'm not happy Sad

Installing or uninstalling xserver-xorg-video-ati has no effect btw.
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 18:19



Joined: 2010-09-27
Posts: 55

Status: Offline
My entries in grub.cfg look like this now:

menuentry 'Debian GNU/Linux, with Linux 2.6.36-1.slh.2-aptosid-amd64' --class debian --class gnu-linux --class gnu --class os {
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set a4a1b182-193f-420f-9c68-c6dd7c79a8ec
echo 'Loading Linux 2.6.36-1.slh.2-aptosid-amd64 ...'
linux /vmlinuz-2.6.36-1.slh.2-aptosid-amd64 root=UUID=c08d8e29-e988-4181-844c-0938d750a2b3 ro quiet
echo 'Loading initial ramdisk ...'
initrd /initrd.img-2.6.36-1.slh.2-aptosid-amd64
}
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject:   PostPosted: 03.12.2010, 18:31



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Online!
Same game as before, show your Xorg.0.log.
And btw, it's easyer for us, if you do
aptosid-paste /var/log/X0rg.0.log
and post the resulting link, instead of upload the log as archive.
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 18:56



Joined: 2010-09-27
Posts: 55

Status: Offline
OK, here my log without xserver-xorg-video-ati installed:

http://pastebin.ca/2009836
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject:   PostPosted: 03.12.2010, 19:01



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Online!
Why you remove xserver-xorg-video-ati at all?
Install it and xserver-xorg-video-radeon too.
 
 View user's profile Send private message  
Reply with quote Back to top
HennROffline
Post subject:   PostPosted: 03.12.2010, 19:20



Joined: 2010-09-27
Posts: 55

Status: Offline
Bacause these both do not depend on each other.

Anyway, I will do so and reboot.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio