Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ibgbOffline
Post subject:   PostPosted: 03.12.2010, 18:35



Joined: 2010-09-11
Posts: 42

Status: Offline
Isn't full-upgrade an aptitude only command?
(it sure isn't referenced in man apt-get and it confuses apt-get if you use it as an argument)
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 03.12.2010, 20:42



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
it is. http://qt-kde.debian.net recommends aptitude, as those guys all use it.
you can just use apt-get and dist-upgeade instead.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 04.12.2010, 09:42



Joined: 2010-09-11
Posts: 183

Status: Offline
full-upgrade for in aptitude what dist-upgrade is for apt-get. So when using apt-get (which is the recommended tool in aptosid) dist-upgrade is right.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 04.12.2010, 12:36
Moderator


Joined: 2010-09-11
Posts: 468

full-upgrade is a command of aptitude. apt-get has dist-upgrade. see "man apt-get"
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 09.12.2010, 21:23



Joined: 2010-09-13
Posts: 293

Status: Offline
The qt-kde.debian.net is empty now. Therefore the packages should have been moved to experimental.

sid is moving again Smile
 
 View user's profile Send private message  
Reply with quote Back to top
kris99Offline
Post subject:   PostPosted: 10.12.2010, 12:12



Joined: 2010-09-11
Posts: 21

Status: Offline
      snvv wrote:
The qt-kde.debian.net is empty now. Therefore the packages should have been moved to experimental.

sid is moving again Smile


Question Question Question

No change since 26-Nov-2010. The files are still there.
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 10.12.2010, 12:41
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
      kris99 wrote:
No change since 26-Nov-2010. The files are still there.
Correct, and they have not been uploaded to Debian experimental - so, the entire post is a misinformation.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 10.12.2010, 13:34



Joined: 2010-09-13
Posts: 293

Status: Offline
Sorry about this.
I tried to upgrade an other machine but the apt-get was empty.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 10.12.2010, 20:53



Joined: 2010-09-11
Posts: 183

Status: Offline
Hello,

I have found a crash in the KDE4.5.x installation: When switching to the desktop-grid effect (Ctrl+FCool and returning from it very fast via Esc, kwin did crash. I could reproduce it multiple times. Sometimes it requires many tries, but it crashes from time to time.

A bug report for this already exists (sorry, I do not have the number at hand) and it is marked fixed. The fix will be in KDE 4.6, but may be backported to the November 4.5.x version. Maybe this already is fixed with installing qt4.7.1.

Qt4.7.1 is in experimental. Did someone try to install it together with KDE 4.5.x? Does it work fine, maybe better than 4.6? Is there a howto somewhere to install it? (The most simple way might be to manually collect all installed qt4.6 packages and upgrade them?)

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 10.12.2010, 20:54



Joined: 2010-09-11
Posts: 183

Status: Offline
Oops, Strg+F8 together with the bracket generates a smilie Cool
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 12.12.2010, 16:42



Joined: 2010-09-11
Posts: 183

Status: Offline
Ok, I did read one comment incorrectly. The bug is not fixed in qt4.7.1 but in KDE4.6 and 4.5.4.
https://bugs.kde.org/show_bug.cgi?id=244813

But anyway: I tried to install the experimental qt4.7.1. So far nearly everything seems to work. But with qt4.7.1 there exists the bug that a digikam process keeps running after exiting digikam. So better do not try qt4.7.1 yet.
 
 View user's profile Send private message  
Reply with quote Back to top
Mte90Offline
Post subject:   PostPosted: 15.02.2011, 17:35



Joined: 2010-09-14
Posts: 51
Location: Rieti
Status: Offline
i have a problem when i try to compile a program because i need kdelisb5-dev but when i try to install i get this:
      Code:

root@aptosidbox:/home/mte90/Desktop# apt-get install kdelibs5-dev
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
kdelibs5-dev è già alla versione più recente.
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kdelibs5-dev : Dipende: libkde3support4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdecore5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdeui5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkio5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkpty4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdesu5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkjsapi4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkjsembed4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkntlm4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libsolid4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkfile4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknewstuff2-4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknewstuff3-4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkparts4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkutils4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libthreadweaver4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkhtml5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkimproxy4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkmediaplayer4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libktexteditor4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknotifyconfig4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdnssd4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkrosscore4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkrossui4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libnepomuk4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libnepomukquery4a (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libplasma3 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkunitconversion4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdewebkit5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: kdoctools (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: kdelibs-bin (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

i use kde 4.5 of this repo.
Any Ideas?

_________________
I'm an italian Aptosid user!!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 15.02.2011, 17:53



Joined: 2010-09-11
Posts: 183

Status: Offline
What does "apt-cache policy kdelibs5-dev" tell you?

If I understand the output correctly, you want to install the 4.5.x version of this dev package, but all other KDE-packages are 4.4.5? Do you have KDE 4.4 or 4.5 installed?
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 15.02.2011, 18:53



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
btw: LANG=C apt-get install kdelibs5-dev will produce an english output.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
Mte90Offline
Post subject:   PostPosted: 15.02.2011, 19:46



Joined: 2010-09-14
Posts: 51
Location: Rieti
Status: Offline
      Code:

mte90@aptosidbox:~/Desktop/Websecurify 0.8$ LANG=C apt-cache policy kdelibs5-dev
kdelibs5-dev:
  Installed: (none)
  Candidate: 4:4.4.5-3
  Version table:
     4:4.5.3-0r1 0
        100 http://qt-kde.debian.net/debian/ experimental-snapshots/main amd64 Packages
     4:4.4.5-3 0
        500 http://ftp.it.debian.org/debian/ sid/main amd64 Packages


      Code:
root@aptosidbox:/home/mte90/.local/share/Trash/files/Websecurify 0.8# LANG=C apt-get install kdelibs5-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdelibs5-dev : Depends: libkde3support4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdecore5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdeui5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkio5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkpty4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdesu5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsapi4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsembed4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkntlm4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libsolid4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkfile4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff2-4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff3-4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkparts4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkutils4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libthreadweaver4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkhtml5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkimproxy4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkmediaplayer4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libktexteditor4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknotifyconfig4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdnssd4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkrosscore4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkrossui4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libnepomuk4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libnepomukquery4a (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libplasma3 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkunitconversion4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdewebkit5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: kdoctools (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: kdelibs-bin (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
E: Broken packages

I have the kde 4.5 on my system but i need the package kdelibs5-dev for compile software but isn't installable.

_________________
I'm an italian Aptosid user!!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio