Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LatOffline
Post subject: *edit* new rar wants ia32-libs  PostPosted: 12.12.2010, 12:28



Joined: 2010-09-19
Posts: 168

Status: Offline
Why I am getting i386 libs?
      Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  ia32-libs lib32asound2 lib32bz2-1.0 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32v4l-0 lib32z1 libc6-i386
The following packages will be upgraded:
  apt-listchanges firmware-linux-free gtk2-engines-qtcurve kde-style-qtcurve kwin-style-qtcurve libneon27
  libneon27-gnutls linux-libc-dev qtcurve rar
10 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/42.1 MB of archives.
After this operation, 97.6 MB of additional disk space will be used.
Download complete and in download only mode


and how come they are not going to be installed in another machine?

      Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  apt-listchanges firmware-linux-free gtk2-engines-qtcurve kde-style-qtcurve kwin-style-qtcurve libneon27-gnutls
  libsdl-mixer1.2 linux-libc-dev qtcurve unrar
10 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,249 kB of archives.
After this operation, 69.6 kB of additional disk space will be used.
Download complete and in download only mode


Both installs are 64bits
Thank you


Last edited by Lat on 12.12.2010, 12:48; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: ia32-libs wants to be installed  PostPosted: 12.12.2010, 12:42



Joined: 2010-09-19
Posts: 168

Status: Offline
oh, I see now:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=602266

Is there an apt command to find out which package wanted ia32-libs?

To figure it out I used:
      Code:
apt-get install -s  apt-listchanges firmware-linux-free gtk2-engines-qtcurve kde-style-qtcurve kwin-style-qtcurve libneon27   libneon27-gnutls linux-libc-dev qtcurve rar |grep 32
and eliminating package by package was the only solution I could think of. I was lucky the first one was the one with the problem
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: ia32-libs wants to be installed  PostPosted: 12.12.2010, 17:43
Moderator


Joined: 2010-09-11
Posts: 468

eliminating packages half by half, is theoretically/matimatically faster than one by one. Smile

or, there can be script to search "ia32" from the result of apt-cache show of each packages...
(i'm not good at shell script, if I need to, I'd write in awk...)
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: ia32-libs wants to be installed  PostPosted: 12.12.2010, 17:52
Moderator


Joined: 2010-09-11
Posts: 468

quick and dirty awk command:

      Code:

apt-cache show apt-listchanges firmware-linux-free gtk2-engines-qtcurve kde-style-qtcurve \
kwin-style-qtcurve libneon27 libneon27-gnutls linux-libc-dev qtcurve rar \
| awk  '/Package/ { p = $2; } /ia32/ { print p "\n" $0 }'
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: ia32-libs wants to be installed  PostPosted: 18.12.2010, 03:30



Joined: 2010-09-19
Posts: 168

Status: Offline
That works. Thank you muchan
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio