Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
snvvOffline
Post subject: How to compile KGraphViewer and KGraphEditor?  PostPosted: 17.12.2010, 12:03



Joined: 2010-09-13
Posts: 293

Status: Offline
I tried to compile KGraphViewer and KGraphEditor
http://kde-apps.org/content/show.php/KG ... tent=23999

I used git to get the files and then I trid the suggested command

cmake -DCMAKE_INSTALL_PREFIX=$KDEDIR /home/snvv/kgraph/kgraphviewer/

      Code:
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /home/snvv/.kde/share/apps;/usr/share/aptosid-settings-kde/kde4/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
  CMakeLists.txt:7 (find_package)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!


What I have done wrong?
Thank you
snvv
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: How to compile KGraphViewer and KGraphEditor?  PostPosted: 17.12.2010, 20:16



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
is cmake-data installed?

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 17.12.2010, 22:16



Joined: 2010-09-13
Posts: 293

Status: Offline
Yes it is.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 17.12.2010, 23:40



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
kdelibs5-dev also?

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 18.12.2010, 03:27



Joined: 2010-09-13
Posts: 293

Status: Offline
No it is not and can not be installed

      Code:
apt-get install kdelibs5-dev                                                                                                         
Reading package lists... Done                                                                                                                                   
Building dependency tree                                                                                                                                         
Reading state information... Done                                                                                                                               
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdelibs5-dev : Depends: libkde3support4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkdecore5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkdeui5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkio5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkpty4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkdesu5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsapi4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsembed4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkntlm4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libsolid4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkfile4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff2-4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff3-4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkparts4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkutils4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libthreadweaver4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkhtml5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkimproxy4 (= 4:4.4.5-2) but it is not going to be installed
                Depends: libkmediaplayer4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libktexteditor4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libknotifyconfig4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkdnssd4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkrosscore4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkrossui4 (= 4:4.4.5-2) but it is not going to be installed
                Depends: libnepomuk4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libnepomukquery4a (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libplasma3 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkunitconversion4 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: libkdewebkit5 (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: kdoctools (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
                Depends: kdelibs-bin (= 4:4.4.5-2) but 4:4.5.3-0r1 is to be installed
E: Broken packages


Regards
snvv
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 18.12.2010, 07:22



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
you will need kde 4.5.3 then.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 05.01.2011, 03:11



Joined: 2010-09-13
Posts: 293

Status: Offline
Ok I tried with a normal 4.4.5 KDE version and here is what it gives:


      Code:
snvv@aptosidbox:~/builddir$ cmake -DCMAKE_INSTALL_PREFIX=$KDEDIR /home/snvv/builddir/kgraphviewer/
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Phonon Version: 4.4.2
-- Found Phonon: /usr/lib/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.4 include dir: /usr/include
-- Found KDE 4.4 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
  Could NOT find ZLIB (missing: ZLIB_INCLUDE_DIR ZLIB_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindZLIB.cmake:47 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:12 (find_package)


-- Configuring incomplete, errors occurred!


What could be missed in this case?
Thank you
snvv
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio