Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
SordonOffline
15 Post subject: Backlight problem with 2.6.37 and Intel graphic cards  PostPosted: 10.01.2011, 15:50



Joined: 2010-09-13
Posts: 55

Status: Offline
There is currently a problem with the backlight on notebooks using an Intel graphic card and the new kernel 2.6.37.
It can happen that the display switches to the lowest possible setting and can't be restored to a brighter setting again (by using Fn function keys). More information in this bug report:
https://bugzilla.kernel.org/show_bug.cgi?id=22672

Best Regards,
Sordon

PS: On my notebook (Dell D620) this bug is unfortunately there and I'm waiting for a fix.


Last edited by Sordon on 14.01.2011, 21:15; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
dpdt1Offline
Post subject: RE: Backlight problem with 2.6.37 and Intel graphic cards  PostPosted: 10.01.2011, 20:52



Joined: 2010-09-27
Posts: 48

Status: Offline
i dont have any serious problems with this, except for these boot messages :

kernel: [ 6.843327] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.

this appeared after first 2.6.37 aptosid kernel. same error with next one.

# infobash -v
Host/Kernel/OS "freedom" running Linux 2.6.37-0.slh.2-aptosid-amd64 x86_64 [ Debian GNU/Linux 6.0 ]
CPU Info (1) Intel Core2 Duo T7250 @ clocked at [ 800.000 MHz ]
(2) Intel Core2 Duo T7250 @ clocked at [ 2001.000 MHz ]
Videocard Intel Mobile GM965/GL960 Integrated Graphics Controller X.Org 1.7.7 [ 1280x800@60.0hz ]
Processes 138 | Uptime 17min | Memory 751.6/3014.0MB | HDD Size 1250GB (80%used) | Client Shell | Infobash v3.34

_________________
# apt-get remove frontiers
 
 View user's profile Send private message  
Reply with quote Back to top
qordOffline
Post subject: Re: Backlight problem with 2.6.37 and Intel graphic cards  PostPosted: 12.01.2011, 18:00



Joined: 2010-12-14
Posts: 7

Status: Offline
      Sordon wrote:
There is currently a problem with the backlight on notebooks using an Intel graphic card and the new kernel 2.6.37.
It can happen that the display switches to the lowest possible setting and can't be restored to a brighter setting again (by using Fn function keys). More information in this bug report:
https://bugzilla.kernel.org/show_bug.cgi?id=22672
.


The bug is also present on my Samsung N220... using .36 for the time being.

-cord
 
 View user's profile Send private message  
Reply with quote Back to top
timrichardsonOffline
Post subject: RE: Re: Backlight problem with 2.6.37 and Intel graphic card  PostPosted: 13.01.2011, 01:02



Joined: 2010-09-12
Posts: 66
Location: Melbourne
Status: Offline
2.6.37-0.shl.4 arrived in the repositories today (13 Jan). I guess it's the fourth 2.6.37 kernel although it's the third one I've noticed.
Are you referring to this kernel, or are you having problems with all 2.6.37 kernels.

_________________
There are some who call me Tim
 
 View user's profile Send private message Visit poster's website Yahoo Messenger  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 13.01.2011, 18:11



Joined: 2010-09-13
Posts: 55

Status: Offline
Looking at the changelog it seems to be that with kernel 2.6.37-0.slh.5 the problem is fixed. Thanks slh
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 13.01.2011, 20:46



Joined: 2010-08-25
Posts: 749

Status: Offline
2.6.37-0.slh.5-aptosid-{686,amd64} might indeed help with this issue. Unfortunately my i830, i945GME and i945GZ chipsets are not affected by this, which makes debugging almost impossible.
 
 View user's profile Send private message  
Reply with quote Back to top
sx9Offline
Post subject:   PostPosted: 13.01.2011, 20:53



Joined: 2010-09-12
Posts: 219
Location: Wiesbaden,Germany
Status: Offline
      Quote:

Unfortunately my i830, i945GME and i945GZ chipsets are not affected by this, which makes debugging almost impossible.


whoa! Have you also made (inofficial) kernels for those architectures?

_________________
My new self-made computer:
Intel Core i7-2600k
ASUS Maximus IV Gene-Z (Mainboard)
2x4GB DDR3 RAM
ATI Radeon HD 6770
OCZ Vertex 3 60GB (SSD)
Western Digital Caviar Green WD20EARX 2TB (HDD)
...
aptosid x86_64
 
 View user's profile Send private message Send e-mail Yahoo Messenger  
Reply with quote Back to top
qordOffline
Post subject:   PostPosted: 14.01.2011, 11:57



Joined: 2010-12-14
Posts: 7

Status: Offline
      slh wrote:
2.6.37-0.slh.5-aptosid-{686,amd64} might indeed help with this issue. Unfortunately my i830, i945GME and i945GZ chipsets are not affected by this, which makes debugging almost impossible.


I'll check with my netbook (apparently with Intel GMA 3150 chipset) and the newest kernel this weekend...

-cord
 
 View user's profile Send private message  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 14.01.2011, 21:14



Joined: 2010-09-13
Posts: 55

Status: Offline
I installed kernel 2.6.37-0.slh.6 and the problem is solved Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
dpdt1Offline
Post subject:   PostPosted: 16.01.2011, 17:01



Joined: 2010-09-27
Posts: 48

Status: Offline
i still get those messages on boot :
      Quote:
Jan 16 15:01:37 freedom kernel: [ 6.683358] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.


and i dont know if it is related, but system doesn't shutdown properly ever since the 2.6.37 kernel. at first it was a few times, but now this is default behaviour.
after the
      Quote:
will now halt

message, system freezes.

infobash -v :
      Quote:
# infobash -v
Host/Kernel/OS "freedom" running Linux 2.6.37-0.slh.6-aptosid-amd64 x86_64 [ Debian GNU/Linux 6.0 ]
CPU Info (1) Intel Core2 Duo T7250 @ clocked at [ 2001.000 MHz ]
(2) Intel Core2 Duo T7250 @ clocked at [ 2001.000 MHz ]
Videocard Intel Mobile GM965/GL960 Integrated Graphics Controller X.Org 1.7.7 [ 1280x800@60.0hz ]
Processes 137 | Uptime 4:01 | Memory 928.4/3014.0MB | HDD Size 250GB (71%used) | Client Shell | Infobash v3.34
 
 View user's profile Send private message  
Reply with quote Back to top
qordOffline
Post subject:   PostPosted: 17.01.2011, 21:12



Joined: 2010-12-14
Posts: 7

Status: Offline
      qord wrote:
      slh wrote:
2.6.37-0.slh.5-aptosid-{686,amd64} might indeed help with this issue. Unfortunately my i830, i945GME and i945GZ chipsets are not affected by this, which makes debugging almost impossible.


I'll check with my netbook (apparently with Intel GMA 3150 chipset) and the newest kernel this weekend...


It's fixed with the new kernel Smile

-cord
 
 View user's profile Send private message  
Reply with quote Back to top
zentOffline
Post subject:   PostPosted: 30.01.2011, 18:11



Joined: 2011-01-30
Posts: 3

Status: Offline
Hey! new here Smile

Im experiencing the same issue, and not solved for me Sad (with slh.14)......
anyone experiencig the same?!!?

-Sorry for my english. Smile

      Code:
Host/Kernel/OS  "aptonet" running Linux 2.6.37-0.slh.14-aptosid-686 i686 [ aptosid 2010-03 Ἀπάτη - kde-lite - (201012262151) ]
CPU Info        (1) Intel Core2 Duo T5670 @ clocked at [ 1800.000 MHz ]
                (2) Intel Core2 Duo T5670 @ clocked at [ 1801.000 MHz ]
Videocard       Intel Mobile 4 Series Chipset Integrated Graphics Controller  X.Org 1.7.7  [ 1280x800@60.0hz ]
Processes 135 | Uptime 1:22 | Memory 1295.3/1991.8MB | HDD Size 160GB (61%used) | Client Shell | Infobash v3.34
 
 View user's profile Send private message  
Reply with quote Back to top
zentOffline
Post subject: more info  PostPosted: 31.01.2011, 17:09



Joined: 2011-01-30
Posts: 3

Status: Offline
more info...
Still having same problem with slh.15 Sad.
and after looking the system logs i found more 'errors' that i think must be related...2011-01-
      Code:
kernel   [ 3331.440501] [drm:i915_gem_object_bind_to_gtt] *ERROR* Attempting to bind a purgeable object

and
      Code:
kernel   [ 3439.651214] [drm:i915_gem_mmap_gtt_ioctl] *ERROR* Attempting to mmap a purgeable buffer

anyone experiencing the same????
thanks in advance and sorry for my english Smile
 
 View user's profile Send private message  
Reply with quote Back to top
saskwatchOffline
Post subject:   PostPosted: 31.01.2011, 17:52



Joined: 2011-01-09
Posts: 2
Location: Regina, Canada
Status: Offline
2.6.37-0.slh.14-aptosid-amd64 has this bug on my dual core
Acer Aspire dual core 1410-2817:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Device 029b
Flags: bus master, fast devsel, latency 0, IRQ 42
Memory at 90000000 (64-bit, non-prefetchable) [size=4M]
Memory at 80000000 (64-bit, prefetchable) [size=256M]
I/O ports at 30d0 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 3
Kernel driver in use: i915

falling back to using 2.6.37-0.slh.11-aptosid-amd64 until
greater minds than mine have this sorted out.
Surprised
 
 View user's profile Send private message  
Reply with quote Back to top
alexfOffline
Post subject:   PostPosted: 04.02.2011, 06:58



Joined: 2011-02-01
Posts: 2

Status: Offline
Hi.

I got now this problem after upgrade today to Linux 2.6.37-0.slh.18-aptosid-amd64.
I can now choose maximum or lowest display brightness on my laptop.

Host/Kernel/OS "butterfly" running Linux 2.6.37-0.slh.18-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info Intel Core2 Solo U3500 @ clocked at [ 1400.000 MHz ]
Videocard Intel Mobile 4 Series Chipset Integrated Graphics Controller X.Org 1.7.7 [ 1366x768@60.0hz ]

Thank you.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio