Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
cge-nogoOffline
Post subject: kernel 2.6.35 and nic e1000e - no link  PostPosted: 14.09.2010, 06:25



Joined: 2010-09-12
Posts: 8

Status: Offline
Hey,
nice to see development continue with a new name. But I got a problem after du with the new kernel 2.6.35.

My network interface eth0 got no link anymore. Ceni reconfiguration doesn't help, but wireless is runnig without problems.

Any suggestions?

dmesg
=====
Sep 14 07:54:29 kernel: [ 1.046346] e1000e: Intel(R) PRO/1000 Network Driver - 1.0.2-k4
Sep 14 07:54:29 kernel: [ 1.046350] e1000e: Copyright (c) 1999 - 2009 Intel Corporation.
Sep 14 07:54:29 kernel: [ 1.046381] e1000e 0000:00:19.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Sep 14 07:54:29 kernel: [ 1.046392] e1000e 0000:00:19.0: setting latency timer to 64
Sep 14 07:54:29 kernel: [ 1.046487] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
Sep 14 07:54:29 kernel: [ 1.316406] e1000e 0000:00:19.0: eth0: (PCI Express:2.5GB/s:Width x1)
Sep 14 07:54:29 kernel: [ 1.316409] e1000e 0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
Sep 14 07:54:29 kernel: [ 1.316429] e1000e 0000:00:19.0: eth0: MAC: 6, PHY: 6, PBA No: ffffff-0ff
Sep 14 07:54:29 kernel: [ 10.289269] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
Sep 14 07:54:29 kernel: [ 10.340136] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X

syslog
======
Sep 14 07:54:29 kernel: [ 10.340463] ADDRCONF(NETDEV_UP): eth0: link is not ready
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 14.09.2010, 13:45



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
I cannot reproduce the problem with my e1000:


      Code:
dibl@sidbox:~$ dmesg | grep e1000
[    0.434218] e1000e: Intel(R) PRO/1000 Network Driver - 1.0.2-k4
[    0.434220] e1000e: Copyright (c) 1999 - 2009 Intel Corporation.
[    0.434235] e1000e 0000:03:00.0: Disabling ASPM  L1
[    0.434250] e1000e 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    0.434265] e1000e 0000:03:00.0: setting latency timer to 64
[    0.434430] e1000e 0000:03:00.0: irq 43 for MSI/MSI-X
[    0.434594] e1000e 0000:03:00.0: Disabling ASPM L0s
[    0.518375] e1000e 0000:03:00.0: eth0: (PCI Express:2.5GB/s:Width x1) 00:1c:c0:1f:54:35
[    0.518377] e1000e 0000:03:00.0: eth0: Intel(R) PRO/1000 Network Connection
[    0.518446] e1000e 0000:03:00.0: eth0: MAC: 2, PHY: 2, PBA No: ffffff-0ff
[   10.815244] e1000e 0000:03:00.0: irq 43 for MSI/MSI-X
[   10.866111] e1000e 0000:03:00.0: irq 43 for MSI/MSI-X
[   13.419974] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX


      Code:
root@sidbox:/var/log# cat /var/log/syslog | grep eth0
.
.
.
Sep 14 13:37:29 sidbox kernel: [   13.419974] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Sep 14 13:37:29 sidbox kernel: [   13.420364] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
.
.
.

My system (d-u this morning):

      Code:
dibl@sidbox:~$ infobash -v3
Host/Kernel/OS  "sidbox" running Linux 2.6.35-4.slh.9-aptosid-amd64 x86_64 [ sidux 2009-03 Μώμος - kde-lite - (200911110039) ]
CPU Info        (1) Intel Core2 X6800 @ 4096 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2926.000 MHz ]                         
                (2) Intel Core2 X6800 @ 4096 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 1596.000 MHz ]                         
Videocard       nVidia GT200 [GeForce GTX 260]  X.Org 1.7.7  [ 1600x1200@50.0hz ]                                                   
Network cards   Intel 82573L Gigabit                                                                                                 
Processes 147 | Uptime 8min | Memory 516.0/3964.8MB | HDD WDC WD1002FBYS-0,WDC WD7500AAKS-0,WDC WD1500AHFD-0 Size 1900GB (47%used) | GLX Renderer GeForce GTX 260/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 256.44 | Client Shell | Infobash v3.34
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 14.09.2010, 14:49



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Does Ceni see it? Why not reconfigure it with Ceni to see if it works
 
 View user's profile Send private message  
Reply with quote Back to top
cge-nogoOffline
Post subject:   PostPosted: 15.09.2010, 05:53



Joined: 2010-09-12
Posts: 8

Status: Offline
I tried reconfiguration with ceni and it recognize the interface. So I can setup a static ip address, but still no link (eth0: link is not ready). Pinging the interface works but no other network device. This is clear because there is no link to the switch. Its like a deactivated interface.
 
 View user's profile Send private message  
Reply with quote Back to top
michaaa62Offline
Post subject:   PostPosted: 15.09.2010, 06:24



Joined: 2010-09-11
Posts: 54
Location: Berlin, Germany
Status: Offline
May be you need firmware-linux or even firmware-linux-nonfree installed to make this nic work?!
Sorry i do not remember exactly how i got this working on one of my previous notebooks Embarassed
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 15.09.2010, 11:10



Joined: 2010-08-25
Posts: 766

Status: Offline
Intel e1000/ e1000e (in contrast to e100!) network cards don't require any loadable firmware, furthermore e1000 (PCI cards) and e1000e (PCIe core) drivers differ quite a lot and should not be mixed up.

Regarding the actual problem, I unfortunately can't help a whole lot, as I don't see any corresponding reports upstream nor can test it myself (only Intel 82541GI, e1000 here - working fine). A look through the complete dmesg output for unrelated (perhaps ACPI or MSI) messages might give further insight.
 
 View user's profile Send private message  
Reply with quote Back to top
birdie
Post subject:   PostPosted: 15.09.2010, 12:04



Joined: 2010-09-15
Posts: 23

Try
# rmmod e1000e
# modrpobe e1000e

BTW, do you have full duplex 1000Mbit?
 
 View user's profile Send private message  
Reply with quote Back to top
cge-nogoOffline
Post subject:   PostPosted: 15.09.2010, 16:15



Joined: 2010-09-12
Posts: 8

Status: Offline
      birdie wrote:
Try
# rmmod e1000e
# modrpobe e1000e

BTW, do you have full duplex 1000Mbit?


Okay tried it, but still the same.

Kernel 2.3.35-9
      Code:
syslog
======
kernel:  e1000e: Intel(R) PRO/1000 Network Driver - 1.0.2-k4
kernel:  e1000e: Copyright (c) 1999 - 2009 Intel Corporation.
kernel:  e1000e 0000:00:19.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
kernel:  e1000e 0000:00:19.0: setting latency timer to 64
kernel:  e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
kernel:  e1000e 0000:00:19.0: eth0: (PCI Express:2.5GB/s:Width x1)
kernel:  e1000e 0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
kernel:  e1000e 0000:00:19.0: eth0: MAC: 6, PHY: 6, PBA No: ffffff-0ff
kernel:  e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
kernel:  e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
kernel:  ADDRCONF(NETDEV_UP): eth0: link is not ready

ethtool
=======
Settings for eth0:
   Supported ports: [ TP ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Advertised pause frame use: No
   Advertised auto-negotiation: Yes
   Speed: Unknown!
   Duplex: Unknown! (255)
   Port: Twisted Pair
   PHYAD: 1
   Transceiver: internal
   Auto-negotiation: on
   MDI-X: Unknown
   Supports Wake-on: pumbag
   Wake-on: g
   Current message level: 0x00000001 (1)
   Link detected: no


Yeah I have full duplex 1000MBit with with Kernel 2.6.34-0
      Code:

Settings for eth0:
   Supported ports: [ TP ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Advertised pause frame use: No
   Advertised auto-negotiation: Yes
   Speed: 1000Mb/s
   Duplex: Full
   Port: Twisted Pair
   PHYAD: 1
   Transceiver: internal
   Auto-negotiation: on
   MDI-X: off
   Supports Wake-on: pumbag
   Wake-on: g
   Current message level: 0x00000001 (1)
   Link detected: yes
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 15.09.2010, 18:56



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Sounds like e1000e could be broken on 2.6.35?

I myself have an e1000 (no e) interface on my Thinkpad and it works fine.
 
 View user's profile Send private message  
Reply with quote Back to top
sidroOffline
Post subject:   PostPosted: 15.09.2010, 19:00



Joined: 2010-09-12
Posts: 15
Location: Romania
Status: Offline
ceni is very slow.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 15.09.2010, 19:05



Joined: 2010-08-25
Posts: 766

Status: Offline
e1000e as a whole doesn't seem to be broken, not only does it work for dibl, I also see no relevant bugs upstream or elsewhere. However side effects of regressions in other subsystems (like I mentioned APCI and MSI support are prime candidates, among others) could impose subtile breakage on other drivers, like e1000e. Additional the exact chipset revision (lspci -nn | grep -i intel.*ethernet) would be interesting.
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 15.09.2010, 19:16



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
cge-nogo, why not post the output of lspci -nn | grep -i intel.*ethernet as slh mentioned. There could be a variant that's not known about.

Another thing to check is the cable. Is it firmly plugged in?
 
 View user's profile Send private message  
Reply with quote Back to top
cge-nogoOffline
Post subject:   PostPosted: 16.09.2010, 06:04



Joined: 2010-09-12
Posts: 8

Status: Offline
      DeepDayze wrote:
cge-nogo, why not post the output of lspci -nn | grep -i intel.*ethernet as slh mentioned. There could be a variant that's not known about.

Okay this is the output:
      Code:
lspci -nn | grep -i ethernet
00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)


      DeepDayze wrote:
Another thing to check is the cable. Is it firmly plugged in?

I know you have to recomment that, but I wouldn't bother you if I didn't checked it before. And well with 2.6.34 it works fine. Sometimes I think I have old configuration somewhere around.
 
 View user's profile Send private message  
Reply with quote Back to top
cge-nogoOffline
Post subject:   PostPosted: 16.09.2010, 07:04



Joined: 2010-09-12
Posts: 8

Status: Offline
Okay bad news about my old configuration idea. I tried the new live cd and the same problem appears. Still no link.
 
 View user's profile Send private message  
Reply with quote Back to top
seasonsOffline
Post subject:   PostPosted: 16.09.2010, 08:07



Joined: 2010-09-13
Posts: 92

Status: Offline
It might have something to do with IRQ 19? Some systems have issues with that one. Do you see any errors/warnings with:
      Code:
cat /var/log/messages |grep irq
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio