Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
riyazOffline
15 Post subject: No sound From iceweasel (solved  PostPosted: 04.02.2011, 10:35



Joined: 2011-02-04
Posts: 8

Status: Offline
Hello all,

I have installed aptosid and everything is working except i get no sound from iceweasel. The sound works in gxine. I have tried changing the setting in iceweaselrc to "aoss" but no luck.

I also have an issue when shutting the system down. I get a message saying disabling irq22.

If someone could let me know what files to post so that it may aid solving this problem.

apart from these two problems aptosid is great Smile

Many Thanks,

Riyaz
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: No sound From iceweasel  PostPosted: 04.02.2011, 11:06



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
cat /proc/asound/cards
 
 View user's profile Send private message  
Reply with quote Back to top
riyazOffline
Post subject:   PostPosted: 04.02.2011, 12:32



Joined: 2011-02-04
Posts: 8

Status: Offline
Here is the output from cat /proc/asound/cards :


      Code:
 0 [CA0106         ]: CA0106 - CA0106
                      X-Fi Extreme Audio [SBxxxx] at 0x7f00 irq 20
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbffc000 irq 16


I have disbaled the onboard audio from the bios so i can use the creative soundcard. I had to create a ~/.asoundrc to get the creative to be the default as alsa would select the nvidia card. The creative soundcard works in gxine etc but still no sound from iceweasel.

Here is the ~/.asoundrc config:
      Code:

pcm.!default {
    type hw
    card CA0106
}
ctl.!default {
    type hw           
    card CA0106
}
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 04.02.2011, 12:44



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
I would delete the .asoundrc.
Then i would do

touch /etc/modprobe.d/myblacklist.conf
echo blaklist snd-hda-intel >> /etc/modprobe.d/myblacklist.conf

reboot.

And btw, the aoss setting in iceweaselrc should not be nessesary and needs the package alsa-oss installed, which is iirc not default.
 
 View user's profile Send private message  
Reply with quote Back to top
riyazOffline
Post subject:   PostPosted: 04.02.2011, 14:41



Joined: 2011-02-04
Posts: 8

Status: Offline
Thank you very much for your help towo everything is working now. Smile
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio