Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
amaOffline
22 Post subject: unsquashfs aptosid.amd64 not possible on 2011-01  PostPosted: 09.02.2011, 08:20



Joined: 2011-02-09
Posts: 2
Location: Dresden, Germany
Status: Offline
Hallo,
aptosid 2011-01 ist great!

But I have a problem: I can't unsquashfs the aptosid.amd64 and aptosid.686.
On 2010-03 all working (with squashfs-tools 4.0-8 from debian) and md5sum of
DVD is O.K.

With 4.0-8 I get:
----snipp
zlib::uncompress failed, unknown error -3
read_block: failed to read block @0x2f508728
read_fragment_table: failed to read fragment table index
FATAL ERROR aborting: failed to read fragment table
----snapp

and with squashfs 4.1-3 I get:
------snipp
Filesystem uses unknown compression, this is unsupported by this version
Decompressors available:
gzip
lzma
lzo
-------snapp

unsquashfs -s aptosid.amd64 give a good result

---snipp
Creation or last append time Sat Feb 5 23:58:20 2011
Filesystem is exportable via NFS
Inodes are compressed
Data is compressed
Fragments are compressed
Check data is not present in the filesystem
Fragments are present in the filesystem
Always_use_fragments option is not specified
Duplicates are removed
Filesystem size 775442.21 Kbytes (757.27 Mbytes)
Block size 131072
Number of fragments 6060
Number of inodes 102229
Number of ids 21
----snapp


What is wrong?

with regards
Andreas Matthus
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: unsquashfs aptosid.amd64 not possible on 2011-01  PostPosted: 09.02.2011, 17:31
Team Member


Joined: 2010-08-26
Posts: 255

Status: Offline
The message you got "Filesystem uses unknown compression, this is unsupported by this version" is correct. As noted in the release notes this version was built with xz compression. You need a squashfs-tools that supports xz compression which probably means you need one from aptosid until a new version reaches sid.
 
 View user's profile Send private message  
Reply with quote Back to top
amaOffline
15 Post subject: Re: RE: unsquashfs aptosid.amd64 not possible on 2011-01  PostPosted: 10.02.2011, 08:29



Joined: 2011-02-09
Posts: 2
Location: Dresden, Germany
Status: Offline
      Quote:
You need a squashfs-tools that supports xz compression which probably means you need one from aptosid until a new version reaches sid.


Thank you, this solves my problem Very Happy

with regards
Andreas Matthus
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio