Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [solved] nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 16:07



Joined: 2010-09-12
Posts: 325

Status: Offline
Although the xorg problem seems to be resolved on AMD64, it seems that it still wants to remove nvidia-glx, which I assume could make things slower for users with the binary nvidia driver.

Perhaps this can be fixed by installing the version from experimental, but I have not tried. (I'll just wait.)

Some info:

      Code:

root@t510[/home/finotti]# infobash -v3
Host/Kernel/OS  "t510" running Linux 2.6.37-0.slh.18-aptosid-amd64 x86_64 [ sidux 2010-01 Ύπνος - kde-full - (201006131622) ]
CPU Info        4x Intel Core i5 M 520 @ 3072 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2400.000 MHz ]                                       
Videocard       nVidia GT218 [NVS 3100M]  X.Org 1.7.7  [ 1366x768@50.0hz ]                                                                           
Network cards   Intel 82577LM Gigabit                                                                                                               
                Intel Centrino Advanced-N 6200                                                                                                       
Processes 171 | Uptime 2:48 | Memory 1121.9/3829.0MB | HDD ST9320423AS Size 320GB (34%used) | GLX Renderer NVS 3100M/PCI/SSE2 | GLX Version 3.2.0 NVIDIA 195.36.31 | Client Shell | Infobash v3.34


      Code:


root@t510[/home/finotti]# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  nvidia-glx openoffice.org-base-core openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw openoffice.org-help-en-us
  openoffice.org-impress openoffice.org-kde openoffice.org-math openoffice.org-style-galaxy openoffice.org-thesaurus-de
  openoffice.org-thesaurus-en-us openoffice.org-writer
The following NEW packages will be installed:
  libccid libfont-ttf-perl libnice10 libpipeline1 libva-x11-1 linux-headers-2.6.37-0.slh.20-aptosid-amd64 linux-image-2.6.37-0.slh.20-aptosid-amd64
  pcscd
The following packages have been kept back:
  gstreamer0.10-ffmpeg
The following packages will be upgraded:
  anthy-common apt apt-utils aptosid-archive-keyring aptosid-manual-common aptosid-manual-en aspell base-files bash-completion bluetooth bluez
  bluez-pcmcia-support bluez-utils cups cups-bsd cups-client cups-common cups-ppdc dbus dbus-x11 dctrl-tools debhelper dictionaries-common dpkg
  dpkg-dev dselect fancontrol foomatic-db foomatic-db-engine foomatic-filters groff groff-base grub-common grub-pc grub2 gstreamer0.10-nice hal
  iproute iso-codes k3b k3b-data kchmviewer ktorrent ktorrent-data libanthy0 libapr1 libaprutil1 libaspell15 libatasmart4 libavahi-client3
  libavahi-common-data libavahi-common3 libavahi-glib1 libavahi-qt3-1 libbluetooth3 libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libcups2
  libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libdb4.8 libdbus-1-3 libdpkg-perl libdrm-intel1 libdrm-radeon1 libdrm2
  libfluidsynth1 libgeoip1 libgl1-mesa-dri libgl1-mesa-glx libglew1.5 libglib2.0-0 libglu1-mesa libgnomevfs2-0 libgnomevfs2-common libgnutls26
  libgpg-error0 libgstfarsight0.10-0 libgudev-1.0-0 libhal-storage1 libhal1 libhunspell-1.2-0 libhyphen0 libk3b6 libk3b6-extracodecs
  libktorrent-l10n libktorrent2 liblapack3gf libmms0 libmysqlclient16 libnm-glib2 libnm-util1 liborc-0.4-0 libpciaccess0 libpcre3 libpcsclite1
  libpdf-api2-perl libpixman-1-0 libpurple0 libschroedinger-1.0-0 libsensors4 libsmbclient libudev0 libusb-0.1-4 libva1 libvlc5 libvlccore4 libvpx0
  libwbclient0 libx11-6 libx11-data libx11-xcb1 libxaw7 libxcb-dri2-0 libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxcb1
  libxext6 libxfont1 libxi6 libxt6 linux-headers-2.6-aptosid-amd64 linux-image-2.6-aptosid-amd64 lm-sensors locales m17n-contrib m17n-db man-db
  mencoder mesa-utils **removed** myspell-en-us mysql-common mysql-server-core-5.1 openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
  openprinting-ppds openssh-client openssh-server patch pidgin pidgin-data pm-utils rsyslog samba-common skanlite smbclient sudo sun-java6-bin
  sun-java6-jre sun-java6-plugin syslinux syslinux-common ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-freefont ttf-liberation ttf-lyx
  ttf-opensymbol udev uno-libs3 ure usbutils vlc vlc-data vlc-nox vlc-plugin-pulse whois x11-apps x11-common x11-session-utils x11-utils xsane
  xsane-common xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nv
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xutils yakuake
224 upgraded, 8 newly installed, 14 to remove and 1 not upgraded.
Need to get 0 B/296 MB of archives.
After this operation, 172 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.


      Code:


root@t510[/home/finotti]# apt-cache policy nvidia-glx
nvidia-glx:
  Installed: 195.36.31-6
  Candidate: 195.36.31-6
  Version table:
     260.19.21-1 0
         50 http://ftp.us.debian.org/debian/ experimental/non-free amd64 Packages
 *** 195.36.31-6 0
        500 http://lug.mtu.edu/debian/ sid/non-free amd64 Packages
        100 /var/lib/dpkg/status
     195.36.24-0 0
        500 http://frickelplatz.de/debian/ sid/non-free amd64 Packages


Last edited by finotti on 11.02.2011, 21:35; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
cid-babaOffline
Post subject: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 17:08



Joined: 2010-09-11
Posts: 24

Status: Offline
I installed the nvidia-stuff from experimantal some time ago (needed it for my new GTX460) and it works without problems here. (amd64)
 
 View user's profile Send private message  
Reply with quote Back to top
quatro_por_quatroOffline
Post subject: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 17:11



Joined: 2010-10-03
Posts: 4

Status: Offline
now the nouveau driver in kernel works well, but is not enabled in shl kernels,

there are alternatives, compiling new kernel or nvidia packages, read:

http://aptosid.com/index.php?name=PNphp ... =5012#5012

I see that your apt-get command does not automatically upgrade openoffice to libreoffice, you should also take care of that.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 18:13
Moderator


Joined: 2010-09-11
Posts: 468

nvidia-glx is still in experimental.
nvidia-glx:
Installed: (none)
Candidate: 195.36.31-6
Version table:
260.19.21-1 0
1 http://ftp.de.debian.org/debian/ experimental/non-free i386 Packages
195.36.31-6 0
500 http://ftp.de.debian.org/debian/ sid/non-free i386 Packages

after getting new xorg, activating experimental with non-free then
# apt-get update
# apt-get install nvidia-glx/experimental
http://aptosid.com/index.php?name=PNphp ... =4959#4959


      quatro_por_quatro wrote:

now the nouveau driver in kernel works well, but is not enabled in shl kernels,

When you wrote this, it was already enabled. 8)
 
 View user's profile Send private message  
Reply with quote Back to top
quatro_por_quatroOffline
Post subject: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 20:35



Joined: 2010-10-03
Posts: 4

Status: Offline
good grief!
nearly twelve hours ago
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 21:17



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
      muchan wrote:


after getting new xorg, activating experimental with non-free then
# apt-get update
# apt-get install nvidia-glx/experimental
http://aptosid.com/index.php?name=PNphp ... =4959#4959


Failed for me.

      Code:
root@yoda:/etc/apt/sources.list.d# apt-get install nvidia-glx/experimental
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Version choisie « 260.19.21-1 » (Debian:experimental [i386]) pour « nvidia-glx »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-glx : Dépend: libgl1-nvidia-glx (= 260.19.21-1)
              Dépend: nvidia-kernel-260.19.21
E: Paquets défectueux

Then I installed libgl1-nvidia-glx: OK but when I wanted to install nvidia-kernel-260.19.21: this package does not exist.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 21:22



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
apt-get -t experimental install nvidia-kernel-source
rmmod nvidia
m-a a-i nvidia-kernel-source
apt-get -t experimental install nvidia-glx
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: RE: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 21:27



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
Thx towo, I'm going to try that and I'll give you a feedback.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 21:34
Moderator


Joined: 2010-09-11
Posts: 468

hopimet, you need to activate the non-free of both sid and experimental.
When my sid didn't have non-free, and only experimental, I got exactly the same error as yours.
If you think you have already, please post the contents of
/etc/apt/sources.list.d/debian.list

(btw. je suis aussi parmi les francophone... mais en ce moment aptosid.fr ne fonctionne pas)
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: RE: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 10.02.2011, 21:42



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
It's OK !!!!!! Many thx towo !!!!

Just a small problem: the movements of my touchpad seem now, very, very slow...

I think it can be modified somewhere ?

Salut munchan, tu es français ? belge ? suisse ? quebecois ? autre choix ?
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: nvidia-glx to be removed (amd64)  PostPosted: 11.02.2011, 21:35



Joined: 2010-09-12
Posts: 325

Status: Offline
Although I haven't tested it for functionality, a new nvidia-glx came now and so it will be upgraded instead of removed, which is what one expects. I'll mark this as solved.
 
 View user's profile Send private message  
Reply with quote Back to top
myloOffline
Post subject:   PostPosted: 12.02.2011, 09:43



Joined: 2010-09-11
Posts: 116
Location: Wiesbaden, Germany
Status: Offline
Hi finotti,

I cannot confirm this by this morning (64bit):

      Code:
Die folgenden Pakete werden ENTFERNT:
  nvidia-glx openoffice.org-base-core openoffice.org-core openoffice.org-thesaurus-de openoffice.org-thesaurus-en-us
  virtualbox-ose-guest-x11 xserver-xorg-video-nv


ENTFERNT = REMOVED

EDIT:
with the frickel repo now apt proposes to update it. Thanks!

_________________
Regards
mylo

Linux 3.1-6.slh.1-aptosid-amd64 x86_64[2010-03 Ἀπάτη (201012262151)]
Intel Core2 Duo E6550 @ Cache/Ram 4MB/4GB nVidia G72 7300 nouveau 2*250GB
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 12.02.2011, 10:16
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Insisting to use drivers who have been removed/replaced upstream is not a good solution, and calling for problems with a rolling release like Aptosid. xserver-xorg-video-nv is gone. For booting from live CD vesa is really good enough. For HDD installations nouveau will be nice in the future, but as it is today it will break with every kernel upgrade until userspace ABI is not upgraded. And there is the proprietary nvidia driver, reliable, easy to upgrade and well working.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
myloOffline
Post subject:   PostPosted: 12.02.2011, 10:58



Joined: 2010-09-11
Posts: 116
Location: Wiesbaden, Germany
Status: Offline
just for me to be sure:

      Code:
nvidia-glx:
  Installiert: 195.36.31-6
  Kandidat:    260.19.36-0~frickel.1


The 195 is, according to my understanding, the proprietary one. Am I right?
Can I replace the 195 now by the 260?
Or shall I go experimental?

Sorry to ask, but may be I am the only one who cannot follow this detailed stuff...

_________________
Regards
mylo

Linux 3.1-6.slh.1-aptosid-amd64 x86_64[2010-03 Ἀπάτη (201012262151)]
Intel Core2 Duo E6550 @ Cache/Ram 4MB/4GB nVidia G72 7300 nouveau 2*250GB
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject:   PostPosted: 12.02.2011, 11:03



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
      Quote:

Can I replace the 195 now by the 260?


Yes, follow the procedure given by towo a few posts above. It was succesful for me.

Then, it's possible that you will have a problem with your touchpad if you're using a laptop. You will find a solution on the other topic:
http://aptosid.com/index.php?name=PNphp ... &t=789
(see muchan's post)
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio