Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
luckybOffline
15 Post subject: python plasma widgets  PostPosted: 01.03.2011, 19:31



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
I cannot get python based plasma widgets to work.

The widgets show up with the following error:
      Code:
This object could not be created for the following reason:
Could not create a python scriptengine for the <XYZ> widget


Apparently my system misses some packages

I've tried to install plasma-scriptengine-python but...
      Code:
The following packages have unmet dependencies:
 plasma-scriptengine-python : Depends: python-kde4 (>= 4:4.2.0) but it is not going to be installed
E: Broken packages


I've also tried to install python-dev, kdebindings-python, kdeplasma-addons, kdebase-workspace-python because of some search engine results but none improved the situation.

I would appreciate any guidelines Rolling Eyes


Last edited by luckyb on 04.03.2011, 16:28; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: python plasma widgets  PostPosted: 01.03.2011, 20:30



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Did you try installing python-kde4?
 
 View user's profile Send private message  
Reply with quote Back to top
luckybOffline
Post subject: RE: python plasma widgets  PostPosted: 01.03.2011, 20:39



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
thanks for the answer deepDayze
yes, sorry for not mentioning.
There seems to be a chain of dependencies that ends up at libqtcore4 which is already the newest verison:

      Code:

apt-get install python-qt4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-qt4 : Depends: libqt4-assistant (>= 4:4.5.3) but it is not going to be installed
              Depends: sip-api-7.1 but it is not installable
E: Broken packages

root@luckyb-laptop:/home/luckyb# apt-get install libqt4-assistant
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt4-assistant : Depends: libqt4-network (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed
                    Depends: libqtcore4 (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed
E: Broken packages

root@luckyb-laptop:/home/luckyb# apt-get install libqt4-network
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt4-network is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 64 not upgraded.

root@luckyb-laptop:/home/luckyb# apt-get install libqtcore4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtcore4 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 64 not upgraded.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: python plasma widgets  PostPosted: 01.03.2011, 20:58



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
aha!

Did you happen to install the newest python-sip package? That package breaks the dependencies as it updates sip-api to 8.0 and python-kde4 needs sip-api-7.1
 
 View user's profile Send private message  
Reply with quote Back to top
detaosOffline
Post subject: RE: python plasma widgets  PostPosted: 01.03.2011, 21:43
Team Member


Joined: 2010-08-26
Posts: 166
Location: floating in the ether
Status: Offline
$10 says he did Wink

see: http://aptosid.com/index.php?name=PNphp ... &t=886

_________________
#aptosid-art ftw!
(what would cleary do?)
 
 View user's profile Send private message Send e-mail Visit poster's website  
Reply with quote Back to top
luckybOffline
Post subject: RE: python plasma widgets  PostPosted: 01.03.2011, 22:25



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
damn, who do I owe 10 bucks to ??

      Code:
Package: python-sip
Priority: optional
Section: python
Installed-Size: 496
Maintainer: Debian Python Modules Team <python>
Architecture: amd64
Source: sip4
Version: 4.12.1-1
Provides: python2.5-sip, python2.6-sip, sip-api-8.0, sip-api-8.1


...and why haven't I kept my promise to read those upgrade warnings before I answer "yes I do"
Shocked
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: python plasma widgets  PostPosted: 02.03.2011, 01:08



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Try to rollback python-sip to the one in testing then try installing python-kde4 again
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: python plasma widgets  PostPosted: 02.03.2011, 08:10
Moderator


Joined: 2010-09-11
Posts: 468

Now python-sip problem is solved. so you can install all the chain smoothly.
 
 View user's profile Send private message  
Reply with quote Back to top
luckybOffline
Post subject: RE: python plasma widgets  PostPosted: 02.03.2011, 14:19



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
thank you all for the answers

unfortunately the python-sip issue is not solved yet.
I did install the previous version, as DeepDayze suggested but there is still a dependency chain that more or less goes as follows:
      Code:
python-kde4 : Depends: python-qt4 but it is not going to be installed
python-qt4 : Depends: libqt4-assistant (>= 4:4.5.3) but it is not going to be installed
libqt4-assistant : Depends: libqt4-network (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed
                    Depends: libqtcore4 (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed


The last 2 (libqt4-network & libqtcore4) are already installed at my system (version 4.7.0~beta2-3)

I assume that this is just a dependency error that is going to be solved some day.
I suggest that I wait for that day and then confirm that the plasma-scriptengine-python package will bring my python widgets back to life...
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
luckybOffline
Post subject: RE: python plasma widgets  PostPosted: 02.03.2011, 14:22



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
...I nearly forgot:
please do not suggest to downgrade libqt4core4 because I simulated the command and the resulting "packages will be REMOVED" list, freaked me out Shocked
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
muchan
Post subject: RE: python plasma widgets  PostPosted: 02.03.2011, 16:00
Moderator


Joined: 2010-09-11
Posts: 468

Indeed, python-kde4 is still depending <sip>,
(as well as other qt's lib as your post suggests) so,
not "all the chain" is installable yet. Sorry.
 
 View user's profile Send private message  
Reply with quote Back to top
Ilinsekt
Post subject:   PostPosted: 03.03.2011, 21:34



Joined: 2010-10-29
Posts: 43

      Quote:

libqt4-assistant : Depends: libqt4-network (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed
Depends: libqtcore4 (= 4:4.6.3-4) but 4:4.7.0~beta2-3 is to be installed


You did not by chance install these two packages from experimental some time ago? Try
      Code:

apt-get install --reinstall libqtcore4/sid libqt4-network/sid
 
 View user's profile Send private message  
Reply with quote Back to top
luckybOffline
Post subject:   PostPosted: 03.03.2011, 22:08



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
thank you Ilinsekt, you seem to be right

This is weird though. My debian.list just includes the sid repo and I don't remember installing anything deliberately from experimental !!

reinstalling from sid as you suggest will downgrade the 2 packages but will also remove 277 Shocked
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
agaidaOffline
Post subject:   PostPosted: 03.03.2011, 22:28



Joined: 2011-01-16
Posts: 22
Location: Bielefeld
Status: Offline
There is an easy solution. Wait for the debian guys get python-kde4 build in the new version with the new dependencies. Maybe one or two weeks (or more .. it's done when it's done)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
luckybOffline
Post subject:   PostPosted: 04.03.2011, 05:56



Joined: 2010-09-17
Posts: 25
Location: Athens, Greece
Status: Offline
Indeed, somehow my system got sid mixed with experimental (I must have done sth, I just don't recall).

Instead of trying some apt magic (and completely ruin it) it would be better to just wait as you suggest.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio