Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hanzdersionOffline
Post subject: Cant connect to any repository  PostPosted: 02.03.2011, 17:02



Joined: 2010-10-26
Posts: 4
Location: Florida
Status: Offline
I havent used aptosid in a while, last time everything was fine but now I cant connect to any repository.

This is my current list:

aptosid.list:
deb http://aptosid.office-vienna.at/aptosid/debian/ sid main fix.main
#deb-src http://aptosid.office-vienna.at/aptosid/debian/ sid main fix.main

debian.list:
deb http://ftp.us.debian.org/debian/ sid main
#deb-src http://ftp.us.debian.org/debian/ sid main
deb http://ftp.de.debian.org/debian unstable main contrib non-free
# deb-src http://ftp.de.debian.org/debian unstable main contrib non-free
deb http://deb.opera.com/opera sid non-free

are these still working? If so then something else is wrong with my system. If not, can someone post the new repos?

Thank you.
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: Re: Cant connect to any repository  PostPosted: 02.03.2011, 17:27
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
      hanzdersion wrote:
debian.list:
deb http://ftp.us.debian.org/debian/ sid main
#deb-src http://ftp.us.debian.org/debian/ sid main
deb http://ftp.de.debian.org/debian unstable main contrib non-free

You have a double entry for sid/unstable. Repos are accessible.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
DonKultOffline
Post subject: Re: Cant connect to any repository  PostPosted: 02.03.2011, 17:28
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
      hanzdersion wrote:
last time everything was fine but now I cant connect to any repository.

I guess you conclude this from an errormessage. Can you post this message and what you did exactly?


Regarding your sources.list:
sid is the same as unstable, so remove the entries for ftp.de.debian.org - if you are really from Florida this mirror should be relatively slow - and add contrib and non-free instead to the ftp.us.debian.org one.

And as Florida isn't near austria (where vienna is located) i would recommend to choose a different mirror for aptosid…

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
cid-babaOffline
Post subject: RE: Cant connect to any repository  PostPosted: 02.03.2011, 17:32



Joined: 2010-09-11
Posts: 24

Status: Offline
the aptosid.list seems okay, but the debian-list is strange, or lets say: more than necessary:

use
deb http://ftp.us.debian.org/debian/ unstable main contrib non-free
#deb-src http://ftp.us.debian.org/debian/ unstable main contrib non-free
that's all you need.

maybe you should choose the us-mirror of aptosid (deb http://mirror.yellowfiber.net/aptosid/), austria is far from florida...

the opera-repo might be better in an own opera.list - but thats a matter of taste.

EDIT: I think I should learn to type much faster Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
hanzdersionOffline
Post subject:   PostPosted: 02.03.2011, 17:53



Joined: 2010-10-26
Posts: 4
Location: Florida
Status: Offline
This is the error I get:

      Code:

root@siduxbox:/etc/apt/sources.list.d# apt-get update
Err http://ftp.de.debian.org unstable Release.gpg
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/contrib Translation-en
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/contrib Translation-en_US
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/main Translation-en
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/main Translation-en_US
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/non-free Translation-en
  Could not resolve 'ftp.de.debian.org'
Err http://ftp.de.debian.org/debian/ unstable/non-free Translation-en_US
  Could not resolve 'ftp.de.debian.org'
Err http://aptosid.office-vienna.at sid Release.gpg                     
  Could not resolve 'aptosid.office-vienna.at'
Err http://aptosid.office-vienna.at/aptosid/debian/ sid/fix.main Translation-en
  Could not resolve 'aptosid.office-vienna.at'
Err http://aptosid.office-vienna.at/aptosid/debian/ sid/fix.main Translation-en_US
  Could not resolve 'aptosid.office-vienna.at'
Err http://aptosid.office-vienna.at/aptosid/debian/ sid/main Translation-en
  Could not resolve 'aptosid.office-vienna.at'
Err http://aptosid.office-vienna.at/aptosid/debian/ sid/main Translation-en_US
  Could not resolve 'aptosid.office-vienna.at'
Err http://deb.opera.com stable Release.gpg
  Could not resolve 'deb.opera.com'
Err http://deb.opera.com/opera/ stable/non-free Translation-en
  Could not resolve 'deb.opera.com'
Err http://deb.opera.com/opera/ stable/non-free Translation-en_US
  Could not resolve 'deb.opera.com'
Reading package lists... Done   
W: Failed to fetch http://aptosid.office-vienna.at/aptosid/debian/dists/sid/Release.gpg  Could not resolve 'aptosid.office-vienna.at'

W: Failed to fetch http://aptosid.office-vienna.at/aptosid/debian/dists/sid/fix.main/i18n/Translation-en.bz2  Could not resolve 'aptosid.office-vienna.at'

W: Failed to fetch http://aptosid.office-vienna.at/aptosid/debian/dists/sid/fix.main/i18n/Translation-en_US.bz2  Could not resolve 'aptosid.office-vienna.at'

W: Failed to fetch http://aptosid.office-vienna.at/aptosid/debian/dists/sid/main/i18n/Translation-en.bz2  Could not resolve 'aptosid.office-vienna.at'

W: Failed to fetch http://aptosid.office-vienna.at/aptosid/debian/dists/sid/main/i18n/Translation-en_US.bz2  Could not resolve 'aptosid.office-vienna.at'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/Release.gpg  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/contrib/i18n/Translation-en.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/contrib/i18n/Translation-en_US.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/main/i18n/Translation-en.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/main/i18n/Translation-en_US.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/non-free/i18n/Translation-en.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://ftp.de.debian.org/debian/dists/unstable/non-free/i18n/Translation-en_US.bz2  Could not resolve 'ftp.de.debian.org'

W: Failed to fetch http://deb.opera.com/opera/dists/stable/Release.gpg  Could not resolve 'deb.opera.com'

W: Failed to fetch http://deb.opera.com/opera/dists/stable/non-free/i18n/Translation-en.bz2  Could not resolve 'deb.opera.com'

W: Failed to fetch http://deb.opera.com/opera/dists/stable/non-free/i18n/Translation-en_US.bz2  Could not resolve 'deb.opera.com'

W: Some index files failed to download, they have been ignored, or old ones used instead.


I removed the "Unnecessary" repos, as u guys recommended.
This one seems to have a wrong syntax:
deb http://mirror.yellowfiber.net/aptosid/
it says malformed line 3 in aptosid.list (line 3 is this repo)
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject:   PostPosted: 02.03.2011, 18:42
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
You are offline? You need a proxy configuration?

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
hanzdersionOffline
Post subject:   PostPosted: 02.03.2011, 19:03



Joined: 2010-10-26
Posts: 4
Location: Florida
Status: Offline
Well if the repos are fine then I guess the problem is on my end, which is strange since I obviously have Internet connection. No I dont use a proxy.

Thanks for the help, I'll have to investigate further.
 
 View user's profile Send private message  
Reply with quote Back to top
redsidOffline
Post subject:   PostPosted: 02.03.2011, 20:26



Joined: 2011-02-08
Posts: 32
Location: Lake Otsego
Status: Offline
Here is the list on one of my computers that should cover what you have. It has and is working OK as of now. Forget that yellowfiber thing. The link is screwed up.

deb http://ftp.us.debian.org/debian/ sid main contrib non-free

deb http://deb.opera.com/opera/ sid non-free

deb http://oscar.aptosid.com/debian/ sid main fix.main
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject:   PostPosted: 02.03.2011, 23:53
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
I did not trace it back but there should be a bug related to apt-build. Purge apt-build and "apt-get update" works again (I got bitten on a box that I don't upgrade very often and which had apt-build installed).

Same symptoms: there was no way to connect to any repository, not even the local ones on the same box. Now everything is fine again.

I have no idea if that is a common problem or custom settings are the cause (this installation is three years old).

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio