Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
edOffline
Post subject: X server crash when returning from full screen flash video  PostPosted: 22.02.2011, 10:33



Joined: 2010-10-18
Posts: 6

Status: Offline
As in the title, when exiting from fullscreen video in chromium-browser, X crashes and restarts, putting me back at the logon screen.

Sometimes X will become very slow and only redraw items when the mouse passes over them, but crashes soon after.

Kaffeine, Movie Player etc. do not cause this to happen.


If it was just chromium crashing, I would open it through a terminal to look at the error messages, but I don't know how to find out what is wrong because the whole Xserver is restarting.

Does anyone know what the problem might be, or how I can see more debugging information?


My system:
      Code:
Host/Kernel/OS  "aptosidbox-hp" running Linux 2.6.37-1.slh.2-aptosid-amd64 x86_64 [ aptosid 2010-03 Ἀπάτη - kde-lite - (201012262151) ]
CPU Info        (1) Pentium Dual-Core T4300 @ clocked at [ 1600.000 MHz ]
                (2) Pentium Dual-Core T4300 @ clocked at [ 2100.000 MHz ]
Videocard       Intel Mobile 4 Series Chipset Integrated Graphics Controller  X.Org 1.9.4  [ 1366x768@60.0hz ]
Processes 127 | Uptime 54min | Memory 588.4/3872.2MB | HDD Size 320GB (46%used) | Client Shell | Infobash v3.34




EDIT: I just thought - this is probably going to be be just a flashplayer problem isn't it? Probably nothing to do with X or chromium.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: X server crash when returning from full screen flash vid  PostPosted: 22.02.2011, 11:44



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
check if /home/USER/.xsession-errors has anything

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: X server crash when returning from full screen flash vid  PostPosted: 22.02.2011, 11:52



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Offline
I would say, it's flash releated.
 
 View user's profile Send private message  
Reply with quote Back to top
edOffline
Post subject:   PostPosted: 23.02.2011, 14:05



Joined: 2010-10-18
Posts: 6

Status: Offline
Well, there are errors, but as far as I can tell from a bit of googling, nothing very informative.

I can't work out why (if it is the flash plugin) that everything crashes instead of just the plugin.

Do these error messages mean anything?

      Code:
kdeinit4: preparing to launch /usr/bin/chromium-browser
knotify(2409) KNotify::event: 77  ref= 0
knotify(2409) KNotify::event: 78  ref= 0
knotify(2409) KNotify::event: 79  ref= 0
knotify(2409) KNotify::event: 80  ref= 0
knotify(2409) KNotify::event: 81  ref= 0
knotify(2409) KNotify::event: 82  ref= 0

(exe:3371): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(exe:3371): Gtk-CRITICAL **: IA__gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed
knotify(2409) KNotify::event: 83  ref= 0
knotify(2409) KNotify::event: 84  ref= 0
kmix: Fatal IO error: client killed
kded4: Fatal IO error: client killed
kwin: Fatal IO error: client killed
ksmserver: Fatal IO error: client killed
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
Handling SIGHUP.
Check failed: g_shutdown_pipe_write_fd != -1
kglobalaccel(2405) GlobalShortcutsRegistry::unregisterKey: Unregistering key "Volume Mute" for "kmix" : "mute"
kglobalaccel(2405) GlobalShortcutsRegistry::unregisterKey: Unregistering key "Volume Down" for "kmix" : "decrease_volume"
kglobalaccel(2405) GlobalShortcutsRegistry::unregisterKey: Unregistering key "Volume Up" for "kmix" : "increase_volume"


*lots of "unregistering key" lines cut out*
      Code:
klauncher: Exiting on signal 1
klauncher(2272)/kio (KLauncher): SlavePool: No communication with slave.

Handling SIGHUP.
Successfully wrote to shutdown pipe, resetting signal handler.
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
Handling SIGTERM.
Successfully wrote to shutdown pipe, resetting signal handler.
Unexpected response from KInit (response = 0).
startkde: Could not start ksmserver. Check your installation.
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kglobalaccel: Fatal IO error: client killed
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
 
 View user's profile Send private message  
Reply with quote Back to top
ragupoOffline
Post subject:   PostPosted: 12.03.2011, 10:13



Joined: 2010-09-11
Posts: 29
Location: Copenhagen
Status: Offline
I can reproduce this error on my system.
      Quote:
"box" running Linux 2.6.37-3.slh.2-aptosid-amd64 x86_64 [ aptosid 2010-03 Ἀπάτη - kde-full - (201012262151) ]
CPU Info 2x Intel Core2 Duo T9550 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 800.000 MHz ]
Videocard Intel Mobile 4 Series Chipset Integrated Graphics Controller X.Org 1.9.4.901 [ 1680x1050@60.0hz ]
ATI Mobility Radeon HD 3650
Network cards Intel 82567LM Gigabit
Intel Ultimate N WiFi Link 5300
Ericsson F3507g Mobile Broadband Minicard Composite Device
Processes 168 | Uptime 18:33 | Memory 1263.4/3861.3MB | HDD WDC WD3200BEVS-0 Size 320GB (24%used) | Client Shell | Infobash v3.35
(-using the intel card)
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio