Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ToZOffline
Post subject: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 04:08



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
As of about a week ago, I am unable to shutdown the computer from within an xfce session. When I select the "Logout" option from the xfce menu and select the shutdown option, I get dumped back to the login screen. Shutdown from the login screen works fine.

I have googled this problem and have tried the following:

1. made sure I am member of powerdev group (already was)
2. made sure hal is running (already was)
3. added "ck-launch-session startxfce4" to my .xinitrc file

...but no luck.

Also, "shutdown -h now" from command prompt works fine. However, "xfce4-session-logout --halt" does not - it also dumps me to the login screen.

Here are my system specs:
      Code:
Host/Kernel/OS  "hypnos" running Linux 2.6.37-2.slh.6-aptosid-686 i686 [ sidux 2010-01 Ύπνος - xfce - (201006131622) ]
CPU Info        2x Intel Core2 Duo T9300 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 800.000 MHz ]
Videocard       ATI M76 [Radeon Mobility HD 2600 Series]  X.Org 1.9.99.903  [ 1680x1050@60.0hz ]
Network cards   Intel 82566MM Gigabit
                Intel PRO/Wireless 4965 AG or AGN [Kedron]
Processes 136 | Uptime 26min | Memory 345.9/3041.8MB | HDD ST9500420AS Size 500GB (58%used) | GLX Renderer Gallium 0.4 on AMD RV630 | GLX Version Yes | Client Shell | Infobash v3.35


Thanks in advance for any advice.
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 04:11



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
Also just found this in syslog:

Mar 8 23:08:33 hypnos gdm[3008]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 09:11
Moderator


Joined: 2010-09-11
Posts: 468

I'm not sure if this is the same problem, but for the same error message,

"gdm_slave_xioerror_handler: Fatal X error - Restarting :0"
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583498

the Debian maintainer of Gnome wrote/asked:

"Do you have any "vga=" stuff in your kernel command line? That would
explain such craches with KMS."
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 11:51



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
Thanks for the reply, but no, there is no VGA= in my kernel command line.Here is contents of /etc/default/grub:
      Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="Microsoft Windows XP Professional (on /dev/sda1)"
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.modeset=0"
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768x16

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 13:45



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
And one more piece of info, at about the same time, I got 3D to work on my ATI HD2600 video card by installing libdrm-radeon1, libdrm2, and xserver-xorg-video-radeon (plus a number of other dependencies that were brought in) from experimental. (Finally, 3D accelerated graphics!).

      Code:
libdrm-radeon1:i386 (2.4.23-3, 2.4.24-1)
xserver-xorg-input-evdev:i386 (2.6.0-2, 2.6.0-3)
xserver-xorg-video-ati:i386 (6.14.0-1, 6.14.0-1+exp2)
xserver-xorg-video-fbdev:i386 (0.4.2-4, 0.4.2-6)
xserver-xorg-video-r128:i386 (6.8.1-5, 6.8.1-5+exp2)
xserver-common:i386 (1.9.4-3, 1.9.99.903-1)
xserver-xorg-video-vesa:i386 (2.3.0-5, 2.3.0-5+exp2)
xserver-xorg-video-mach64:i386 (6.8.2-5, 6.8.2-5+exp2)
xserver-xorg-core:i386 (1.9.4-3, 1.9.99.903-1)
xserver-xorg-input-synaptics:i386 (1.4.0-1, 1.4.0-1+exp1)
xserver-xorg-video-radeon:i386 (6.14.0-1, 6.14.0-1+exp2)
xserver-xorg-video-intel:i386 (2.14.0-4, 2.14.0-4+exp2)
libdrm2:i386 (2.4.23-3, 2.4.24-1)


Perhaps this is where the problem lies?
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 14:44



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Offline
Please comment these two lines

      Code:

GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768x16

and after that do update-grub
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 09.03.2011, 20:10



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
Thanks for the suggestion, towo, but after commenting those two lines, running update-grub and rebooting, there is no change. It appears as though after I click the Shutdown option, the X server crashes (based on the error message in syslog) and gdm restarts.
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 11.03.2011, 21:28



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
I was thinking about reverting back from the experimental packages to see if that solves the problem. I did some research and found that I could try:
      Code:
apt-get install xserver-xorg-video-radeon=6.14.0-1

but I get:
      Code:
E: Version '6.14.0-1' for 'xserver-xorg-video-radeon' was not found

even though:
      Code:
# apt-cache policy xserver-xorg-video-radeon
xserver-xorg-video-radeon:
  Installed: 1:6.14.0-1+exp2
  Candidate: 1:6.14.0-1+exp2
  Version table:
 *** 1:6.14.0-1+exp2 0
          1 http://ftp.debian.org/debian/ experimental/main i386 Packages
        100 /var/lib/dpkg/status
     1:6.14.0-1 0
        500 http://ftp.us.debian.org/debian/ sid/main i386 Packages
        500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages

What is the proper procedure to revert back from experimental?
 
 View user's profile Send private message  
Reply with quote Back to top
slsimicOffline
Post subject: RE: XFCE - Shutdown command only logs out  PostPosted: 13.03.2011, 12:34



Joined: 2011-02-28
Posts: 2
Location: Belgrade
Status: Offline
I have similar problem...
I can not log out from KDE session back to KDM login screen... instead, when I logoff I get onto tty1 console login prompt.

Thing started with new sh$*!y Gallium driver Sad
Is there any indices when we could expect to have RADEON driver back?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio