Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hopimetOffline
Post subject: Desktop size is too small  PostPosted: 15.03.2011, 14:34



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
Hello all,

Because I had a problem to reinstall nvidia-glx after the 2.6.38 kernel upgrade, I decided it was time to get rid of that proprietary driver and install the free nouveau driver. I followed the procedure given by slam in another topic and it worked fine.

However I have a strange bug: my desktop size is 1280x800 although the screen resolution is 1280x1024.

Clearly, my wallpaper and all the applications I launch are truncated by a large black bar (1280x224 I think) at the bottom of the screen.

It is strange because the resolution is 1280x1024 during the connexion screen and the kde splash screen but it switches to 1280x800 a few seconds after I reach the desktop screen. What is amazing is that my dock (Cairo) is displayed on the very bottom of the screen on the famous "black bar", which confirms that the screen resolution is 1280x1024.

I precise that I have tested an xfce and a fluxbox sessions and that all is OK with these environments.

Thus I think the configuration of nouveau is OK because the resolution of the screen is really 1280x1024 and the problem is specifically related to kde because only the kde desktop display is affected.

Actually, when I look at the system configuration settings, I can see that the maximum size of the desktop screen is 1280x800 but I have no option to set it to 1280x1024.

Is there a configuration file I should modify to correct this ?

Thanks in advance for your answers.


Last edited by hopimet on 15.03.2011, 21:00; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: RE: Desktop size is too small  PostPosted: 15.03.2011, 18:37



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
Well, the problem comes from the desktop special effects and the compositing display that are not activated. Unfortunately KDE refuses to activate these settings.

Any idea ?

Do I need an xorg.conf ?

Edit; with xfce compositing is OK and display resolution is 1280x1024 although the config settings tool indicates that the higher resolution for the screen is 1280x800 !!!

If it can help, my GC is:
VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

Edit 2: I have just discovered another problem. No more sound !
Edit 3: I have reinstalled nouveau and sound is OK ! However display problems remain unsolved...
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: RE: Desktop size is too small  PostPosted: 16.03.2011, 08:42



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
No one can help me ?
 
 View user's profile Send private message  
Reply with quote Back to top
myloOffline
Post subject: RE: Desktop size is too small  PostPosted: 16.03.2011, 12:26



Joined: 2010-09-11
Posts: 116
Location: Wiesbaden, Germany
Status: Offline
I think this german thread is dealing with your problem (bar = balken):

http://aptosid.de/index.php?name=PNphpBB2&file=viewtopic&t=144&highlight=balken

_________________
Regards
mylo

Linux 3.1-6.slh.1-aptosid-amd64 x86_64[2010-03 Ἀπάτη (201012262151)]
Intel Core2 Duo E6550 @ Cache/Ram 4MB/4GB nVidia G72 7300 nouveau 2*250GB
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: RE: Desktop size is too small  PostPosted: 16.03.2011, 14:45



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
Thx for helping me.

But I'm not sure this is the same problem. OK I'm not sure to understand german too...

As I said the problem is only with KDE (not with xfce for example). So, I don't unterstand why I should have to change grub conf.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Desktop size is too small  PostPosted: 16.03.2011, 16:19



Joined: 2010-09-12
Posts: 319

Status: Offline
Can you create a new user and log in to see if it will also have a problem in KDE? If not, it might be personal some configuration. In this case you can backup your KDE config dir and try to reconfigure again. (I know, it is a pain, but it might be a solution...)
 
 View user's profile Send private message  
Reply with quote Back to top
hopimetOffline
Post subject: Re: RE: Desktop size is too small  PostPosted: 16.03.2011, 19:20



Joined: 2010-10-13
Posts: 62
Location: France
Status: Offline
      finotti wrote:
Can you create a new user and log in to see if it will also have a problem in KDE? If not, it might be personal some configuration. In this case you can backup your KDE config dir and try to reconfigure again. (I know, it is a pain, but it might be a solution...)


That didn't solve the problem but gave informations.

The new user was not able to activate desktop effects and compositing. That's why I have this black bar on the bottom of my screen when cairo-dock is launched. Actually this is a black rectangle around cairo-dock which is due to the non-activation of compositing: I had this error message when I launched cairo for the fist time with the new user.

Again, the strange fact is that compositing is activated in xfce session.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio