Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Razgorov_Prikazka
15 Post subject: [SOLVED] Problem setting the time and timezone  PostPosted: 28.09.2010, 19:26



Joined: 2010-09-14
Posts: 9
Location: (City) Groningen (Province) Groningen (Country) The Netherlands
Hey all!

I got a bit of a problem setting the time and the time zone.
The BIOS time is set correctly, but the time on the system tray is two hours early.
When I try the easy way (system settings > time and date) I get the error:
      Code:
Unable to authenticate/execute the action: 4,

The same when I try to let it synchronize with a timeserver.
I set the timezone in .profile
      Code:
TZ='Europe/Amsterdam'; export TZ

and loged out and back in. No difference. So I tried (as root)
      Code:
root@siduxbox:/home/razgorov# date -s 21:24
Tue Sep 28 21:24:00 CEST 2010
root@siduxbox:/home/razgorov#

loged out, back in... nothing.

The time printed in with uptime is set correctly, so it seems to be a quirk in KDE or something.
      Code:
razgorov4@siduxbox:~$ uptime
21:28:14 up  5:22,  3 users,  load average: 0.73, 0.72, 0.88
razgorov@siduxbox:~$


So I am a bit out of options. Does anyone have an idea for me?

TIA!
Razgorov Prikazka


Last edited by Razgorov_Prikazka on 29.09.2010, 13:13; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arminOffline
Post subject:   PostPosted: 28.09.2010, 19:31



Joined: 2010-09-17
Posts: 4

Status: Offline
Did you try within kde:

      Code:
Alt-F2
kdesu systemsettings


Date & time --> timezone

Question
 
 View user's profile Send private message  
Reply with quote Back to top
lekaOffline
Post subject:   PostPosted: 28.09.2010, 21:53



Joined: 2010-09-20
Posts: 1

Status: Offline
Try as root "date mmddhhssyyyy"
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 28.09.2010, 23:27
Team Member


Joined: 2010-08-26
Posts: 258

Status: Offline
I suspect this is down to your system thinking the hardware clock is in UTC when in fact it is localtime (or vice-versa). The file /etc/default/rcS sets a UTC variable which tells the system if your clock is in localtime or UTC. If the clock is in localtime but this has UTC=yes then change it to UTC=no. If the hardware (bios) clock is UTC but the file says UTC=no then change it to UTC=yes. The second thing though is to run "dpkg-reconfigre tzdata" to make sure you have the correct timezone selected for your system. As long as these two things are right there should be no need to try to set the time with the date command
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject:   PostPosted: 29.09.2010, 00:01



Joined: 2010-09-12
Posts: 155
Location: Canada
Status: Offline
And one more way to get there from a root terminal: dbus-launch systemsettings
 
 View user's profile Send private message  
Reply with quote Back to top
Razgorov_Prikazka
Post subject:   PostPosted: 29.09.2010, 13:13



Joined: 2010-09-14
Posts: 9
Location: (City) Groningen (Province) Groningen (Country) The Netherlands
      armin wrote:

      Code:
Alt-F2
kdesu systemsettings

Date & time --> timezone
Question


some how I got the error:
      Code:
Unable to authenticate/execute the action: 6,

instead of Unable to authenticate/execute the action: 4. I closed system settings, checked my clock... and the correct time was set!

Thanks a bunch people!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
protector2020Offline
15 Post subject:   PostPosted: 20.03.2011, 17:17



Joined: 2011-03-20
Posts: 1

Status: Offline
      leka wrote:
Try as root "date mmddhhssyyyy"


ty it was very useful for me, a newbie
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio