Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
BlueJayofEvilOffline
Post subject: KDE SC 4.6 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 15.09.2010, 19:18



Joined: 2010-09-15
Posts: 5

Status: Offline
Update: I made a few minor tweaks to this guide to (hopefully) avoid some confusion. This guide works for KDE SC 4.6 (and should for any future KDE developments hosted in the repo it uses.) I tried this on a fresh install (and completely dist-upgraded.)

This is an unofficial, unsupported how-to for those who wish to try KDE SC 4.6.x on their systems. Do not try this unless you know what you are doing!
This how-to uses a third-party repo found at http://qt-kde.debian.net



Step 1
Add these lines to a .list file in /etc/apt/sources.list.d/
(e.g. /etc/apt/sources.list.d/kde.list)
      Code:
deb http://qt-kde.debian.net/debian experimental-snapshots main
deb-src http://qt-kde.debian.net/debian experimental-snapshots main


Step 2
      Code:
apt-get update

and then
      Code:
apt-get install pkg-kde-archive-keyring

then
      Code:
apt-get update


Step 3
Create or edit the /etc/apt/preferences file and add the following entries:
      Code:
Package: *
Pin: release a=unstable
Pin-Priority: 900

Package: *
Pin: release o=qt-kde,a=experimental-snapshots
Pin-Priority: 901


Step 4
Change to runlevel 3
      Code:
init 3

and then log in as root.

Step 5
      Code:
apt-get dist-upgrade

Check the list of packages to be installed, upgraded, and/or removed. If you agree with what it wants to do, confirm the upgrade.

Step 6
Either reboot or go back to runlevel 5.
You should now have KDE SC 4.6.x on your system.

_________________
AMD Phenom II x6 1100T
16GB DDR3 1333MHz RAM
Integrated Radeon HD 4250
PowerColor AMD Radeom HD 6970 PCS+
Realtek ALC892 Chipset
320GB EIDE & 3TB SATA III hard drives
LITE-ON iHBS212 optical drive


Last edited by BlueJayofEvil on 12.05.2011, 16:09; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 16.09.2010, 01:06



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Good write up for all who want to play with KDE SC 4.5.1

I have it installed and so far no major issues and it's pretty decent
 
 View user's profile Send private message  
Reply with quote Back to top
belzeOffline
Post subject: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 16.09.2010, 11:48



Joined: 2010-09-13
Posts: 100

Status: Offline
2 days with it and my cat is still alive!
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 16.09.2010, 16:51



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
      belze wrote:
2 days with it and my cat is still alive!


That's good to hear Smile
 
 View user's profile Send private message  
Reply with quote Back to top
LanziOffline
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 16.09.2010, 17:20



Joined: 2010-09-11
Posts: 126
Location: Hessen
Status: Offline
What about digikam and Gwenvies. Are theese upgraded as well? in Sid is still digicam 1.2

_________________
Urlaub im Harz? http://pension-grueneinsel.de
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 16.09.2010, 17:58



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
digicam is, no idea on gwenview.
the cat sits on the notebook with 4.5, so i cant check now Smile

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
dexterusOffline
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)  PostPosted: 17.09.2010, 00:02



Joined: 2010-09-16
Posts: 16

Status: Offline
Here's what I get:
      Code:

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  aptosid-art-kde aptosid-art-kde-keres aptosid-art-ksplash-keres
  aptosid-settings-kde kappfinder kde-minimal kde-window-manager 
  kdebase-workspace kdebase-workspace-bin libkephal4 libkonq5
  libplasmaclock4a libprocesscore4a libsolidcontrol4 libsolidcontrolifaces4
  libtaskmanager4a plasma-desktop plasma-widget-adjustableclock
  sidux-art-kde sidux-art-kde-moros sidux-art-ksplash-moros
  sidux-settings-kde
The following NEW packages will be installed:
  akonadi-backend-mysql docbook-xml freespacenotifier libcln6
  libdbusmenu-qt2 libkatepartinterfaces4 libkcmutils4 libkemoticons4
  libkephal4a libkidletime4 libkonq5a libkprintutils4 libplasmaclock4b
  libprocesscore4b libqalculate5 libsolidcontrol4a libsolidcontrolifaces4a
  libtaskmanager4b sgml-base sgml-data xml-core
The following packages will be upgraded:
  akonadi-server ark dolphin gwenview kate kcalc
  kdebase-apps kdebase-bin kdebase-data kdebase-runtime
  kdebase-runtime-data kdebase-workspace-data
  kdebase-workspace-kgreet-plugins kdegraphics-libs-data
  kdelibs-bin kdelibs5 kdelibs5-data kdelibs5-dev kdelibs5-plugins
  kdepasswd kdepimlibs-kio-plugins kdepimlibs5 kdm kdoctools kfind
  khelpcenter4 klipper konqueror konqueror-nsplugins konsole kppp
  ksnapshot ksysguard ksysguardd ktorrent kwrite libakonadi-contact4
  libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadiprivate1 libgpgme++2 libkabc4 libkblog4 libkcal4
  libkde3support4 libkdecorations4 libkdecore5 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkfile4 libkholidays4 libkhtml5 libkimap4
  libkimproxy4 libkio5 libkipi7 libkjsapi4 libkjsembed4 libkldap4
  libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkonq5-templates libkonqsidebarplugin4a
  libkontactinterface4 libkparts4 libkpimidentities4 libkpimtextedit4
  libkpimutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libksane0
  libkscreensaver5 libksgrd4 libksignalplotter4 libktexteditor4 libktnef4
  libkunitconversion4 libkutils4 libkwineffects1a libkworkspace4
  libkxmlrpcclient4 libmailtransport4 libmicroblog4 libnepomuk4
  libnepomukquery4a libokularcore1 libplasma-geolocation-interface4
  libplasma3 libplasmagenericshell4 libprocessui4a libqgpgme1 libsolid4
  libsyndication4 libthreadweaver4 libweather-ion4a okular
  oxygen-icon-theme plasma-dataengines-workspace
  plasma-desktopthemes-artwork plasma-scriptengine-javascript
  plasma-widget-folderview plasma-widgets-workspace systemsettings
113 upgraded, 21 newly installed, 22 to remove and 0 not upgraded.

Something tells me it would be not a good idea to proceed. Am I right? Thanks in advance. Smile
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 17.09.2010, 11:26



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
Here's what I saw:

      Code:
root@sidbox:/home/dibl# apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kappfinder libkephal4 libkonq5 libplasmaclock4a libprocesscore4a libsolidcontrol4 libsolidcontrolifaces4 libtaskmanager4a
The following NEW packages will be installed:
  akonadi-backend-mysql freespacenotifier libcln6 libdbusmenu-qt2 libkatepartinterfaces4 libkcmutils4 libkdewebkit5 libkemoticons4
  libkephal4a libkidletime4 libkonq5a libkprintutils4 libplasmaclock4b libprocesscore4b libqalculate5 libsolidcontrol4a
  libsolidcontrolifaces4a libtaskmanager4b
The following packages will be upgraded:
  akonadi-server ark dolphin foomatic-db-engine foomatic-filters foomatic-filters-ppds gwenview kate kcalc kde-window-manager
  kdebase-apps kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdebase-workspace kdebase-workspace-bin
  kdebase-workspace-data kdebase-workspace-kgreet-plugins kdegraphics-libs-data kdegraphics-strigi-plugins kdelibs-bin kdelibs5
  kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd kdepimlibs-kio-plugins kdepimlibs5 kdm kdoctools kfind
  khelpcenter4 kinfocenter klipper konqueror konsole kppp ksnapshot ksysguard ksysguardd ksystemlog kwrite libakonadi-kabc4
  libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadiprivate1 libgpgme++2 libkabc4 libkblog4 libkcal4 libkdcraw8
  libkde3support4 libkdecorations4 libkdecore5 libkdesu5 libkdeui5 libkdnssd4 libkexiv2-8 libkfile4 libkholidays4 libkhtml5
  libkimap4 libkimproxy4 libkio5 libkipi7 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq5-templates libkonqsidebarplugin4a libkparts4 libkpimidentities4
  libkpimtextedit4 libkpimutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libksane0 libkscreensaver5 libksgrd4
  libksignalplotter4 libktexteditor4 libktnef4 libkunitconversion4 libkutils4 libkwineffects1a libkworkspace4 libkxmlrpcclient4
  libmailtransport4 libmicroblog4 libnepomuk4 libnepomukquery4a libokularcore1 libplasma-geolocation-interface4 libplasma3
  libplasmagenericshell4 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libprocessui4a libqgpgme1 libsolid4
  libsyndication4 libthreadweaver4 libweather-ion4a okteta okular okular-extra-backends oxygen-icon-theme
  plasma-dataengines-workspace plasma-desktop plasma-desktopthemes-artwork plasma-scriptengine-javascript plasma-widget-folderview
  plasma-widgets-workspace policykit-1 systemsettings                                                                               
126 upgraded, 18 newly installed, 8 to remove and 0 not upgraded.                                                                   
Need to get 145MB of archives.                                                                                                       
After this operation, 44.0MB disk space will be freed.                                                                               
Do you want to continue [Y/n]


It seems to have installed with no issues. Desktop settings all remain untouched, compiz and conky work as expected, very nice!

Thanks BlueJayofEvil!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 17.09.2010, 15:37



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
kappfinder has been removed from KDE 4.5.x according to upstream as I inquired about it, and the other packages that were removed were replaced with new versions.
 
 View user's profile Send private message  
Reply with quote Back to top
d.v.e.Offline
Post subject:   PostPosted: 18.09.2010, 15:33



Joined: 2010-09-12
Posts: 7

Status: Offline
Upgrade done , all good Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
merlynOffline
Post subject:   PostPosted: 18.09.2010, 23:30



Joined: 2010-09-12
Posts: 76
Location: Brisbane, Australia
Status: Offline
I've installed this on my desktop system but will hold off installing it on my laptop for now.

Reasons so far being, (I've yet to spend a good deal of time with it).

1. Not so keen on the new layout of system settings, it's a little disjointed and cluttered to my way of thinking, the 4.4.x layout is a lot cleaner imho.

2. Not a big fan of the monochrome systray icons, the new 'info' icon is barely visible (except the highlights) on dark themes, scissors for klipper, ( = "cut" in my book).

2a. as the monochrome icons apply only to system/hardware 'utilities' and the tooltips still display the 'old colourful icons', (to date) it introduces visual inconsistencies.

Obviously the above points are purely subjective, (based on personal tastes), and other folks will be happy with the changes.

Other than that I'm happy with 4.5.x, and the upgrade path went smoothly.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 18.09.2010, 23:37



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
i would be happy with all monochrome icons and look forward for the other sections to follow.
i heard you can get the colourful ones back though, but didnt bother myself.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
kap4linOffline
Post subject:   PostPosted: 19.09.2010, 02:43



Joined: 2010-09-12
Posts: 6

Status: Offline
Anyone who upgraded to 4.5.1 with nvidia card and using the binary drivers? Any issues there?

_________________
ThinkPad T410:
2x Core i5 M540 @ 2.53 GHz, 4GB RAM, nVidia GT218 [NVS3100M], Intel Centrino Advanced-N 6200
(sidux) 2010-01 Hypnos
 
 View user's profile Send private message  
Reply with quote Back to top
ghstryderOffline
Post subject:   PostPosted: 19.09.2010, 03:57



Joined: 2010-09-12
Posts: 91
Location: Detroit
Status: Offline
      kap4lin wrote:
Anyone who upgraded to 4.5.1 with nvidia card and using the binary drivers? Any issues there?


7150M and current binary driver. No issues here.
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 19.09.2010, 04:34



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
No issues here with latest nVidia binary driver as well
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio