Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
wolvensongOffline
Post subject: Problem connecting to WPA encrypted network(Info Added)  PostPosted: 05.04.2011, 02:02



Joined: 2011-04-05
Posts: 3
Location: Buenos Aires, Argentina
Status: Offline
Hi There aptosidians Very Happy

Ive installed aptosid geras on an IBM Thinkpad T41

      Code:
Host/Kernel/OS  "aptosid-thinkpad" running Linux 2.6.37-0.slh.18-aptosid-686 i686 [ aptosid 2011-01 Γῆρας - kde-full - (201102052200) ]
CPU Info        Intel Pentium M clocked at [ 1600.000 MHz ]
Videocard       ATI Radeon Mobility M7 LW [Radeon Mobility 7500]  X.Org 1.7.7  [ 1024x768@60.0hz ]
Network cards   Intel 82540EP Gigabit
                AIRONET Wireless Cisco Aironet Wireless 802.11b
Processes 105 | Uptime 13min | Memory 168.0/1009.6MB | HDD FUJITSU MHT2040A Size 37GB (7%used) | GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v3.35



ifconfig displays the following related to my wlan card


      Code:
eth1      Link encap:Ethernet  HWaddr 00:0e:9b:2e:1d:1f 
          inet6 addr: fe80::20e:9bff:fe2e:1d1f/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:888 dropped:0 overruns:0 frame:888
          TX packets:50 errors:50 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:11212 (10.9 KiB)
          Interrupt:11 Base address:0x8000


Im trying to connect to a linksys wrt54g (ver.6) router with WPA2 personal encryption.

wpa-gui connects and disconnects constantly, and displays this error message

      Code:
- Disconnect event - remove keys


when trying to connect to the router via ceni I get the following

      Code:

Configuring interface eth1=eth1 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/bridge
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: using default driver type: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -s -B -P /var/run/wpa_supplicant.eth1.pid -i eth1 -D wext -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...
wpa_supplicant: waiting for "/var/run/wpa_supplicant.eth1.pid":  0 (max. 5)
wpa_supplicant: creating sendsigs omission pidfile: /lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.eth1.pid
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/eth1
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "Los_Teritos" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: enabling network block 0 -- OK

dhclient -v -pf /var/run/dhclient.eth1.pid -lf /var/lib/dhcp/dhclient.eth1.leases eth1
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth1/00:0e:9b:2e:1d:1f
Sending on   LPF/eth1/00:0e:9b:2e:1d:1f
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/000resolvconf                                                                                       
run-parts: executing /etc/network/if-up.d/mountnfs                                                                                             
run-parts: executing /etc/network/if-up.d/ntpdate                                                                                             
run-parts: executing /etc/network/if-up.d/openssh-server                                                                                       
run-parts: executing /etc/network/if-up.d/wpasupplicant

Press Enter key to continue ...



setting the wlan card in roam mode with ceni displays this

      Code:
Configuring interface eth1=eth1 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/bridge
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wait for wpa_cli to attach
wpa_supplicant: using default driver type: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -s -B -P /var/run/wpa_supplicant.eth1.pid -i eth1 -W -D wext -c /etc/wpa_supplicant/wpa-roam.conf
Starting /sbin/wpa_supplicant...
wpa_supplicant: waiting for "/var/run/wpa_supplicant.eth1.pid":  0 (max. 5)
wpa_supplicant: creating sendsigs omission pidfile: /lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.eth1.pid
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/eth1
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/000resolvconf
run-parts: executing /etc/network/if-up.d/mountnfs
run-parts: executing /etc/network/if-up.d/ntpdate
run-parts: executing /etc/network/if-up.d/openssh-server
run-parts: executing /etc/network/if-up.d/wpasupplicant
wpa_supplicant: /sbin/wpa_cli -B -P /var/run/wpa_action.eth1.pid -i eth1 -p /var/run/wpa_supplicant -a /sbin/wpa_action
Starting /sbin/wpa_cli...

Press Enter key to continue ...




iwlist command returns the following

      Code:
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

irda0     Interface doesn't support scanning.

eth1      Scan completed :
          Cell 01 - Address: 00:1C:10:2C:48:0C
                    ESSID:"Los_Teritos"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Quality=73/100  Signal level=-59 dBm  Noise level:0 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK


setting my network under WPA personal gets same error, setting it to WEP or non secured connects without any problems.

Any help is much appreciated


Wolf.
 
 View user's profile Send private message MSN Messenger ICQ Number 
Reply with quote Back to top
hunkirdowneOffline
Post subject: RE: Problem connecting to WPA encrypted network(Info Added)  PostPosted: 29.06.2011, 12:42



Joined: 2010-09-13
Posts: 19
Location: Texas Gulf Coast
Status: Offline
Just a shot in the dark, but what does your interfaces file look like? As root you can edit /etc/network/interfaces to look like the following.
      Quote:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-ssid Los_Teritos
wpa-psk ********


Replace the "********" with your wpa passkey.

From there you should be able to run dhclient as you have before but I usually just run the following as root.

      Code:
ifup eth1

provided eth1 is not up already or you will get an error. In that case...
      Code:
ifconfig eth1 down && ifup eth1


If you want a gui, try 'wicd' -- it has worked well for me in the past. However, on one distro (aptosid? -- maybe.) I had to comment out everything in my 'interfaces' file before I got it to work (said so in the instructions that I actually read for once Wink.

Final note: As root the following will make your 'interfaces' file invisible to others and make you slightly more secure.
      Code:
chmod 0600 /etc/network/interfaces


HTH,
HD
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio