Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LearnincurveOffline
Post subject: Problems with radeon HD 2400 on lappy.: X crashes frequently  PostPosted: 31.03.2011, 08:30



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
Hi all,

I've just done a fresh install of Aptosid on my acer Travelmate 6592 laptop which I use at work.

Previously used Sidux, which I hadn't updated since before the migration to Aptosid - hence the fresh install, fully d-u'd as per yesterday.

My problem is with the radeon HD 2400 XT graphics. I followed the instructions for installing using modeset=0 then adding th nonfree firmware and the system boots ok, but I originally
had big problems getting my dual monitor setup with 2nd monitor connected over DVI (identified by X as HDMI-0) to work. X crashed when initialising the dual monitor resolution. The aptosid room on irc was fantastic and with their help I managed to
(almost) solve this using a 30-screen.conf file in /etc/X11/xorg.conf.d/ PASTEBIN: http://paste.pocoo.org/show/363122/

The problem now is that if I DON'T use composite rendering X will crash immediately if I try to move or resize any window. Compositing is extremely slow and KDE turns it off after a while
- resulting in the inevitable crash the first time I try to move or resize anything. My workaround for the moment is to turn off as many effects as possible, but I still get thrown out many times a day.

I should add that I did try connecting the external monitor through VGA yesterday. This worked even without the 30-screen.conf file, but gave me the same problem that I experience now. I was unable to move or resize any windows.

I'm posting my Xorg.0.log including the entries from the last crash ending in failed to revalidate. PASTEBIN: http://paste.pocoo.org/show/363119/

and dmesg - indicating there is a problem with the drm framebuffer id PASTEBIN : http://paste.pocoo.org/show/363116/

also here is the output from infobash -v3 PASTEBIN: http://paste.pocoo.org/show/363120/

and $ cat /etc/modprobe.d/radeon-kms.conf
options radeon modeset=1

dpkg --status firmware-linux-nonfree PASTEBIN: http://paste.pocoo.org/show/363121/


I am wondering whether this might be a memory issue, as I think the video adapter uses some shared memory. If anyone can suggest a way to check this I'd be grateful.


If you need any more info please let me know.

Cheers!
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject: RE: Problems with radeon HD 2400 on lappy.: X crashes freque  PostPosted: 31.03.2011, 08:40
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
You might want to try turning the Composite Type from OpenGL to XRenderer in Systemsettings/Desktop Effects/Advanced.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
LearnincurveOffline
Post subject: RE: Problems with radeon HD 2400 on lappy.: X crashes freque  PostPosted: 31.03.2011, 10:10



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
Thanks Chris. I did initially try this but it just seemed to make compositing even slower.

The initial problem is to do with X crashing the first time I try to resize a window if I DON'T use compositing. A compositing desktop is only a workaround for this.

In the meantime I'll try your suggestion and report back.
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 31.03.2011, 10:24



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
First impression is that there is a lag, but it might be more stable. No crashes so far.
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 04.04.2011, 11:10



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
OK. A few days on and using XRender and I'm still getting crashes. Not as frequent, but I've been thrown out 3 times since starting work today. Anything else I can try? I read on another thread (from last year) that updating some packages from experimental might help?
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 06.04.2011, 07:16



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
This is really annoying. The lappy is my main work machine and I'm regularly thrown out of everything I'm doing. Can anyone shed more light on this?
 
 View user's profile Send private message  
Reply with quote Back to top
seasonsOffline
Post subject:   PostPosted: 09.04.2011, 16:27



Joined: 2010-09-13
Posts: 92

Status: Offline
Try turning acceleration off and see if that's the issue.
Option "NoAccel" "boolean"
Enables or disables all hardware acceleration.
The default is to enable hardware acceleration.
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 27.04.2011, 09:19



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
      Quote:
Try turning acceleration off and see if that's the issue.
Option "NoAccel" "boolean"


Thanks seaons, I didn't see this before nw as I was having dns problems for the aptosid domain earlier and have been away since.

As I'm still a little confused about the current way to configure xorg, can you say where this goes? I currently only have a xorg.conf.d/30-screen.conf

sections are Monitor and device so I put the line in device:

now looks like:

      Code:

#30-screen.conf
Section "Monitor"
         Identifier        "LVDS"
         Option            "Primary"      "true"
 EndSection

Section "Monitor"
         Identifier        "HDMI-0"
         Option            "RightOf"      "LVDS"
EndSection

Section "Device"
         Identifier       "ATI Radeon HD 2400 XT"
         Option           "Monitor-LVDS" "LVDS"
         Option           "Monitor-HDMI-0" "HDMI-0"
         Option           "NoAccel" "boolean"
EndSection

Cheers!

Marius
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 27.04.2011, 09:27



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
Evidently wrong place:

Xorg.0.log:

snip...
      Code:

 2034.807] (II) RADEON(0): [DRI2] Setup complete
[  2034.807] (II) RADEON(0): [DRI2]   DRI driver: r600
[  2034.807] (II) RADEON(0): Front buffer size: 13992K
[  2034.807] (II) RADEON(0): VRAM usage limit set to 39744K
[  2034.808] (==) RADEON(0): Backing store disabled
[  2034.808] (II) RADEON(0): Direct rendering enabled
[  2034.808] (II) RADEON(0): Setting EXA maxPitchBytes
[  2034.808] (II) EXA(0): Driver allocated offscreen pixmaps
[  2034.808] (II) EXA(0): Driver registered support for the following operations:
[  2034.808] (II)         Solid
[  2034.808] (II)         Copy
[  2034.808] (II)         Composite (RENDER acceleration)
[  2034.808] (II)         UploadToScreen
[  2034.808] (II)         DownloadFromScreen
[  2034.808] (II) RADEON(0): Acceleration enabled
 
 View user's profile Send private message  
Reply with quote Back to top
ToZOffline
Post subject:   PostPosted: 28.04.2011, 02:42



Joined: 2010-09-11
Posts: 26
Location: Toronto, Ontario, Canada
Status: Offline
I believe the correct syntax is:

Option "NoAccel" "true"
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 28.04.2011, 12:53



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
      ToZ wrote:
I believe the correct syntax is:

Option "NoAccel" "true"


Quite right ToZ, my bad.

Unfortunately still getting
      Code:
99106.218] (II) RADEON(0): Acceleration enabled


after changing /etc/X11/xorg.conf.d/30-screen.conf
to:

      Code:
#30-screen.conf
Section "Monitor"
         Identifier        "LVDS"
         Option            "Primary"      "true"
 EndSection

Section "Monitor"
         Identifier        "HDMI-0"
         Option            "RightOf"      "LVDS"
EndSection

Section "Device"
         Identifier       "ATI Radeon HD 2400 XT"
         Option           "Monitor-LVDS" "LVDS"
         Option           "Monitor-HDMI-0" "HDMI-0"
         Option           "NoAccel" "true"
EndSection
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 06.05.2011, 11:21



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
I still have this problem. If anyone can think of anything else to try, I'd be happy to know.
 
 View user's profile Send private message  
Reply with quote Back to top
GdV87Offline
Post subject:   PostPosted: 07.05.2011, 09:43



Joined: 2010-10-11
Posts: 63
Location: Italy
Status: Offline
I've exactly the same laptop (acer TravelMate 6592) and the same graphic card (ATI Mobility Radeon HD2400XT).
I'm using aptosid 64 bit with radeon free driver and I've the same problem: every time I plug in a second monitor, X crashes (I haven't tried yet to modify "30-screen.conf" file). However, with ATI proprietary driver that I used previously, the second monitor works flawlessly. On the other hand, with ATI proprietary driver, I've had other (minor) problems, such as: image tearing with moving windows, errors after stand-by and freezing after switching tty.
Nevertheless, if the second monitor is more important for you than these other problems, maybe you should give a try to the proprietary drivers.
Greetings

GdV87
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 12.05.2011, 11:55



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
Thanks GdV87. It's good to know I'm not alone. I can probably live with the occasional crash now if I save my work frequently enough. The last time I used ATI proprietary drivers they were a nightmare, so don't really want to go back.

The only time I get crashes now (with compositing enabled) is when I connect to an external session (VM or citrix) across both screens - then scroll.

In the meantime I eagerly install each update hoping the problem has been solved.

If anyone has a good workaround or solution I'd be very glad to hear!

M.
 
 View user's profile Send private message  
Reply with quote Back to top
LearnincurveOffline
Post subject:   PostPosted: 30.05.2011, 08:01



Joined: 2011-03-31
Posts: 12
Location: Stavanger
Status: Offline
I was really hoping this would be fixed with the new radeon driver which was in this morning's dist-upgrade. But sadly the behaviour is still there.

Does anyone have any new ideas to try?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio