Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
muchan
Post subject: [Solved] 2011-04-05 audacious will be removed  PostPosted: 05.04.2011, 00:04
Moderator


Joined: 2010-09-11
Posts: 468

Two libraries for audacious hit the sid earlier than the audacious package itself.

you can proceed d-u with holding either libaudcore1 or audacious, without audacious removed.

# apt-get update
# echo audacious hold | dpkg --set-selections
# apt-get dist-upgrade

later:
# echo audacious install | dpkg --set-selections

(here i386 repo. I don't know if 64bit has the same problem)


Last edited by muchan on 13.04.2011, 16:48; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
ovlOffline
Post subject:   PostPosted: 06.04.2011, 08:26



Joined: 2010-09-12
Posts: 6

Status: Offline
2011-04-06 - audacious was removed in amd64

      Code:

The following packages have unmet dependencies:
 audacious : Depends: audacious-plugins (>= 2.4.2) but 2.3+dfsg-1+b2 is to be installed


workaround: install audacious-plugins from experimental repo
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 06.04.2011, 10:38
Moderator


Joined: 2010-09-11
Posts: 468

      ovl wrote:
2011-04-06 - audacious was removed in amd64

      Code:

The following packages have unmet dependencies:
 audacious : Depends: audacious-plugins (>= 2.4.2) but 2.3+dfsg-1+b2 is to be installed


workaround: install audacious-plugins from experimental repo


hmmmm, audacious is not removed from the sid repo of amd64/i386,
and problem with libaudcore1 persists...

You mean audacious was removed on your d-u? = you didn't read warning, and you said "Yes" to remove it?
and then you wanted to install from sid and failed? and your workaround was to install from experimental?
if all is Yes, then OK. be it.

(you could downgrade libaudcore1 and libaudclient2 then you could install audacious from the sid )

IMHO for people holding audacious as 1st post, workaround is not neccessary.
 
 View user's profile Send private message  
Reply with quote Back to top
ovlOffline
Post subject:   PostPosted: 07.04.2011, 02:22



Joined: 2010-09-12
Posts: 6

Status: Offline
      Quote:
You mean audacious was removed on your d-u? = you didn't read warning, and you said "Yes" to remove it?

Yes, indeed.
But, having amd64 system, I don't have any problems with libaudcore1 and libaudclient2, the only problem was invalid version of audacious-plugins in sid repository. So, after d-u (and audacious removed), I installed audacious-plugins from experimental, and after that install audacious from sid. At the moment of writing audacious-plugins in sid repository still has version 2.3+dfsg-1+b2.

      Code:
~$ apt-cache policy audacious audacious-plugins libaudcore1 libaudclient2
libaudcore1:
  Installed: 2.4.4-1
  Candidate: 2.4.4-1
  Version table:
 *** 2.4.4-1 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
audacious:
  Installed: 2.4.4-1
  Candidate: 2.4.4-1
  Version table:
 *** 2.4.4-1 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
audacious-plugins:
  Installed: 2.4.3-1
  Candidate: 2.4.3-1
  Version table:
 *** 2.4.3-1 0
        100 /var/lib/dpkg/status
     2.3+dfsg-1+b2 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
libaudclient2:
  Installed: 2.4.4-1
  Candidate: 2.4.4-1
  Version table:
 *** 2.4.4-1 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
 
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 07.04.2011, 09:47
Moderator


Joined: 2010-09-11
Posts: 468

sure. the problem of libaudcore1 and libaudclient2, is that it removes sid version of audacious, and make impossible to install audacious from sid repository.
You don't have problem, because you have already removed it, and installed newer (unsupported) version.
it is very clear. 8)

{ edit: I did not notice when audacious 2.4.4-1 entered to sid.
and after it entered, the problem is -plugins, as ovl wrote above. He was right.
And yes, installing audacious-plugins from experimental is one solution. esp, when an user want to newly install audacious. }


Last edited by muchan on 09.04.2011, 17:44; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
seasonsOffline
Post subject:   PostPosted: 09.04.2011, 16:13



Joined: 2010-09-13
Posts: 92

Status: Offline
Hopefully, 2.5.0 will be out very soon (and hit the sid repo quickly). It is a really nice upgrade.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 13.04.2011, 16:50
Moderator


Joined: 2010-09-11
Posts: 468

new package of audacious-plugins is already on sid, and it completes the transition.
Now audiacious is installable without experimental repo.

marked [Solved]
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio