Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
oddballOffline
Post subject: Can't install gimp "broken packages" 64 bit Aptosi  PostPosted: 18.04.2011, 14:41



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
      Quote:
The following packages have unmet dependencies:
gimp : Depends: python-gtk2 (>= 2.8.0) but it is not going to be installed
E: Broken packages

I need gimp, how do I do?
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject: RE: Can  PostPosted: 18.04.2011, 14:53
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
      Code:
apt-get update && apt-get -f install
apt-get install python-gtk2 gimp

Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
oddballOffline
Post subject: Re: RE: Can  PostPosted: 18.04.2011, 14:59



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
      slam wrote:
      Code:
apt-get update && apt-get -f install
apt-get install python-gtk2 gimp

Greetings,
Chris
Sorry but it doesn't work.
      Quote:
The following packages have unmet dependencies:
python-gtk2 : Depends: python2.5-cairo but it is not installable
E: Broken packages
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject: RE: Re: RE: Can  PostPosted: 18.04.2011, 15:04
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Any holds? If so, remove them, dist-upgrade - and try again.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
oddballOffline
Post subject: RE: Re: RE: Can  PostPosted: 18.04.2011, 16:15



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
Doesn't help. It's a nearly new installation due to a new hd, only a few days old. Did d-u yesterday and now again, no difference. No holds.
 
 View user's profile Send private message  
Reply with quote Back to top
hefeeOffline
Post subject: RE: Re: RE: Can  PostPosted: 18.04.2011, 16:25



Joined: 2010-09-14
Posts: 26

Status: Offline
Than try to install the testing version:
      Code:

apt-get install gimp/testing python-gtk2/testing
 
 View user's profile Send private message  
Reply with quote Back to top
oddballOffline
Post subject: Re: RE: Re: RE: Can  PostPosted: 18.04.2011, 16:35



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
      hefee wrote:
Than try to install the testing version:
      Code:

apt-get install gimp/testing python-gtk2/testing
Doesn't work
 
 View user's profile Send private message  
Reply with quote Back to top
jacmoeOffline
Post subject: RE: Re: RE: Re: RE: Can  PostPosted: 18.04.2011, 16:53



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
Doesn't work here either.
I guess we just need to wait for python gtk to make it's way into sid?

I discovered KDE Krita as an (excellent) painterly alternative to Gimp, so there's something good in this too. Wink
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 18.04.2011, 17:36



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
Mine is not new, but here is what is working today:


      Code:
root@aptosidbox:/# apt-cache policy gimp
gimp:
  Installed: 2.7.3~git20110415
  Candidate: 2.7.3~git20110415
  Version table:
 *** 2.7.3~git20110415 0
        500 http://frickelplatz.de/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     2.6.11-2 0
        500 http://cdn.debian.net/debian/ unstable/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
root@aptosidbox:/# apt-cache policy python-gtk2
python-gtk2:
  Installed: 2.17.0-4+b1
  Candidate: 2.17.0-4+b1
  Version table:
 *** 2.17.0-4+b1 0
        500 http://cdn.debian.net/debian/ unstable/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 18.04.2011, 19:25
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Completely unsupported and unsupportable Gimp beta versions from 3rd party repos are really no topic in here.
As it is installable fine here with .de mirrors, I would suggest to simply use another mirror - or wait a day.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
oddballOffline
Post subject:   PostPosted: 18.04.2011, 19:32



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
      slam wrote:
Completely unsupported and unsupportable Gimp beta versions from 3rd party repos are really no topic in here.
As it is installable fine here with .de mirrors, I would suggest to simply use another mirror - or wait a day.
Greetings,
Chris
Thanks for your efforts slam but after changing to .de repo, a new du with some phyton gobjekt upgraded the situation is not better.
      Quote:
root@aptosidbox-T61:/home/vilde# apt-get install python-gtk2 gimp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-gtk2 : Depends: python2.5-cairo but it is not installable
Depends: python2.5-gobject but it is not installable
E: Broken packages
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 18.04.2011, 19:40
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
      Code:
apt-get purge python2.5-*

and try again.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
oddballOffline
Post subject:   PostPosted: 18.04.2011, 20:03



Joined: 2010-09-11
Posts: 108
Location: Skåne, Sweden
Status: Offline
It removed 4 things but without result, same problem. HMM wonder what I lost now, by accident I closed the terminal window so I couldn't copy what was removed
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 18.04.2011, 20:50
Moderator


Joined: 2010-09-11
Posts: 468

      oddball wrote:
It removed 4 things but without result, same problem. HMM wonder what I lost now, by accident I closed the terminal window so I couldn't copy what was removed


you have log files
/var/log/apt/term.log
/var/log/apt/history.log
/var/log/dpkg.log
 
 View user's profile Send private message  
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 18.04.2011, 21:22



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
After doing apt-get purge python2.5-*
I get this:
      Code:
The following packages will be REMOVED:
  apt-xapian-index* packagesearch* python-cups* python-cupshelpers* python-iniparse* python-pexpect*
  python-xapian* system-config-printer-udev*

Since I am not really sure how I get those things back, I'd rather wait for some magically solution.

Or can I just install them afterwards using this? ->
      Code:
apt-get install   apt-xapian-index* packagesearch* python-cups* python-cupshelpers* python-iniparse* python-pexpect*
  python-xapian* system-config-printer-udev*

Does apt-get take wildcards? Smile

Or is this a transition period?
I've installed Aptosid just a week ago - and been doing dist-upgrades three times (succesfully).
I really like Aptosid so far. Wink

<edit>
Seems related to the 'hold python' topic, doesn't it?
Since I installed Aptosid just recently, it was too late to hold anything. We just have to wait, right?
</edit>
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio