Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
kermOffline
15 Post subject: (solved) enabling external usb audio adapter  PostPosted: 25.04.2011, 02:02



Joined: 2011-01-03
Posts: 34

Status: Offline
Happy Easter to all.
Thank you to all admins; aptosid is working great for me.

I've connected a VANTEC NBA-200U USB External Audio Adapter, and connected to it a couple of old PC speakers. And I hoped it would "just work"
Sound continues to be routed through my internal audio card.

      Code:
root@debboxa:~# cat /proc/asound/cards
 0 [ICH5           ]: ICH4 - Intel ICH5
                      Intel ICH5 with ALC850 at irq 17
 1 [default        ]: USB-Audio - USB Sound Device       
                      USB Sound Device         at usb-0000:00:1d.2-2, full speed
root@debboxa:~#


I don't find pulseaudio on my aptosid system, so I'm guessing aptosid has a preferred way.

In KDE4 multimedia "sound and video configuration" my adapter is recognized as (USB Sound Device (USB audio). However, it refuses to play the test file through my adapter (but light on my adapter flashes).

The old speakers are functional. Device volume is set at half, and is unmuted.

I'll be grateful for suggestions on how to proceed.This is a very cool device, and I'm impatient to get it working.

Best regards,
kerm
 
 View user's profile Send private message  
Reply with quote Back to top
ShakaZOffline
Post subject: RE: enabling external usb audio adapter  PostPosted: 25.04.2011, 04:01



Joined: 2011-02-16
Posts: 67

Status: Offline
Did you try enabling other channels than the master volume in the Kmix mixer?
To enable pulseaudio I think you have to install libsdl1.2debian-pulseaudio.
apt-cache search pulseaudio, may help you find other relevant packages related to pulseaudio.
 
 View user's profile Send private message  
Reply with quote Back to top
kermOffline
Post subject:   PostPosted: 26.04.2011, 03:58



Joined: 2011-01-03
Posts: 34

Status: Offline
ShakaZ:

Thank you for replying.

"Did you try enabling other channels than the master volume in the Kmix mixer?"

Yes. the kmix window shows:
-that Intel ICH5 is the active card,
-that Surround, Center & LFE are muted.
-when I select the alternative USB sound as card, it shows only a PCM bar, with PCM capture selected.

From my reading today, I must set both the USB sound device, and the USB adapter, as 0 (default).
There must be a simple way to do that, but I haven't found it yet.
There are so many apps and modules, I'm confused.
Which is why I'd like to know what the aptosid way is to set up as I want to do.

As regards pulseaudio, I don't know if it's necessary to the aptosid way.

kerm
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 26.04.2011, 05:54



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
If you want the usb sound as device 0, you need a /etc/modprobe.d/mysound.conf with the following content:
      Code:

options snd-usb-audio index=0
options snd-hda-intel index=1


Last edited by towo on 26.04.2011, 08:41; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 26.04.2011, 07:42
Moderator


Joined: 2010-09-11
Posts: 468

index=9 -> index=0?
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 26.04.2011, 08:42



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
Huh, yes, i've edit my post.
 
 View user's profile Send private message  
Reply with quote Back to top
kermOffline
Post subject:   PostPosted: 26.04.2011, 20:07



Joined: 2011-01-03
Posts: 34

Status: Offline
Towo:

Thank you for replying.

Looks like a plan, but; I don't appear to have a "/mysound.conf" on my system.

      Code:
root@debboxa:/etc/modprobe.d# dir
aliases.conf              alsa-base.conf  fbdev-blacklist.conf  linux-sound-base_noOSS.conf  radeon-kms.conf
alsa-base-blacklist.conf  blacklist.conf  i915-kms.conf         nbd-client.conf              ueagle-atm.conf
root@debboxa:/etc/modprobe.d#


Suggestion, please?
It's suggested by my local linuxusers' group that I install and work with pulseaudio. But I don't want to stray from the aptosid "way" if not necessary.

kerm
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 26.04.2011, 21:27
Moderator


Joined: 2010-09-11
Posts: 468

      kerm wrote:

Suggestion, please?


if it does not appear, create it yourself with suggested content?
(if it is worse, you can delete it.)

{edited: typo }


Last edited by muchan on 27.04.2011, 00:07; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
kermOffline
Post subject:   PostPosted: 26.04.2011, 23:08



Joined: 2011-01-03
Posts: 34

Status: Offline
muchan:

Thank you. I'll do that.
It's been pointed out to me locally that I don't find /mysound.conf because it isn't there, I must create it.
I didn't understand.

I have another suggestion from a M$-admin: in BIOS, disable the internal soundcard. And booting, hope that the system will tunnel to the USB external adapter. Does that have any hope of success?

I'm really not trying to be annoying; I just have little understanding.

kerm
 
 View user's profile Send private message  
Reply with quote Back to top
kermOffline
Post subject: enabling external usb audio adapter: SOLVED  PostPosted: 27.04.2011, 04:38



Joined: 2011-01-03
Posts: 34

Status: Offline
Friends:

What keeps me optimistic is the belief that someone, somewhere, has an extremely simple solution to any IT-vexation I occasionally encounter.

Just because it was easy, I tried my M$-admin. friend's advice: I disabled the sound module in BIOS, and rebooted.

With KDE open, I asked VLC to play a music cd. It protested, and suggested I reinstall a newer (?) edition of VLC. I didn't bother.

I closed VLC and made the same request of juk.
A KDE window opened listing my sound cards, and inviting me to choose the one I wanted as default.
I chose my USB external audio adapter, and clicked OK, and "apply".
The window closed, and juk began to play the cd ... through my USB adapter.

There may be some very minor tweaking remaining, but:
Problem solved !

Thanks to all who replied.
Best regards,
kerm
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio