Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
siegekingOffline
15 Post subject: Problems... (solved)  PostPosted: 18.09.2010, 14:41



Joined: 2010-09-18
Posts: 10

Status: Offline
Due to ignorance I did a du with old sidux rep.
I had a few problems. I changed then to spline aptosid, but still the same:

# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Status-Informationen einlesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
apt-utils: Hängt ab: libapt-pkg4.10
debtags: Hängt ab: libapt-pkg4.10
ia32-libs-gtk: Hängt ab: ia32-libs (>= 20100914) ist aber nicht installiert
libapt-pkg-perl: Hängt ab: libapt-pkg4.10
libept1: Hängt ab: libapt-pkg4.10
nspluginwrapper: Hängt ab: ia32-libs (>= 2.4) ist aber nicht installiert
packagesearch: Hängt ab: libapt-pkg4.10
python-apt: Hängt ab: libapt-pkg4.10
E: Nicht-erfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.



DU mit -f ergibt:
....
Extrahiere Vorlagen aus Paketen: 95%apt-extracttemplates: error while loading shared libraries: libapt-pkg.so.4.10: cannot open shared object file: No such file or directory
debconf: apt-extracttemplates schlug fehl: Ungültiger Dateideskriptor
Extrahiere Vorlagen aus Paketen: 100%
(Lese Datenbank ... 141437 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke ia32-libs (aus .../ia32-libs_20100914_amd64.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/ia32-libs_20100914_amd64.deb (--unpack):
Versuche, »/usr/lib32/libnspr4.so.0d« zu überschreiben, welches auch in Paket ia32-libs-workaround-499043 0.0.1+squeeze1 ist
dpkg-deb: Unterprozess einfügen mit Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/ia32-libs_20100914_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Besten Dank für eure Hilfe


Last edited by siegeking on 18.09.2010, 16:36; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: Problems...  PostPosted: 18.09.2010, 15:23



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
try: dpkg --purge ia32-libs-workaround-499043 0.0.1+squeeze1 && apt-get -f install

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
siegekingOffline
Post subject:   PostPosted: 18.09.2010, 16:35



Joined: 2010-09-18
Posts: 10

Status: Offline
dpkg --purge ia32-libs-workaround-499043
&& apt-get install -f

did it!

Thank you very much!
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 18.09.2010, 16:47
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Moved to "Software" and out of "Upgrade Warnings", as this package was never recommended, nore in Debian Sid.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio