Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
daniel_roOffline
15 Post subject: [solved] romanian keyboard language (solved)  PostPosted: 07.01.2011, 17:37



Joined: 2011-01-07
Posts: 51
Location: Bacau - Romania
Status: Offline
Hello to everyone,

I am new to Aptosid. Did a quick search but could not find the answer, so I thought to bother you with the question, maybe someone asked before and you could give me a link. I have installed the sistem in romanian, I have Ro menus, but in OOffice, how can I write in romanian? Near the date, on the taskbar in the right it shows romanian but do not know how to write with ro characters.

Thanks.


Last edited by daniel_ro on 10.01.2011, 12:13; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
saxxonianOffline
Post subject: RE: romanian keyboard language  PostPosted: 07.01.2011, 19:19



Joined: 2010-09-11
Posts: 28
Location: Brasov, Romania
Status: Offline
Hi Daniel! Welcome to aptosid.
try this: In the systray (next to the date/clock) right click on the flag/language to open the Keyboard Layout menu.
Select an appropriate keyboard (mine is Generic 104-key PC)and from the available layouts on the left select Romania-ro and add it to the right.
Then select Romania-ro on the right (active layouts) and underneath it select Layout variant: Standard Cedilla and Label should be: ro .
In the command line beneath this you should have: setxkbmap -model pc104 -layout us,de,ro -variant ,,std_cedilla



kb-layout.png
 Description:
 Filesize:  65.82 KB
 Viewed:  14782 Time(s)

kb-layout.png


 
 View user's profile Send private message  
Reply with quote Back to top
daniel_roOffline
Post subject: RE: romanian keyboard language  PostPosted: 07.01.2011, 19:51



Joined: 2011-01-07
Posts: 51
Location: Bacau - Romania
Status: Offline
Thank you. It worked!!
 
 View user's profile Send private message  
Reply with quote Back to top
catalinusOffline
32 Post subject:   PostPosted: 19.01.2011, 21:23



Joined: 2010-09-12
Posts: 27
Location: Romania
Status: Offline
I am using xfce flavor, no Romanian install for me, but I'm glad to see two compatriots here!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
saxxonianOffline
Post subject:   PostPosted: 20.01.2011, 06:15



Joined: 2010-09-11
Posts: 28
Location: Brasov, Romania
Status: Offline
Hi catalinus, likewise glad.
used to use xfce few years ago, can't remember how, there is a way of typing -ro in xfce. maybe I will remember.
 
 View user's profile Send private message  
Reply with quote Back to top
dorinOffline
Post subject:   PostPosted: 20.01.2011, 09:21



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
@catalinus
On xfce:
1) Menu->Settings->Keyboard->Layout->Add and add the Romanian cedilla layout
and/or
2) rightClik on task-bar->Add New Items->Keyboard Layouts->Add and make the personal settings
Here are more then two.
Welcome to aptosid! Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
ConvBSDOffline
Post subject:   PostPosted: 20.01.2011, 19:26



Joined: 2010-09-16
Posts: 30

Status: Offline
At least three compatriots there ( including me ).
Va salut domnilor.
 
 View user's profile Send private message  
Reply with quote Back to top
dorinOffline
Post subject:   PostPosted: 21.01.2011, 06:45



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
In this tread we are 5 but are more in the forum and much more users.
Maybe we could make another tread in other section of the forum or a pool.
Also we can collaborate.
Vă salut pe toți!
 
 View user's profile Send private message  
Reply with quote Back to top
daniel_roOffline
Post subject:   PostPosted: 29.04.2011, 19:52



Joined: 2011-01-07
Posts: 51
Location: Bacau - Romania
Status: Offline
va salut si eu!
 
 View user's profile Send private message  
Reply with quote Back to top
saxxonianOffline
Post subject:   PostPosted: 30.04.2011, 18:48



Joined: 2010-09-11
Posts: 28
Location: Brasov, Romania
Status: Offline
hei Dan, salutare!
 
 View user's profile Send private message  
Reply with quote Back to top
sagerianOffline
Post subject:   PostPosted: 18.03.2012, 09:06



Joined: 2010-09-13
Posts: 5

Status: Offline
Salut baieti!

in aptosid 2011.03, I have the following problem: I can't install a proper Romanian language keyboard layout and it's variants.
In a default install, in "Add layout" dialog box I have three fields:
- limit selection by language: I choose Romanian
- Layout: I have German and Romanian here. Why would I need a German layout in Romanian language? Beats me. Anyway, I choose Romanian here.
- Variant: Default. Here I should just have Romanian layouts, and more than one. Cedilla, comma below etc. Default doesn't explain anything.
 
 View user's profile Send private message  
Reply with quote Back to top
RoEnOffline
Post subject:   PostPosted: 18.03.2012, 11:03
Team Member


Joined: 2010-08-26
Posts: 15

Status: Offline
http://wiki.aptosidusers.de/index.php?t ... t_hinzu%3F Wink
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
sagerianOffline
Post subject:   PostPosted: 18.03.2012, 15:02



Joined: 2010-09-13
Posts: 5

Status: Offline
      RoEn wrote:
http://wiki.aptosidusers.de/index.php?title=Wie_f%C3%BCge_ich_in_xcfe_ein_zus%C3%A4tzliches_Tastatur-Layout_hinzu%3F Wink


Yes, I also have a Romanian flag System Tray and in a text editor like Kate I can't type Romanian characters.
I'm telling you something has changed, this was working fine in the past versions.
I am using aptosid kde full, but it's obviously not full.

If I only knew how to install new keyboard layouts and where to get them, I can't just add them to the used layouts since they don't exist in my computer as files, or so I believe, since I can't choose them in System Settings - Input devices - Keyboard Layouts.
 
 View user's profile Send private message  
Reply with quote Back to top
dorinOffline
Post subject:   PostPosted: 18.03.2012, 17:17



Joined: 2011-01-20
Posts: 18
Location: Vatra Dornei, Romania
Status: Offline
@sagerian
1. This tread was mark as solved for xfce.
2. It's safe to use default option for Romanian. I use it because I'm not a type master.
For Romanian's characters I use RightAlt+The_desire_key(I,i,S,s,A,a,T,t,& Q,q) to obtain Î,î,Ă,ă,Ș,ș,Ț,ț, & Â,â.
Also I have Ctrl+LeftAlt+K for switch between layouts (defaults for KDE)
3. You don't need DE layout. Remove'it. Add or let the US as default. Useful for konsole.
For any help ask. You are welcome Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject:   PostPosted: 19.03.2012, 17:32
Team Member


Joined: 2010-08-26
Posts: 170

Why should one do it the easy way when he can get it through the difficult one...


The release notes:
Installation

It is recommended to set keymaps, locales and timezone before booting the live system to be installed, by selecting them from the boot menu [F2], [F3]. This way, locale settings propagate to all required places for the installed system and don't require cumbersome changes at several places.

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio