Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
chris_debianOffline
Post subject: X doesn't work, so can't install.  PostPosted: 01.05.2011, 07:03



Joined: 2011-05-01
Posts: 3

Status: Offline
Hi, all!

I've been using GNU/Debian for a very long time, but am new to aptosid. I downloaded the aptosid-2011-01-geras-xfce-i386-201102052006 image and it booted succesfully.

Unfortunately, I get an error from my Sun GDM-5410 CRT monitor saying that the display is 'out of range'. I've had this problem before, when installing some distros, but only after the installation has completed. I then just let the system boot and change to another tty and re-configure X at runlevel 3.

With aptosid, I can't even get the installation started, because as soon as an X session is started for the install, my monitor shuts down.

Is there a way for me to pass some kernel (or other) options at boot time, so that I get a 'safe' X configuration, therefore allowing me to start the install?

Any help really appreciated, a I'm keen to try aptosid.

Thanks,

Chris.
 
 View user's profile Send private message  
Reply with quote Back to top
pjnsmbOffline
Post subject:   PostPosted: 01.05.2011, 07:26



Joined: 2010-09-12
Posts: 18
Location: Solihull.U.K
Status: Offline
have a look at

http://manual.aptosid.com/en/cheatcodes ... cheatcodes
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 01.05.2011, 08:56



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
i would try with noedid

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
chris_debianOffline
Post subject:   PostPosted: 01.05.2011, 10:29



Joined: 2011-05-01
Posts: 3

Status: Offline
Thanks, guys.

What's 'noedid'? I couldn't see it listed with the other cheatcodes.

Cheers,

Chris.
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 01.05.2011, 10:47
Team Member


Joined: 2010-08-26
Posts: 254

Status: Offline
I've never heard of noedid, but edid is the name of the data provided by your monitor to tell the system what modes it supports. I guess it's not listed in the aptosid manual (for now anyway) as it's not an aptosid specific "cheatcode".

If that doesn't work for you there are more options to get into the system so you can install.

Depending what sort of video card you have setting "xmode" and "xrate" might let you set a good video mode for your monitor directly at boot time (I think Intel, AMD and NVidia cards should work this way, but not sure if any other cards would for now, for other cards "screen" and "vsync" will do something similar).

Just adding "3" to the command line at boot will make it boot into runlevel 3 which does not start X at all. From there you could either create an xorg config snippet to set the mode you need or just use the cli-installer to install from the command line and then go messing with creating whatever bit of X configuration you need after you boot into the install.

"xmodule=vesa" might work by forcing the system to use the vesa video driver which only has a much more limited set of modes. This does setup your system to not use the best driver for your device though, so I'd say it's best to try and figure out a good answer one of the other ways and only resort to this if you can't figure out how to fix up your X configuration and can live with the vesa driver in the meantime.

There are probably even more options I'm not thinking of, but hopefully one of these solutions will get you where you need to go. If not and you are posting again, please include the type of graphics device in your system as it can influence your options.
 
 View user's profile Send private message  
Reply with quote Back to top
chris_debianOffline
Post subject:   PostPosted: 01.05.2011, 12:00



Joined: 2011-05-01
Posts: 3

Status: Offline
These sound like good ideas. Unfortunately, because aptosid has incorrectly mapped my keyboard, I am not able to enter the 'noedid' string, because the 'n' and 'o' aren't available anywhere on my keyboard. Is there an alternative boot image somewhere, that I can try?

Cheers,

Chris.
 
 View user's profile Send private message  
Reply with quote Back to top
pjnsmbOffline
Post subject:   PostPosted: 01.05.2011, 12:39



Joined: 2010-09-12
Posts: 18
Location: Solihull.U.K
Status: Offline
have a look at the cheat codes again

' lang ' code looks like what you need

_________________
pjnsmb
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 01.05.2011, 20:44
Team Member


Joined: 2010-08-26
Posts: 254

Status: Offline
For the keyboard layout it's not looking at the cheatcodes that is required as looking at the menus on the bootscreen (available via the function keys which hopefully work for you). If the lang menu doesn't offer you a suitable option the keyboard sub-menu might. Yes choosing a lang or keyboard layout in the boot menu will change the layout without in boot menu itself so hopefully one of these will work for you, if not please tell us what keyboard layout you have (maybe even tell us anyway, I'm curious what layout doesn't give you an "n" or "o" anywhere).
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio