Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
mirixOffline
Post subject: [SOLVED] hplip will be removed  PostPosted: 04.05.2011, 09:40



Joined: 2010-10-25
Posts: 28

Status: Offline
Well, in my case (64-bit) hplip not only has been removed but it can not be reinstalled yet:

hplip:
Depends: libhpmud0 but it is not going to be installed
Depends: libsane-hpaio but it is not going to be installed
Depends: hplip-cups but it is not going to be installed

I had to download the drivers from here:

http://hplipopensource.com/hplip-web/index.html

And install them manually (more or less) as explained here:

http://koroshiyaitchy.wordpress.com/200 ... 80-series/

Of course, it does not work straightforwardly and one has to install new packages as demanded by the installer (mostly development files).

The main difference between these instructions and what I did, apart from the drivers' version, is that I had to --disable-network-build rather than enabling it due to unmet dependencies. Then it seems that the configuration tool selects by default the hpijs drivers, which do not work fine in my case. I needed reconfigure the printer to select the cups drivers from the cups administration web interface.

NOTE: My printer model is also all-in-one but way older than the one from the instructions. It works fine now. In addition if, as it was my case, you need to test several configurations before finding the working one, do not forget to make clean before make.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 05.05.2011, 06:06



Joined: 2010-09-11
Posts: 183

Status: Offline
Yes, hplip wants to be removed currently. You should watch such things that apt-get reports before the dist-upgrade and avoid dist-upgrading until this is fixed in the package dependencies.

The reason today is that libsnmp15 would be removed because of the currently missing up to date libperl5 library. This leads to a dependency issue with libsnmp15 that is hplip deoending on.
 
 View user's profile Send private message  
Reply with quote Back to top
deusdaraOffline
Post subject:   PostPosted: 05.05.2011, 12:48



Joined: 2010-09-17
Posts: 6

Status: Offline
Hi

Today after dist-upgrade hplip removed this morning. hpijs-cups was removed too.

Deusdara

_________________
[Mobo:Intel DG41CN][CPU:Intel Core2Duo E6400@2.13 GHz][RAM:2x1 GB 800
MHz DDR2 Kingston][GPU:Intel Graphics Media Accelerator X4500 onboard][HD:Seagate 500GB
SATA II][Fonte:Thermaltake 430 W][aptosid]
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 05.05.2011, 18:51



Joined: 2010-09-12
Posts: 25

Status: Offline
solved ?????

The following packages will be REMOVED::
clamtk hpijs hplip-cups libcairo-perl libgtk2-perl libhpmud0 libpango-perl libperl5.10 libsane-hpaio libsnmp15 pdl

sorry 64 bit

oldie
 
 View user's profile Send private message  
Reply with quote Back to top
ruebe99Offline
Post subject:   PostPosted: 05.05.2011, 20:03



Joined: 2010-09-11
Posts: 13

Status: Offline
yeah - again a nice misguiding info (like last weekend where a serious warning has been moved) - 'solved' is mutually not the right status
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 05.05.2011, 20:38
Moderator


Joined: 2010-09-11
Posts: 468

The previous thread about hplip problem was solved and marked as [solved] correctly.
http://aptosid.com/index.php?name=PNphp ... amp;t=1127

For new problem, (isn't it Perl transition related?) new thread is splited.

Beside, now, because of Perl transition, users are supposed not to do dist-upgrade,
http://aptosid.com/index.php?module=new ... amp;sid=26
      Quote:

The transition to X.Org 1.10 in sid has begun. DO NOT dist-upgrade so long as REMOVES are being shown, as doing so would remove the xserver video and input packages leaving you unable to start X.

Updates about this issue will be posted in the relevant thread in the "Upgrade Warnings" section of the forum here.

Additionally, the transition to Perl 5.12 has begun. Relevant details here [ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619117 ]. Again, DO NOT dist-upgrade so long as REMOVES are being shown. These transitions should be over shortly, so a little patience will go a long way in keeping your system up and running.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject:   PostPosted: 06.05.2011, 00:51
Moderator


Joined: 2010-09-11
Posts: 468

"Isn't it Perl transition related?"

Yes, it is.
hpijs and hplip depends libhpmud0,
which depends libsnmp15,
which depends libperl5.10,
which depends perl-base

so this split thread belongs to:
perl Wants to Remove Packages
http://aptosid.com/index.php?name=PNphp ... amp;t=1222
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 08.05.2011, 07:39



Joined: 2010-09-11
Posts: 183

Status: Offline
It is fixed now. hplip is not going to be removed anymore here (32bit)

The following packages will be REMOVED:
libperl5.10 (5.10.1-20)
virtualbox-ose-guest-x11 (4.0.4-dfsg-1+b1)
The following NEW packages will be installed:
libmtp-runtime (1.0.6-5)
libperl5.12 (5.12.3-6)
libxcb-util0 (0.3.8-1)
linux-headers-2.6.38-5.slh.3-aptosid-686 (2.6.38-31)
linux-image-2.6.38-5.slh.3-aptosid-686 (2.6.38-31)
The following packages will be upgraded:
...[cut]...
628 upgraded, 5 newly installed, 2 to remove and 0 not upgraded.
Need to get 5.080 kB/1.794 MB of archives.
After this operation, 243 MB of additional disk space will be used.
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 08.05.2011, 09:55



Joined: 2010-09-18
Posts: 17

Status: Offline
Not for me:
      Code:

The following packages will be REMOVED:
  aptosid-irc hpijs hplip hplip-cups hplip-gui irssi libdbd-mysql-perl libhpmud0 libperl5.10 libpurple0 libsane-hpaio libsnmp15
  mysql-client mysql-client-5.1 mysql-server mysql-server-5.1 qutecom
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject:   PostPosted: 08.05.2011, 10:06



Joined: 2010-11-27
Posts: 63

Status: Offline
Here (64 bit) i get this:

      Code:


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libperl5.10
The following NEW packages will be installed:
  cpp-4.6 dkms g++-4.6 gcc-4.6 libboost-program-options1.46.1 libperl5.12 libstdc++6-4.6-dev libxcb-util0
  linux-headers-2.6.38-5.slh.3-aptosid-amd64 linux-image-2.6.38-5.slh.3-aptosid-amd64 nvidia-kernel-dkms
The following packages will be upgraded:
  akonadi-server alsa-base alsa-utils anthy-common apt-conf-aptosid aptosid-archive-keyring aptosid-art-kde aptosid-art-kde-geras
  aptosid-art-kdm-geras aptosid-art-ksplash-geras aptosid-art-wallpaper aptosid-art-wallpaper-geras aptosid-irc
  aptosid-manual-common aptosid-manual-de aptosid-manual-en aptosid-scripts aptosid-settings-kde binutils blender ceni
  configure-cups cpp cpp-4.4 cpp-4.5 debconf debconf-i18n debconf-utils debhelper dictionaries-common distro-defaults dmakms dpkg
  dpkg-dev e2fslibs e2fsprogs elinks-lite fll-iso2usb g++ g++-4.4 g++-4.5 gcc gcc-4.4 gcc-4.4-base gcc-4.5 gcc-4.5-base
  gcc-4.6-base gfxboot-theme-aptosid gfxboot-themes-aptosid-2011-01-geras-core gir1.2-glib-2.0 gtk2-engines-qtcurve iceweasel
  infobash install-usb-gui irssi iso-codes k3b k3b-data kaffeine kdelibs-bin kdelibs5-data kdelibs5-plugins kdepimlibs-kio-plugins
  kdoctools kernel-remover kexec-tools lib32gcc1 lib32stdc++6 libaa1 libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4
  libakonadi-kde4 libakonadi-kmime4 libakonadiprivate1 libanthy0 libapache2-mod-perl2 libaudio2 libavahi-client3
  libavahi-common-data libavahi-common3 libavcodec52 libavdevice52 libavformat52 libavutil50 libboost-program-options1.42.0
  libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libcairo-perl libcomerr2 libcurses-perl libdb4.7 libdb4.8 libdpkg-perl
  libegl1-mesa libgcc1 libgfortran3 libgirepository-1.0-1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx
  libgl1-nvidia-alternatives libgl1-nvidia-glx libglib-perl libglu1-mesa libglu1-mesa-dev libglx-nvidia-alternatives libgomp1
  libgpgme++2 libgpgme11 libgphoto2-2 libgphoto2-port0 libgraphicsmagick3 libgstreamer0.10-0 libgtk2-perl libhtml-parser-perl
  libieee1284-3 libio-pty-perl libk3b6 libk3b6-extracodecs libkabc4 libkcal4 libkde3support4 libkdecore5 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkfile4 libkholidays4 libkhtml5 libkimap4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkldap4
  libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkontactinterface4 libkparts4
  libkpimidentities4 libkpimtextedit4 libkpimutils4 libkpty4 libkresources4 libkrosscore4 libktexteditor4 libktnef4
  libkunitconversion4 libkutils4 liblash3 liblcms1 libldap-2.4-2 liblocale-gettext-perl libmailtransport4 libmicroblog4 libmodplug1
  libmozjs2d libmpfr4 libnepomuk4 libnepomukquery4a libopenraw1 liborc-0.4-0 libpam-modules libpam-runtime libpam0g libpango-perl
  libpcap0.8 libpixman-1-0 libplasma3 libpostproc51 libpython3.2 libqgpgme1 libqt3-mt libqt4-assistant libqt4-core libqt4-dbus
  libqt4-declarative libqt4-designer libqt4-dev libqt4-gui libqt4-help libqt4-network libqt4-opengl libqt4-opengl-dev
  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test
  libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libquadmath0 libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-filter-mobiledev libreoffice-impress
  libreoffice-java-common libreoffice-kde libreoffice-l10n-it libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-writer libselinux1 libsnmp-base libsnmp15 libsolid4 libss2 libstdc++6 libstdc++6-4.4-dev
  libstdc++6-4.5-dev libsvga1 libsvn-java libsvn1 libswscale0 libsyndication4 libterm-readkey-perl libtext-charwidth-perl
  libtext-iconv-perl libthreadweaver4 libvte9 libwebkit-1.0-2 libwebkit-1.0-common libwpd-0.9-9 libwps-0.2-2 libwxbase2.8-0
  libwxgtk2.8-0 libxcb-render-util0 libxfixes3 libxine1-xvdr libxml-libxml-perl libxml-libxslt-perl libxmu6 libxmuu1
  linux-headers-2.6-aptosid-amd64 linux-image-2.6-aptosid-amd64 linux-sound-base locales mercurial mesa-common-dev nvidia-glx
  nvidia-kernel-source perl perl-base perl-modules python-cups python-gobject python-reportbug python-vte python-wxgtk2.8
  python-wxversion python3.2 python3.2-minimal qt4-qmake reportbug squashfs-tools sun-java6-bin sun-java6-jdk sun-java6-jre
  sun-java6-plugin ttf-opensymbol udev-config-aptosid uno-libs3 ure x11-utils x11proto-xext-dev xdg-browser-launcher xserver-common
  xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xulrunner-1.9.1


the removal of libperl5.10 is normal, correct?
 
 View user's profile Send private message  
Reply with quote Back to top
LanziOffline
Post subject:   PostPosted: 08.05.2011, 10:07



Joined: 2010-09-11
Posts: 126
Location: Hessen
Status: Offline
here on 64bit its getting better Wink

      Quote:

Die folgenden Pakete werden ENTFERNT:
libperl5.10 libpurple0 pidgin portmap virtualbox-ose-guest-x11


so, do we still need libperl5.10 libpurple0 ?

_________________
Urlaub im Harz? http://pension-grueneinsel.de
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 08.05.2011, 14:26



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
      Lanzi wrote:
here on 64bit its getting better Wink

      Quote:

Die folgenden Pakete werden ENTFERNT:
libperl5.10 libpurple0 pidgin portmap virtualbox-ose-guest-x11


so, do we still need libperl5.10 libpurple0 ?


libpurple0 is part of pidgin so you should wait if you want to keep pidgin
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 08.05.2011, 18:31
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      lab wrote:
Not for me:
      Code:

The following packages will be REMOVED:
  aptosid-irc hpijs hplip hplip-cups hplip-gui irssi libdbd-mysql-perl libhpmud0 libperl5.10 libpurple0 libsane-hpaio libsnmp15
  mysql-client mysql-client-5.1 mysql-server mysql-server-5.1 qutecom


lab, try changing your sources, or try doing

      Code:
apt-get update && apt-get dist-upgrade


apt-get update is a key factor before doing dist-upgrade

you shouldn't be seeing mysql-client mysql-client-5.1 mysql-server mysql-server-5.1 getting removed, I'm not seeing this and I rely on mysql for mythtv. On 4 of my computers mysql & mythtv don't want to be removed anymore
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 08.05.2011, 19:04



Joined: 2010-09-11
Posts: 183

Status: Offline
      Lanzi wrote:
      Quote:

Die folgenden Pakete werden ENTFERNT:
libperl5.10 libpurple0 pidgin portmap virtualbox-ose-guest-x11


so, do we still need libperl5.10 libpurple0 ?


As long as only libraries get removed, this should be no problem. Usually the dependencies from application packages are defined fine.

If you need pidgin, you should not dist-upgrade. If you do not use it, just note it in a text file "lost_packages.txt" or something like this, and check again the next days, if the application is installable again.

portmap is replaced by another package. (rpcbind if I remember correctly).

The only thing is, that I do not know if virtualbox-ose-guest-x11 is required. If you do not use virtualbox, it certainly is not required. But if you are using virtualbox, I do not know.
 
 View user's profile Send private message  
Reply with quote Back to top
LanziOffline
Post subject:   PostPosted: 08.05.2011, 19:47



Joined: 2010-09-11
Posts: 126
Location: Hessen
Status: Offline
I put perl on hold to keep pidgin.
Everything went well.

_________________
Urlaub im Harz? http://pension-grueneinsel.de
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio