Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
seasonsOffline
8 Post subject: [SOLVED] perl Wants to Remove Packages  PostPosted: 02.05.2011, 09:26



Joined: 2010-09-13
Posts: 92

Status: Offline
On 64-bit:
      Code:
$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  aspell ceni configure-debian debconf-i18n dictionaries-common dvdrip
  gmusicbrowser gtk2-ex-formfactory-perl intltool irssi
  libaudio-scrobbler-perl libcairo-perl libcurses-perl libcurses-ui-perl
  libdigest-sha1-perl libevent-perl libevent-rpc-perl libexpect-perl
  libglib-perl libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl
  libgstreamer-perl libgtk2-perl libhpmud0 libhtml-parser-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-message-perl
  libhttp-negotiate-perl libio-pty-perl liblocale-gettext-perl libpango-perl
  libperl5.10 libproc-processtable-perl libpurple0 libsnmp15
  libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl
  libtext-wrapi18n-perl libwww-perl libxml-parser-perl module-assistant
  myspell-de-de myspell-en-us pidgin xchat
The following packages will be upgraded:
  perl perl-base perl-modules
3 upgraded, 0 newly installed, 48 to remove and 0 not upgraded.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: perl Wants to Remove Packages  PostPosted: 02.05.2011, 14:23
Moderator


Joined: 2010-09-11
Posts: 468

holding perl-base was enough on my system.
# echo perl-base hold | dpkg --set-selections

(when solved:
# echo perl-base install | dpkg --set-selections
to proceed)
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: perl Wants to Remove Packages  PostPosted: 02.05.2011, 15:05



Joined: 2010-08-25
Posts: 689

Status: Offline
I strongly recommend against games with holding back packages (which always tend to get forgotten), is it really so painful just to omit upgrading for a mere day or two..?
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: perl Wants to Remove Packages  PostPosted: 02.05.2011, 15:45
Moderator


Joined: 2010-09-11
Posts: 468

I revert the hold after upgrade... so not forgotten... and so that I can see next time
if the problem is solved...
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: perl Wants to Remove Packages  PostPosted: 03.05.2011, 09:43
Moderator


Joined: 2010-09-11
Posts: 468

Sorry, I did not notice this announcement in the News section:
http://aptosid.com/index.php?module=new ... amp;sid=26
      Quote:

The transition to X.Org 1.10 in sid has begun. DO NOT dist-upgrade so long as REMOVES are being shown, as doing so would remove the xserver video and input packages leaving you unable to start X.

Updates about this issue will be posted in the relevant thread in the "Upgrade Warnings" section of the forum here.

Additionally, the transition to Perl 5.12 has begun. Relevant details here [ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619117 ]. Again, DO NOT dist-upgrade so long as REMOVES are being shown. These transitions should be over shortly, so a little patience will go a long way in keeping your system up and running.
 
 View user's profile Send private message  
Reply with quote Back to top
GdV87Offline
Post subject: RE: perl Wants to Remove Packages  PostPosted: 06.05.2011, 13:38



Joined: 2010-10-11
Posts: 63
Location: Italy
Status: Offline
Today d-u wants to remove only pidgin (which depends on perl-base >= 5.10.1-17), is it the same for you all too?

GdV87


Last edited by GdV87 on 06.05.2011, 13:41; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: perl Wants to Remove Packages  PostPosted: 06.05.2011, 13:40



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
still removes all this for me:

      Code:
The following packages will be REMOVED:
  hpijs hpijs-ppds hplip hplip-cups hplip-gui irssi irssi-scripts libhpmud0 libperl5.10 libpurple0 libsane-hpaio libsnmp15 pidgin
  pidgin-encryption pidgin-extprefs pidgin-guifications pidgin-musictracker pidgin-otr pidgin-plugin-pack pidgin-privacy-please pidgin-themes
  qutecom


so it may be quite a while before updated packages are uploaded
 
 View user's profile Send private message  
Reply with quote Back to top
LanziOffline
Post subject: RE: perl Wants to Remove Packages  PostPosted: 06.05.2011, 22:31



Joined: 2010-09-11
Posts: 126
Location: Hessen
Status: Offline
@Deep Daze:

Same here:
      Quote:

Die folgenden Pakete werden ENTFERNT:
gtk2-ex-formfactory-perl hpijs hpijs-ppds hplip hplip-cups hplip-gui libcairo-perl libgtk2-gladexml-perl libgtk2-perl libhpmud0 libpango-perl libperl5.10
libpurple0 libsane-hpaio libsnmp15 pidgin portmap slimrat virtualbox-ose-guest-x11

_________________
Urlaub im Harz? http://pension-grueneinsel.de
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
nowhiskeyOffline
Post subject:   PostPosted: 07.05.2011, 15:58



Joined: 2010-10-09
Posts: 14

Status: Offline
today the situation looks better here, but still some perl stuff will be removed. 32bit:

      Quote:
Die folgenden Pakete werden ENTFERNT:
libgstreamer-interfaces-perl libgstreamer-perl libperl5.10
Die folgenden NEUEN Pakete werden installiert:
cpp-4.6 g++-4.6 gcc-4.6 guile-1.8-libs libbse-0.7-4 libgd2-noxpm libmtp-runtime libperl5.12 libstdc++6-4.6-dev libxcb-util0 linux-headers-2.6.38-5.slh.3-aptosid-686
linux-image-2.6.38-5.slh.3-aptosid-686 puredata-core puredata-doc puredata-extra puredata-gui puredata-utils tk
Die folgenden Pakete sind zurückgehalten worden:
libgmp10 libgmpxx4ldbl libtar-dev
Die folgenden Pakete werden aktualisiert (Upgrade):
alsa-base alsa-utils apt-conf-aptosid aptosid-archive-keyring aptosid-art-xfce aptosid-art-xfce-apate aptosid-art-xsplash-apate aptosid-irc aptosid-scripts
aptosid-settings-xfce beast binutils ceni comerr-dev configure-cups cpp cpp-4.4 cpp-4.5 debconf debconf-i18n debconf-utils debhelper dictionaries-common
distro-defaults dpkg dpkg-dev e2fslibs e2fsprogs elinks-lite ffmpeg fll-iso2usb g++ g++-4.4 g++-4.5 gcc gcc-4.4 gcc-4.4-base gcc-4.5 gcc-4.5-base gcc-4.6-base
gfxboot-theme-aptosid gfxboot-themes-aptosid-2010-03-apate-core gir1.2-freedesktop gir1.2-glib-2.0 git git-core git-man gnumeric help2man iceweasel imagemagick
infobash install-usb-gui irssi iso-codes k3b k3b-data kaffeine kdelibs-bin kdelibs5-data kdelibs5-dev kdelibs5-plugins kdoctools kernel-remover kexec-tools
liba52-0.7.4 liba52-0.7.4-dev libaa1 libaa1-dev libaubio-dev libaubio2 libaudio-dev libaudio2 libavahi-client-dev libavahi-client3 libavahi-common-data
libavahi-common-dev libavahi-common3 libavahi-glib-dev libavahi-glib1 libavcodec-dev libavcodec52 libavdevice-dev libavdevice52 libavfilter-dev libavfilter1
libavformat-dev libavformat52 libavutil-dev libavutil50 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libcddb2 libcddb2-dev libcomerr2 libcurses-perl libdb4.7
libdb4.8 libdigest-sha1-perl libdjvulibre-text libdjvulibre21 libdpkg-perl libegl1-mesa libegl1-mesa-dev libgcc1 libgfortran3 libgirepository-1.0-1 libgl1-mesa-dev
libgl1-mesa-dri libgl1-mesa-glx libglib-perl libglu1-mesa libglu1-mesa-dev libgomp1 libgphoto2-2 libgphoto2-2-dev libgphoto2-port0 libgraphicsmagick3 libgtop2-7
libgtop2-common libhtml-parser-perl libieee1284-3 libieee1284-3-dev libio-pty-perl libiptcdata0 libjte1 libk3b6 libkde3support4 libkdecore5 libkdesu5 libkdeui5
libkdewebkit5 libkdnssd4 libkfile4 libkhtml5 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4
libkparts4 libkpty4 libkrosscore4 libkrossui4 libktexteditor4 libkunitconversion4 libkutils4 liblash-dev liblash3 liblcms1 liblcms1-dev libldap-2.4-2 libldap2-dev
liblocale-gettext-perl libmagick++3 libmagickcore3 libmagickwand3 libmimic0 libmlt++-dev libmlt++3 libmlt-data libmlt-dev libmlt4 libmodplug-dev libmodplug1
libmozjs-dev libmozjs2d libmpfr-dev libmpfr4 libmtp-dev libmtp8 libnepomuk4 libnepomukquery4a libnet-dbus-perl libopenraw1 liborc-0.4-0 liborc-0.4-dev libpam-modules
libpam-runtime libpam0g libpcap0.8 libperl-dev libpixman-1-0 libpixman-1-dev libplasma3 libpostproc-dev libpostproc51 libpq-dev libpq5 libproc-processtable-perl
libprojectm-dev libprojectm2 libqt3-mt libqt4-assistant libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-help libqt4-network libqt4-opengl
libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-webkit libqt4-xml libqt4-xmlpatterns
libqtcore4 libqtgui4 libquadmath0 libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-filter-mobiledev libreoffice-impress libreoffice-java-common libreoffice-math libreoffice-officebean libreoffice-style-galaxy libreoffice-writer
libselinux1 libselinux1-dev libsnmp-base libsnmp15 libsolid4 libss2 libstdc++6 libstdc++6-4.4-dev libstdc++6-4.5-dev libsvga1 libsvga1-dev libsvn1 libswscale-dev
libswscale0 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libthreadweaver4 libupower-glib1 libvte9 libwebkit-1.0-2 libwebkit-1.0-common libwpd-0.9-9
libwps-0.2-2 libwxbase2.8-0 libwxgtk2.8-0 libxcb-keysyms1 libxcb-keysyms1-dev libxcb-render-util0 libxcb-render-util0-dev libxfixes-dev libxfixes3 libxml-parser-perl
linux-headers-2.6-aptosid-686 linux-image-2.6-aptosid-686 linux-sound-base locales lv2core melt mesa-common-dev network-manager-gnome openshot perl perl-base
perl-modules pkg-kde-tools projectm-data puredata python-cairo python-cups python-glade2 python-gobject python-gobject-dev python-gst0.10 python-gtk2 python-gtk2-dev
python-gtksourceview2 python-notify python-pygoocanvas python-pyorbit python-tk qt4-qmake ristretto shotwell subversion thunar-volman ttf-opensymbol
udev-config-aptosid uno-libs3 ure vim vim-common x11-utils xchat xdg-browser-launcher xfce4 xfce4-panel xfce4-xkb-plugin xserver-common xserver-xorg-core
xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-fbdev
xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-vesa xserver-xorg-video-vmware xulrunner-1.9.1 xulrunner-dev


the 3 packages are in hold because of this one:

http://www.aptosid.com/index.php?name=P ... amp;t=1094


cheers,
doc
 
 View user's profile Send private message  
Reply with quote Back to top
hunkirdowneOffline
Post subject:   PostPosted: 07.05.2011, 16:41



Joined: 2010-09-13
Posts: 19
Location: Texas Gulf Coast
Status: Offline
I don't use Perl directly, but it is required for module-assistant which I need to build the kernel so my PCMCIA wireless card will work. I have two boxes on which aptosid is installed and this one (see, it's right here) is the one that I care most about so I await a more definitive notification that it's safe to get back in the water.

That said, the other box lost module-assistant but I was able, after a few updates, to get it back so Perl must be fixed at least to a certain degree. But X got trashed so all I have is a shell there -- but that's another topic.
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 07.05.2011, 17:17



Joined: 2010-09-12
Posts: 24

Status: Offline
MEZ 19:00 du - perl seems to be ok

oldie
 
 View user's profile Send private message  
Reply with quote Back to top
seasonsOffline
Post subject: Re: RE: perl Wants to Remove Packages  PostPosted: 07.05.2011, 17:43



Joined: 2010-09-13
Posts: 92

Status: Offline
      GdV87 wrote:
Today d-u wants to remove only pidgin (which depends on perl-base >= 5.10.1-17), is it the same for you all too?

Yes, I went ahead and updated today (64-bit). I'm sure pidgin will be updated by the next time I want to use it.
 
 View user's profile Send private message  
Reply with quote Back to top
CarnophageOffline
Post subject:   PostPosted: 07.05.2011, 17:43



Joined: 2010-09-12
Posts: 58

Status: Offline
      oldie wrote:
MEZ 19:00 du - perl seems to be ok

oldie

It all depends on the software installed.
Current migration status: http://release.debian.org/transitions/html/perl.html
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
oldieOffline
Post subject:   PostPosted: 07.05.2011, 19:07



Joined: 2010-09-12
Posts: 24

Status: Offline
nice site - for me - try to study instead - faster
 
 View user's profile Send private message  
Reply with quote Back to top
oddballOffline
Post subject:   PostPosted: 07.05.2011, 19:46



Joined: 2010-09-11
Posts: 107
Location: Skåne, Sweden
Status: Offline
Looks like finally I can do an d-u, libperl5.10 will be removed but probably the new installed libperl5.12 will replace the old one?
      Code:
Calculating upgrade... Done.
The following packages will be REMOVED:
  libperl5.10
The following NEW packages will be installed:
  libmtp-runtime libperl5.12 libxcb-util0
  linux-headers-2.6.38-5.slh.3-aptosid-686
  linux-image-2.6.38-5.slh.3-aptosid-686
The following packages will be upgraded:..................
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio