Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LatOffline
Post subject: Error setting Tx Power  PostPosted: 07.05.2011, 05:06



Joined: 2010-09-19
Posts: 169

Status: Offline
I'm getting the below in dmesg
      Code:
[   15.799035] iwl3945 0000:05:00.0: Error setting Tx power (-5).


Should I worry?
      Code:
05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
 
 View user's profile Send private message  
Reply with quote Back to top
nekosilvertailOffline
Post subject: RE: Error setting Tx Power  PostPosted: 07.05.2011, 14:42



Joined: 2011-02-11
Posts: 3

Status: Offline
I don't know if i should contribute, but i get something kind of related to his error, since the last upgrade ( i did today , from 2.6.36.0 Aptosid Geras kde full amd64 ) i get this dmesg:
http://paste.debian.net/116277/
Errors keeps coming up until i switch off my wireless.
as soon as i reconnect my wireless device - my network stops working
http://paste.debian.net/116278/

and: the error shows up again.
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: Error setting Tx Power  PostPosted: 08.05.2011, 00:07



Joined: 2010-09-19
Posts: 169

Status: Offline
nekosilvertail: my wireless do work. I don't have any "Failed to stop TX DMA in 100 msec after killing last frame".

I'm just curious of that Error setting TX power. Looks like http://svn.berlios.de/svnroot/repos/ful ... tion.patch has something to do and maybe (but probably is not related) http://svn.berlios.de/svnroot/repos/ful ... ging.patch

I can trigger it when I resume from sleep ( open the lid of the laptop ). Wireless works for like 5 secs then the wireless disconnects for seconds and reconnects. I'll post dmesg messages
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: Error setting Tx Power  PostPosted: 08.05.2011, 02:29



Joined: 2010-09-19
Posts: 169

Status: Offline
      Code:
[  348.262223] iwl3945 0000:05:00.0: Error setting Tx power (-5).
[  348.266865] PM: resume of devices complete after 2897.713 msecs
[  348.267223] Restarting tasks ... done.
[  348.280464] video LNXVIDEO:00: Restoring backlight state
[  349.797785] iwl3945 0000:05:00.0: Queue 4 stuck for 2000 ms.
[  349.797790] iwl3945 0000:05:00.0: On demand firmware reload
[  349.872129] iwl3945 0000:05:00.0: Error setting Tx power (-5).
[  349.987904] EXT4-fs (sda8): re-mounted. Opts: errors=remount-ro,barrier=0,commit=0
[  349.991398] EXT4-fs (sda6): re-mounted. Opts: commit=0,commit=0,commit=0,commit=0
[  363.049618] wlan0: deauthenticated from 00:16:b6:xx:xx:xx (Reason: 7)
[  363.077134] cfg80211: All devices are disconnected, going to restore regulatory settings
[  363.077146] cfg80211: Restoring regulatory settings while preserving user preference for: US
[  363.077157] cfg80211: Calling CRDA to update world regulatory domain
[  363.085322] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[  363.085328] cfg80211: World regulatory domain updated:
[  363.085331] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  363.085334] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.085338] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  363.085341] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  363.085344] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.085347] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.085365] cfg80211: Calling CRDA for country: US
[  363.091095] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
[  363.091100] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091104] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
[  363.091107] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091110] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
[  363.091113] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091116] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
[  363.091119] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091122] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
[  363.091125] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091128] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
[  363.091131] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091134] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
[  363.091137] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091139] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
[  363.091143] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091145] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
[  363.091148] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091151] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
[  363.091154] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091157] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
[  363.091160] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
[  363.091163] cfg80211: Updating information on frequency 5180 MHz for a 20 MHz width channel with regulatory rule:
[  363.091166] cfg80211: 5170000 KHz - 5250000 KHz @  KHz), (300 mBi, 1700 mBm)
[  363.091169] cfg80211: Updating information on frequency 5200 MHz for a 20 MHz width channel with regulatory rule:
[  363.091172] cfg80211: 5170000 KHz - 5250000 KHz @  KHz), (300 mBi, 1700 mBm)
[  363.091174] cfg80211: Updating information on frequency 5220 MHz for a 20 MHz width channel with regulatory rule:
[  363.091178] cfg80211: 5170000 KHz - 5250000 KHz @  KHz), (300 mBi, 1700 mBm)
[  363.091180] cfg80211: Updating information on frequency 5240 MHz for a 20 MHz width channel with regulatory rule:
[  363.091183] cfg80211: 5170000 KHz - 5250000 KHz @  KHz), (300 mBi, 1700 mBm)
[  363.091186] cfg80211: Updating information on frequency 5260 MHz for a 20 MHz width channel with regulatory rule:
[  363.091189] cfg80211: 5250000 KHz - 5330000 KHz @  KHz), (300 mBi, 2000 mBm)
[  363.091192] cfg80211: Updating information on frequency 5280 MHz for a 20 MHz width channel with regulatory rule:
[  363.091195] cfg80211: 5250000 KHz - 5330000 KHz @  KHz), (300 mBi, 2000 mBm)
[  363.091198] cfg80211: Updating information on frequency 5300 MHz for a 20 MHz width channel with regulatory rule:
[  363.091201] cfg80211: 5250000 KHz - 5330000 KHz @  KHz), (300 mBi, 2000 mBm)
[  363.091204] cfg80211: Updating information on frequency 5320 MHz for a 20 MHz width channel with regulatory rule:
[  363.091207] cfg80211: 5250000 KHz - 5330000 KHz @  KHz), (300 mBi, 2000 mBm)
[  363.091209] cfg80211: Updating information on frequency 5745 MHz for a 20 MHz width channel with regulatory rule:
[  363.091213] cfg80211: 5735000 KHz - 5835000 KHz @  KHz), (300 mBi, 3000 mBm)
[  363.091216] cfg80211: Updating information on frequency 5765 MHz for a 20 MHz width channel with regulatory rule:
[  363.091219] cfg80211: 5735000 KHz - 5835000 KHz @  KHz), (300 mBi, 3000 mBm)
[  363.091221] cfg80211: Updating information on frequency 5785 MHz for a 20 MHz width channel with regulatory rule:
[  363.091225] cfg80211: 5735000 KHz - 5835000 KHz @  KHz), (300 mBi, 3000 mBm)
[  363.091227] cfg80211: Updating information on frequency 5805 MHz for a 20 MHz width channel with regulatory rule:
[  363.091230] cfg80211: 5735000 KHz - 5835000 KHz @  KHz), (300 mBi, 3000 mBm)
[  363.091233] cfg80211: Updating information on frequency 5825 MHz for a 20 MHz width channel with regulatory rule:
[  363.091236] cfg80211: 5735000 KHz - 5835000 KHz @  KHz), (300 mBi, 3000 mBm)
[  363.091239] cfg80211: Regulatory domain changed to country: US
[  363.091242] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  363.091245] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[  363.091248] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[  363.091251] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.091255] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.091258] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  363.091261] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[  363.352000] iwl3945 0000:05:00.0: Error setting Tx power (-5).
[  363.353661] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  400.640663] wlan0: authenticate with 00:16:b6:xx:xx:xx (try 1)
[  400.642563] wlan0: authenticated
[  400.642618] wlan0: associate with 00:16:b6:xx:xx:xx (try 1)
[  400.645532] wlan0: RX AssocResp from 00:16:b6:xx:xx:xx (capab=0x411 status=0 aid=2)
[  400.645541] wlan0: associated
[  400.647923] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
I think everything in that log is fine, but the Tx setting error
 
 View user's profile Send private message  
Reply with quote Back to top
nekosilvertailOffline
Post subject: Re: RE: Error setting Tx Power  PostPosted: 08.05.2011, 23:15



Joined: 2011-02-11
Posts: 3

Status: Offline
      Lat wrote:
Wireless works for like 5 secs then the wireless disconnects for seconds and reconnects.


Yup, thats exactly my Problem.
I think i wait for the next kernel upgrade. If not fixed with that I'm trying for myself. So lets wait on

[EDIT]

found it.

      Quote:
commit 0d51cccc2436fa4d978efc3764552779e163d840
Author: Felix Fietkau <nbd>
Date: Fri Mar 11 21:38:18 2011 +0100

ath9k: fix stopping tx dma on reset

In some situations, stopping Tx DMA frequently fails, leading to messages
like this:

ath: Failed to stop TX DMA in 100 msec after killing last frame
ath: Failed to stop TX DMA!

This patch uses a few MAC features to abort DMA globally instead of iterating
over all hardware queues and attempting to stop them individually.
Not only is that faster and works with a shorter timeout, it also makes the
process much more reliable.

With this change, I can no longer trigger these messages on AR9380,
and on AR9280 they become much more rare.

Signed-off-by: Felix Fietkau <nbd>
Signed-off-by: John W. Linville <linville>


http://www.kernel.org/pub/linux/kernel/ ... 2.6.39-rc1
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: Re: RE: Error setting Tx Power  PostPosted: 14.05.2011, 20:34



Joined: 2010-09-19
Posts: 169

Status: Offline
I don't get the TX DMA errors. tho
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio