Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
pumrelOffline
Post subject:   PostPosted: 07.05.2011, 21:58



Joined: 2010-09-14
Posts: 117
Location: Czech Republic
Status: Offline
Ok, so I survived the dist-upgrade (on amd64) with perl5.12 replacing perl5.10. Everything is working just fine.

_________________
Petr
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
etorixOffline
Post subject:   PostPosted: 08.05.2011, 03:08
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
yeah, on amd64 this is pretty much over, apart from some HP [hplip] stuff
 
 View user's profile Send private message  
Reply with quote Back to top
merlynOffline
Post subject:   PostPosted: 08.05.2011, 03:50



Joined: 2010-09-12
Posts: 76
Location: Brisbane, Australia
Status: Offline
Just completed a dist-upgrade on 32bit, no removals whatsoever, the only replacement being libperl5.12 for libperl 5.10.

Everything is Dinky Di.

Cheers.
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 08.05.2011, 07:24
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
All problems solved here on amd64 (with several removals before), simply did:
      Code:
apt-get update && apt-get install libperl5.12 hplip hplip-gui hplip-doc

hplip is working again.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
gerdOffline
Post subject:   PostPosted: 08.05.2011, 08:24



Joined: 2010-09-13
Posts: 94

Status: Offline
Not all problems. At least pidgin still is to be removed...
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 08.05.2011, 08:27
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Yep, pidgin still depends on the outdated libperlapi5.10.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 08.05.2011, 09:51



Joined: 2010-09-18
Posts: 17

Status: Offline
Seems some mysql packages as well:

      Code:

The following packages will be REMOVED:
  aptosid-irc hpijs hplip hplip-cups hplip-gui irssi libdbd-mysql-perl libhpmud0 libperl5.10 libpurple0 libsane-hpaio libsnmp15
  mysql-client mysql-client-5.1 mysql-server mysql-server-5.1 qutecom
 
 View user's profile Send private message  
Reply with quote Back to top
hunkirdowneOffline
Post subject:   PostPosted: 08.05.2011, 16:35



Joined: 2010-09-13
Posts: 19
Location: Texas Gulf Coast
Status: Offline
      oddball wrote:
Looks like finally I can do an d-u, libperl5.10 will be removed but probably the new installed libperl5.12 will replace the old one?
That is my understanding. Saw the same thing last night but waiting on something else before I "punch the monkey".

While a little frustrating this (and other) package issue has taught me a thing or two so all in all I'm happy to be here. Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 08.05.2011, 18:17
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      lab wrote:
Seems some mysql packages as well:

      Code:

The following packages will be REMOVED:
  aptosid-irc hpijs hplip hplip-cups hplip-gui irssi libdbd-mysql-perl libhpmud0 libperl5.10 libpurple0 libsane-hpaio libsnmp15
  mysql-client mysql-client-5.1 mysql-server mysql-server-5.1 qutecom


I don't see this anymore with the mysql packages and will probably do a du today as mysql and mythtv don't want to be removed anymore (at least on this end)


      Code:
The following packages will be REMOVED:
  libperl5.10 virtualbox-ose-guest-x11
The following NEW packages will be installed:
  libperl5.12 libxcb-util0 linux-headers-2.6.38-5.slh.3-aptosid-686 linux-image-2.6.38-5.slh.3-aptosid-686
The following packages will be upgraded:
  alsa-base alsa-utils binutils cvs dictionaries-common dpkg dpkg-dev e2fslibs e2fsprogs elinks-lite gir1.2-glib-2.0
  gtk2-engines-qtcurve imagemagick irssi iso-codes k3b k3b-data kaffeine kde-style-qtcurve kdelibs-bin kdelibs5 kdelibs5-data
  kdelibs5-plugins kdepimlibs-kio-plugins kdoctools kwin-style-qtcurve liba52-0.7.4 libaa1 libakonadi-kabc4 libakonadi-kcal4
  libakonadi-kde4 libakonadi-kmime4 libaudio2 libboost-program-options1.42.0 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686
  libcairo-perl libcomerr2 libcrypt-ssleay-perl libcurses-perl libdatetime-perl libdb4.7 libdb4.8 libdbd-mysql-perl libdbi-perl
  libdpkg-perl libfcgi-perl libfile-libmagic-perl libftdi1 libgirepository-1.0-1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx
  libgl1-nvidia-alternatives libgl1-nvidia-glx libglib-perl libglu1-mesa libglx-nvidia-alternatives libgpgme11 libgpod4-nogtk
  libgraphicsmagick3 libgtk2-perl libhtml-parser-perl libieee1284-3 libimobiledevice1 libio-pty-perl libio-socket-ssl-perl
  libk3b6 libk3b6-extracodecs libkabc4 libkcal4 libkde3support4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkfile4 libkholidays4 libkhtml5 libkimap4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4
  libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpimutils4 libkpty4 libkresources4 libkrosscore4
  libkrossui4 libktexteditor4 libkunitconversion4 libkutils4 liblash3 liblcms1 libldap-2.4-2 liblist-moreutils-perl
  liblocale-gettext-perl libmagickcore3 libmagickwand3 libmailtransport4 libmicroblog4 libmpfr4 libmtp8 libmyth-0.24-0
  libmythavcodec52 libmythavcore0 libmythavformat52 libmythavutil50 libmythpostproc51 libmythswscale0 libnepomuk4
  libnepomukquery4a libnet-ssleay-perl libogg0 libossp-uuid-perl libossp-uuid16 libpam-modules libpam-runtime libpam0g
  libpango-perl libparams-validate-perl libplasma3 libplist1 libqt4-dbus libqt4-designer libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-webkit libqt4-xml libqtcore4
  libqtgui4 libselinux1 libsnmp-base libsnmp15 libsolid4 libss2 libsvga1 libsvn-perl libsvn1 libsyndication4 libterm-readkey-perl
  libtext-charwidth-perl libtext-iconv-perl libthreadweaver4 libwxbase2.8-0 libwxgtk2.8-0 libxcb-keysyms1 libxml-libxml-perl
  libxml-parser-perl libyaml-syck-perl linux-headers-2.6-aptosid-686 linux-image-2.6-aptosid-686 linux-sound-base locales
  mercurial mesa-common-dev **removed** mythtv mythtv-backend mythtv-common mythtv-database mythtv-frontend nvidia-glx
  nvidia-kernel-dkms nvidia-kernel-source nvidia-vdpau-driver perl perl-base perl-modules python-cups python-gobject
  python-mythtv python-pyvorbis python-wxgtk2.8 python-wxversion qtcurve reprepro subversion sun-java6-bin sun-java6-jre
  sun-java6-plugin vim vim-common x11-utils xserver-common xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
  xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo
237 upgraded, 4 newly installed, 2 to remove and 0 not upgraded.
Need to get 297 MB of archives.
After this operation, 159 MB of additional disk space will be used.
Do you want to continue [Y/n]?
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 08.05.2011, 23:13



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Today just libperl5.10 to be removed so I let that go...everything's good on my end now
 
 View user's profile Send private message  
Reply with quote Back to top
hightimeOffline
Post subject:   PostPosted: 09.05.2011, 03:24



Joined: 2010-09-11
Posts: 14
Location: USA
Status: Offline
I ran a d-u on 64-bit today. Only a couple of problems. First, I let it remove pdftk (not sure that it's due to a perl dependency or not). Hope it gets fixed soon.

The second problem is with spamassassin 3.3.1. Under perl5.12 a line in Check.pm causes a warning. This causes a glitch in retrieving mail and you get the same message retrieved over and over. You also get a lot of email about the failure in the fetch process. The error is
      Code:

warn: Use of "goto" to jump into a construct is deprecated at
/usr/share/perl5/Mail/SpamAssassin/Plugin/Check.pm line 409.

Fedora encountered this problem last fall when they were pushing out perl5.12. They are using spamassassin 3.3.2 from SVN. I tried simply copying the Check.pm file from that version, but it generates other errors.
 
 View user's profile Send private message  
Reply with quote Back to top
gandiaOffline
Post subject:   PostPosted: 09.05.2011, 06:21



Joined: 2011-04-15
Posts: 4

Status: Offline
good morning,

      Quote:
Die folgenden Pakete werden ENTFERNT(removed):
guile-1.8-slib libperl5.10 libxml-sablot-perl perl-suid


is it save to let them go? or is it better to wait a while longer for a d-u?

greetz
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 09.05.2011, 06:25



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
you can purge libperl5.10, install libperl5.12 and do another dist-upgrade-d to check for removals

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
gandiaOffline
Post subject:   PostPosted: 09.05.2011, 06:42



Joined: 2011-04-15
Posts: 4

Status: Offline
an
      Quote:
apt-get remove --purge -s libperl5.10 && apt-get install libperl5.12
shows also
      Quote:
Die folgenden Pakete werden ENTFERNT:
libperl5.10* libxml-sablot-perl* perl-suid*
looks like the same to me, so let them go???

greetz
gandia
 
 View user's profile Send private message  
Reply with quote Back to top
nowhiskeyOffline
Post subject:   PostPosted: 09.05.2011, 11:40



Joined: 2010-10-09
Posts: 14

Status: Offline
i just did an d-u and let the libgstreamer-interfaces-perl libgstreamer-perl get removed cause i am pretty sure that i do not need them really. everything else perl related went smoothly.

cheers,
doc
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio