Post new topic   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Author Message
kermOffline
Post subject: k3b & HAL impasse  PostPosted: 16.06.2011, 19:23



Joined: 2011-01-03
Posts: 34

Status: Offline
Friends:

I've been regularly dist-upgrading (like twice a week) this last month.

I'd like to use k3b, but seem to be at an impasse. k3b demands hal.
I fear doing more harm than good by reinstating hal.If I delete hal, I don't know if k3b will auto-switch to udev. Nor do I know how to tell it.

I'll be grateful for advice. Move forward? Move back? Park and wait for the path to clear?

chuk
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 16.06.2011, 20:31



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
Something strange -- I see no such dependency:

      Code:
root@aptosidbox:/home/don# apt-cache policy k3b
k3b:
  Installed: 2.0.2-2
  Candidate: 2.0.2-2
  Version table:
 *** 2.0.2-2 0
        500 http://cdn.debian.net/debian/ unstable/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     1.70.0~beta1+svn1083614 0
        500 http://frickelplatz.de/debian/ sid/main amd64 Packages
root@aptosidbox:/home/don# apt-cache depends k3b
k3b
  Depends: kdebase-runtime
  Depends: libc6
  Depends: libgcc1
  Depends: libk3b6
  Depends: libkcddb4
  Depends: libkde3support4
  Depends: libkdecore5
  Depends: libkdeui5
  Depends: libkfile4
  Depends: libkio5
  Depends: libknotifyconfig4
  Depends: libkparts4
  Depends: libkutils4
  Depends: libmusicbrainz4c2a
  Depends: libqt4-dbus
  Depends: libqt4-network
  Depends: libqt4-qt3support
  Depends: libqt4-svg
  Depends: libqt4-xml
  Depends: libqtcore4
  Depends: libqtgui4
  Depends: libqtwebkit4
  Depends: libsolid4
  Depends: libstdc++6
  Depends: k3b-data
 |Depends: wodim                                                                                                                     
  Depends: cdrskin                                                                                                                   
  Depends: cdparanoia                                                                                                               
  Depends: cdrdao                                                                                                                   
  Depends: genisoimage                                                                                                               
  Suggests: k3b-extrathemes                                                                                                         
  Suggests: k3b-i18n                                                                                                                 
  Suggests: normalize-audio                                                                                                         
  Suggests: sox                                                                                                                     
  Suggests: movixmaker-2                                                                                                             
  Recommends: libk3b6-extracodecs                                                                                                   
  Recommends: dvd+rw-tools                                                                                                           
  Recommends: vcdimager                                                                                                             
  Replaces: k3b-data                                                                                                                 
root@aptosidbox:/home/don#


Tell more -- what do you see?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
kermOffline
Post subject:   PostPosted: 17.06.2011, 19:51



Joined: 2011-01-03
Posts: 34

Status: Offline
dibl:

Thank you for replying.

I see exactly what you saw and reported.

(Whining). Also, I see when I open k3b, a popup:
"System Configuration Problems - K3b
1 problem.
No optical drive found.
K3b did not find any optical device in your system.
Solution: Make sure HAL daemon is running, it is used by K3b for finding devices."

K3b will do all its other neat stuff. But it won't see the burner and burn.

kerm
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 17.06.2011, 20:04



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
The issue shows up when you run k3b, but I don't think it is a k3b issue. Use ps to check your list of running processes. You need to see most of these:


      Code:
102      10803  0.0  0.0  58944  3988 ?        Ssl  11:01   0:00 /usr/sbin/hald
root     10804  0.0  0.0  36396  1728 ?        S    11:01   0:00 hald-runner
root     10833  0.0  0.0  38512  1600 ?        S    11:01   0:01 hald-addon-input: Listening on /dev/input/event1 /dev/input/event0 /
dev/input/event7 /dev/input/event2 /dev/input/event3 /dev/input/event5
root     10855  0.0  0.0  38508  1604 ?        S    11:01   0:00 hald-addon-storage: polling /dev/sdf (every 2 sec)
root     10858  0.0  0.0  38520  1596 ?        S    11:01   0:00 /usr/lib/hal/hald-addon-cpufreq
102      10859  0.0  0.0  26440  1284 ?        S    11:01   0:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root     10860  0.0  0.0  38508  1608 ?        S    11:01   0:01 hald-addon-storage: polling /dev/sr0 (every 2 sec)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
bfreeAdministrator
Post subject:   PostPosted: 17.06.2011, 20:55
Team Member


Joined: 2010-08-26
Posts: 251

Status: Online!
I don't get it. I can run k3b just fine and nothing from hal is running.

I even just removed hal and hal-info from my system and nothing changed (and it didn't remove anything else).

Have a look at what apt says if you ask it to remove all your hal packages, odds are you can just let them go (and hopefully then k3b will unconfuse itself).
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 17.06.2011, 21:11



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
If you google "k3b hal daemon" you'll see a lot of issues in other distros, same problem. I found this Debian bug from last year: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574032
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 17.06.2011, 21:50



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
simulating removal of all hal packages craps out:
      Code:
root@aptosidbox:/home/devil# LANG=C apt-get purge hal hal-info libhal-storage1 libhal1 libkephal4 libkephal4abi1 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdebase-workspace-bin : Depends: libkephal4abi1 (= 4:4.6.3-1) but it is not going to be installed
                         Depends: libplasmagenericshell4 (= 4:4.6.3-1) but it is not going to be installed
                         Depends: plasma-desktop (= 4:4.6.3-1) but it is not going to be installed or
                                  plasma-netbook (= 4:4.6.3-1) but it is not going to be installed
                         Recommends: plasma-scriptengines but it is not going to be installed
E: Broken packages


greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeAdministrator
Post subject:   PostPosted: 17.06.2011, 22:18
Team Member


Joined: 2010-08-26
Posts: 251

Status: Online!
devil: libkephal4 and libkephal4abi1 have nothing to do with hal and kdebase-workspace-bin depends on libkephal4abi1 so it's no surprise your command failed.

I've confirmed with two others that removing hal should not be an issue, one did it a while ago and the other just checked now.
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeAdministrator
Post subject:   PostPosted: 17.06.2011, 22:25
Team Member


Joined: 2010-08-26
Posts: 251

Status: Online!
      dibl wrote:
I found this Debian bug from last year: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574032

Emphasis mine.

The latest information on that bug is from before the last Debian release. Since then kde 4.6 has arrived and dependencies on hal have been eradicated.
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 17.06.2011, 22:44



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
I took out libkephal4 and libkephal4abi1 from devil's list, and tried:


      Code:
root@aptosidbox:/home/don# apt-get purge  hal hal-info libhal-storage1 libhal1 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  gimp* gimp-plugin-registry* hal* hal-info* hwinfo* libhal-storage1* libhal1* libhd16*
0 upgraded, 0 newly installed, 8 to remove and 1 not upgraded.
Purg gimp-plugin-registry [2:3.5.2-1~frickel-1]
Purg gimp [2.7.3~git20110415]
Purg hal [0.5.14-6]
Purg hal-info [20091130-1]
Purg hwinfo [16.0-2]
Purg libhal-storage1 [0.5.14-6]
Purg libhd16 [16.0-2]
Purg libhal1 [0.5.14-6]
root@aptosidbox:/home/don#


That doesn't look desirable -- I need gimp. What do I not understand?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
x-un-i
Post subject:   PostPosted: 17.06.2011, 22:57
Team Member


Joined: 2010-08-26
Posts: 170

      dibl wrote:
I took out libkephal4 and libkephal4abi1 from devil's list, and tried:


      Code:
root@aptosidbox:/home/don# apt-get purge  hal hal-info libhal-storage1 libhal1 -s
...
The following packages will be REMOVED:
  gimp* gimp-plugin-registry* hal* hal-info* hwinfo* libhal-storage1* libhal1* libhd16*
0 upgraded, 0 newly installed, 8 to remove and 1 not upgraded.
Purg gimp-plugin-registry [2:3.5.2-1~frickel-1]
Purg gimp [2.7.3~git20110415]
....
root@aptosidbox:/home/don#


That doesn't look desirable -- I need gimp. What do I not understand?


your system gone crap... or the installed packages.
gimp has no relationship at all with hal.

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?


Last edited by x-un-i on 17.06.2011, 23:04; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 17.06.2011, 23:04
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      Code:
root@x1:/home/piper# apt-get purge hal hal-info libhal-storage1 libhal1 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package hal is not installed, so not removed
Package libhal-storage1 is not installed, so not removed
Package libhal1 is not installed, so not removed
Package hal-info is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


      Code:
oot@x1:/home/piper# apt-get purge hal hal-info libhal-storage1 libhal1  libkephal4abi1 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package hal is not installed, so not removed
Package libhal-storage1 is not installed, so not removed
Package libhal1 is not installed, so not removed
Package hal-info is not installed, so not removed
The following packages will be REMOVED:
  aptosid-art-kde* aptosid-art-kde-imera* aptosid-art-ksplash-imera* aptosid-settings-kde* kde-plasma-desktop* kde-window-manager* kdebase-workspace*
  kdebase-workspace-bin* kdeplasma-addons* libkephal4abi1* libplasmaclock4abi1* libplasmagenericshell4* libtaskmanager4abi1*
  plasma-dataengines-workspace* plasma-desktop* plasma-widget-lancelot* plasma-widgets-addons* plasma-widgets-workspace*
0 upgraded, 0 newly installed, 18 to remove and 0 not upgraded.
Purg aptosid-settings-kde [1.2.7]
Purg aptosid-art-kde [1.5.24]
Purg aptosid-art-kde-imera [0.0.6]
Purg aptosid-art-ksplash-imera [0.0.6]
Purg kde-plasma-desktop [5:68]
Purg kdebase-workspace [4:4.6.3-1]
Purg kde-window-manager [4:4.6.3-1]
Purg kdebase-workspace-bin [4:4.6.3-1]
Purg kdeplasma-addons [4:4.6.3-1]
Purg plasma-desktop [4:4.6.3-1]
Purg plasma-widget-lancelot [4:4.6.3-1]
Purg plasma-widgets-addons [4:4.6.3-1]
Purg plasma-widgets-workspace [4:4.6.3-1]
Purg plasma-dataengines-workspace [4:4.6.3-1]
Purg libtaskmanager4abi1 [4:4.6.3-1]
Purg libplasmagenericshell4 [4:4.6.3-1]
Purg libplasmaclock4abi1 [4:4.6.3-1]
Purg libkephal4abi1 [4:4.6.3-1]


piper@x1:~$ infobash -v3
Host/Kernel/OS "x1" running Linux 2.6.39-1.slh.8-aptosid-amd64 x86_64 [ aptosid snapshot - kde-lite - (201106102023) ]
CPU Info 2x AMD Athlon 64 X2 Dual Core 4200+ 512 KB cache flags( sse3 ht nx lm svm ) clocked at [ 1000.000 MHz ]
Videocard nVidia GF106 [GeForce 450 GTS] X.Org 1.10.2 [ 1920x1080@60.0hz ]
Network cards Realtek RTL8111/8168B PCI Express Gigabit
Processes 123 | Uptime 2:39 | Memory 574.8/3966.0MB | HDD ST3320620AS,ST31000528AS,ST31000528AS Size 2320GB (48%used) | GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v3.36

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject:   PostPosted: 17.06.2011, 23:06
Team Member


Joined: 2010-08-26
Posts: 170

@piper apt-cache show libkephal4abi1 nothing related to hal Wink

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 17.06.2011, 23:28
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      x-un-i wrote:
@piper apt-cache show libkephal4abi1 nothing related to hal Wink


Yes, I know that Wink just wanted to show if that package was removed what else goes Smile

      Code:
oot@x1:/home/piper# apt-get purge libkephal4abi1 -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  aptosid-art-kde* aptosid-art-kde-imera* aptosid-art-ksplash-imera* aptosid-settings-kde* kde-plasma-desktop* kde-window-manager* kdebase-workspace*
  kdebase-workspace-bin* kdeplasma-addons* libkephal4abi1* libplasmaclock4abi1* libplasmagenericshell4* libtaskmanager4abi1*
  plasma-dataengines-workspace* plasma-desktop* plasma-widget-lancelot* plasma-widgets-addons* plasma-widgets-workspace*
0 upgraded, 0 newly installed, 18 to remove and 13 not upgraded.
Purg aptosid-settings-kde [1.2.7]
Purg aptosid-art-kde [1.5.24]
Purg aptosid-art-kde-imera [0.0.6]
Purg aptosid-art-ksplash-imera [0.0.6]
Purg kde-plasma-desktop [5:68]
Purg kdebase-workspace [4:4.6.3-1]
Purg kde-window-manager [4:4.6.3-1]
Purg kdebase-workspace-bin [4:4.6.3-1]
Purg kdeplasma-addons [4:4.6.3-1]
Purg plasma-desktop [4:4.6.3-1]
Purg plasma-widget-lancelot [4:4.6.3-1]
Purg plasma-widgets-addons [4:4.6.3-1]
Purg plasma-widgets-workspace [4:4.6.3-1]
Purg plasma-dataengines-workspace [4:4.6.3-1]
Purg libtaskmanager4abi1 [4:4.6.3-1]
Purg libplasmagenericshell4 [4:4.6.3-1]
Purg libplasmaclock4abi1 [4:4.6.3-1]
Purg libkephal4abi1 [4:4.6.3-1]
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 18.06.2011, 00:01



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
      x-un-i wrote:


your system gone crap... or the installed packages.
gimp has no relationship at all with hal.


Bummer.

Fortunately, I found that the relationship was that gimp depends on libhal1. So, I did the removals, then reinstalled gimp and it brought back libhal1. I think there must be no relationship between libhal1 and the other hal packages. Smile

And YES (On Topic), K3b still starts up with no issues.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio