Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
WromeyOffline
Post subject: atheros wlan very slow with 2.6.38  PostPosted: 20.03.2011, 08:21



Joined: 2010-09-12
Posts: 29

Status: Offline
With the newest 2.6.38 Kernel, my wlan is very slow. It is an atheros AR928X Wireless Network Adapter. I have learned in the german forum, that there is a problem.

Is there hope, that it will be fixed?

Wolfgang

______________
free as in freedom
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: atheros wlan very slow with 2.6.38  PostPosted: 20.03.2011, 08:43



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
i edited threadtitle to be more descriptive

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
WromeyOffline
Post subject: RE: atheros wlan very slow with 2.6.38  PostPosted: 20.03.2011, 08:51



Joined: 2010-09-12
Posts: 29

Status: Offline
Thank you. My workaround: Install the 2.6.37 kernel from frickelplatz (thanx towo).

Wolfgang
 
 View user's profile Send private message  
Reply with quote Back to top
anubisthetaOffline
Post subject: RE: atheros wlan very slow with 2.6.38  PostPosted: 29.03.2011, 16:46



Joined: 2010-10-19
Posts: 1
Location: Pittsburgh, PA
Status: Offline
I have an Atheros wireless card as well.
      Code:

lspci | grep Atheros
02:00.0 Ethernet controller: Atheros Communications AR8151 v1.0 Gigabit Ethernet (rev c0)
03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)


I had problems when updating to the new kernel. For me, changing my network connection from N to G solved my problems.

Hope this helps.
 
 View user's profile Send private message  
Reply with quote Back to top
schlumblOffline
Post subject:   PostPosted: 30.03.2011, 05:58



Joined: 2011-03-30
Posts: 3

Status: Offline
My solution is putting

      Code:
options ath9k nohwcrypt=1


in a file called /etc/modprobe.d/ath9k.conf

Works fine so far.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio