Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
darioOffline
Post subject: Cannot connect to the wireless network  PostPosted: 04.04.2011, 20:59



Joined: 2010-11-27
Posts: 63

Status: Offline
I'm trying to install aptosid to an hp nx7400 laptop, but wireless network doesn't work, the card is this:
      Code:

10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
        Subsystem: Hewlett-Packard Company Compaq 6710b or nx9420 Notebook
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Memory at f4000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access>
        Kernel driver in use: iwl3945


I installed the firmware and loaded the module as suggested by fw-detect.
In ceni i see correctly my wireless network in the list, but i get this message:
      Code:

Configuring interface wlan0=wlan0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: using default driver type: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -s -B -P /var/run/wpa_supplicant.wlan0.pid -i wlan0 -D wext -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...
wpa_supplicant: creating sendsigs omission pidfile: /lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/wlan0
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "NETWORK_NAME" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: enabling network block 0 -- OK

dhclient -v -pf /var/run/dhclient.wlan0.pid -lf /var/lib/dhcp/dhclient.wlan0.leases wlan0
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/00:13:02:45:76:ea
Sending on   LPF/wlan0/00:13:02:45:76:ea
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/000resolvconf
run-parts: executing /etc/network/if-up.d/mountnfs
run-parts: executing /etc/network/if-up.d/ntpdate
run-parts: executing /etc/network/if-up.d/openssh-server
run-parts: executing /etc/network/if-up.d/wpasupplicant

Press Enter key to continue ...


I'm sure the network key is right, the only difference i noticed from the ceni screenshot in the manual is that i haven't got the backend option on the configuration page after selecting the network from the list.
p.s. i'm using a live system on the laptop, with an usb stick prepared with the install aptosid to usb program.
wpa supplicant and wireless tools are installed
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: Cannot connect to the wireless network  PostPosted: 04.04.2011, 21:20
Team Member


Joined: 2010-08-26
Posts: 170

is firmware-iwlwifi installed?

as non-free package is not included in the iso.

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?


Last edited by x-un-i on 04.04.2011, 21:23; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 04.04.2011, 21:21



Joined: 2010-08-25
Posts: 724

Status: Offline
Given the lack of earlier, wide spread, bugreports about iwl3945 in Γῆρας (at least 2 of our developers occasionally use systems with iwl3945), I'd find it hard to believe that it was broken in the release, but please try to upgrade the kernel as well (and make sure that the according firmware is installed), as I just got confirmation that iwl3945 is at least working 2.6.38-2.slh.2-aptosid-{686,amd64}.

If the problem persists, we'd need further info, like:
      Code:
$ dmesg
$ /usr/sbin/rfkill list
$ /usr/sbin/iw phy phy0 info
$ /usr/sbin/iw dev wlan0 scan
"rfkill" or "iw" may not be preinstalled.
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 04.04.2011, 21:40



Joined: 2010-11-27
Posts: 63

Status: Offline
Is there any way to upgrade the kernel when using a live system? At the end i get the network working after a restart and repeating the whole procedure, but i can't reach any site, also "ping 8.8.8.8" sometimes gets a response and sometimes not. Networks works in DHCP mode, the wireless network card worked without any problem since Ubuntu 8.10 (kernel 2.6.27), my intention was to replace ubuntu with aptosid because i don't like the upcoming release of ubuntu.

p.s. i haven't here the whole output of the first command, but it said that the card wasn't disabled, from the other commands i got something like "folder iw not found". I'm sorry for the incomplete information but i had to restart the laptop because my mother needed it. Maybe tomorrow i'll try again.


Last edited by dario on 04.04.2011, 21:48; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 04.04.2011, 21:46



Joined: 2010-08-25
Posts: 724

Status: Offline
By far the easiest way is to (at least temporarily) connect a simple ethernet cable...

That said, the current kernel can also be downloaded from http://aptosid.com/debian/pool/main/l/linux-aptosid-2.6/ and installed manually through dpkg. But given the lack of previous complaints about iwl3945 and the 2.6.37 based release kernel for Γῆρας, I'd find it hard to believe that it didn't work (iwl3945 is far too common for that), just that the person who confirmed iwl3945 to be working on 2.6.38 only had the current kernel available.

Also make sure that potential wlan (rfkill) buttons aren't switched to disabled (airline mode).
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 04.04.2011, 21:49



Joined: 2010-11-27
Posts: 63

Status: Offline
I edited the post above, yes, the buttons and the wlan light are turned on.
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 05.04.2011, 10:32



Joined: 2010-11-27
Posts: 63

Status: Offline
Today i tried again to set up the network, the network works but i have some dns problems: i have to specify manually the dns server (for example 208.67.222.222) because i can't reach any site if i left the dns field empty in ceni's configuration page. This is quite strange, i've never had to specify the dns server in the other (the other aptosid pcs i have are connected to the wired network), the dns are already setted in the wireless switch.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: Cannot connect to the wireless network  PostPosted: 05.04.2011, 11:04
Moderator


Joined: 2010-09-11
Posts: 468

I'm not sure for your case, but I see some ISPs are not happy about their clients
connect Wifi router on the client side, and 'expose' internet connection to wider audiences,
and so make obstacle at DNS server side, by not answering properly when queried
not from their own access point.
(I may be wrong about the technical description, but in essence,
DNS server does not work when accessed via wifi router and yet other router).

There may be simpler solution, but in my case, using OpenDNS (208.67.222.222 and 208.67.220.220)
as default DNS server solves the problem.
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 05.04.2011, 11:46



Joined: 2010-11-27
Posts: 63

Status: Offline
I forgot to say, that the DNSs setted in the wireless router are the OpenDNS.
 
 View user's profile Send private message  
Reply with quote Back to top
darioOffline
Post subject: RE: Cannot connect to the wireless network  PostPosted: 05.04.2011, 15:29



Joined: 2010-11-27
Posts: 63

Status: Offline
I tried Debian Squeeze live-CD and network worked perfectly, so i can install it as a temporary solution (i need the laptop working for tomorrow). I'll try the next aptosid release on this laptop (it will have .38 kernel, right?).
However, thank you very much for the help!
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio