Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
arwaOffline
Post subject: dist-upgrade: pkgProblemResolver::Resolve generated breaks  PostPosted: 24.03.2011, 08:10



Joined: 2010-09-11
Posts: 183

Status: Offline
Hallo,

since yesterday dist-upgrade shows the following error:

      Code:
apt-get -duV -o Debug::pkgProblemResolver=yes dist-upgrade

Reading package lists...
Building dependency tree...
Reading state information...
Starting
Starting 2
Investigating (0) libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs )
Broken libgdk-pixbuf2.0-0:i386 Breaks on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (< 2.26.3-2)
  Considering librsvg2-2:i386 24 as a solution to libgdk-pixbuf2.0-0:i386 104
  Added librsvg2-2:i386 to the remove list
Broken libgdk-pixbuf2.0-0:i386 Breaks on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (< 0.2.8.4-7)
  Considering libwmf0.2-7:i386 7 as a solution to libgdk-pixbuf2.0-0:i386 104
  Added libwmf0.2-7:i386 to the remove list
  Fixing libgdk-pixbuf2.0-0:i386 via remove of librsvg2-2:i386
  Fixing libgdk-pixbuf2.0-0:i386 via remove of libwmf0.2-7:i386
Investigating (0) libeina1 [ i386 ] < none -> 1.0.0-1 > ( libs )
Broken libeina1:i386 Conflicts on libeina0 [ i386 ] < none > ( none )
  Considering libeina-svn-06:i386 56 as a solution to libeina1:i386 36
  Holding Back libeina1:i386 rather than change libeina0:i386
Investigating (0) libeet1 [ i386 ] < 1.4.0~beta+1.3.2-1 -> 1.4.0-2 > ( libs )
Broken libeet1:i386 Depends on libeina1 [ i386 ] < none -> 1.0.0-1 > ( libs ) (>= 1.0.0~beta)
  Considering libeina1:i386 36 as a solution to libeet1:i386 23
  Holding Back libeet1:i386 rather than change libeina1:i386
Investigating (0) libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libevas-svn-06:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (>= 2.26.0)
  Considering librsvg2-2:i386 24 as a solution to libevas-svn-06:i386 17
  Removing libevas-svn-06:i386 rather than change librsvg2-2:i386
Investigating (0) gimp [ i386 ] < 2.6.11-1 > ( graphics )
Broken gimp:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (>= 2.26.0)
  Considering librsvg2-2:i386 24 as a solution to gimp:i386 15
  Removing gimp:i386 rather than change librsvg2-2:i386
Investigating (0) libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore1:i386 Depends on libeina1 [ i386 ] < none -> 1.0.0-1 > ( libs ) (>= 1.0.0~beta)
  Considering libeina1:i386 36 as a solution to libecore1:i386 11
  Holding Back libecore1:i386 rather than change libeina1:i386
Investigating (0) libevas1 [ i386 ] < none -> 1.0.0-1 > ( libs )
Broken libevas1:i386 Depends on libeina1 [ i386 ] < none -> 1.0.0-1 > ( libs ) (>= 1.0.0~beta)
  Considering libeina1:i386 36 as a solution to libevas1:i386 8
  Holding Back libevas1:i386 rather than change libeina1:i386
Investigating (0) libecore-input-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libecore-input-svn-06:i386 Depends on libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libevas-svn-06:i386 17 as a solution to libecore-input-svn-06:i386 6
  Removing libecore-input-svn-06:i386 rather than change libevas-svn-06:i386
Investigating (0) libgegl-0.0-0 [ i386 ] < 0.0.22-2+b1 > ( libs )
Broken libgegl-0.0-0:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (>= 2.26.0)
  Considering librsvg2-2:i386 24 as a solution to libgegl-0.0-0:i386 5
  Removing libgegl-0.0-0:i386 rather than change librsvg2-2:i386
Investigating (0) librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
Broken librsvg2-common:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (= 2.26.3-1)
  Considering librsvg2-2:i386 24 as a solution to librsvg2-common:i386 4
  Removing librsvg2-common:i386 rather than change librsvg2-2:i386
Investigating (0) libecore-imf-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libecore-imf-svn-06:i386 Depends on libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libevas-svn-06:i386 17 as a solution to libecore-imf-svn-06:i386 3
  Removing libecore-imf-svn-06:i386 rather than change libevas-svn-06:i386
Investigating (0) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 7 as a solution to libgraphicsmagick3:i386 3
  Removing libgraphicsmagick3:i386 rather than change libwmf0.2-7:i386
Investigating (0) libecore-x-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libecore-x-svn-06:i386 Depends on libecore-input-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libecore-input-svn-06:i386 6 as a solution to libecore-x-svn-06:i386 3
  Removing libecore-x-svn-06:i386 rather than change libecore-input-svn-06:i386
Investigating (0) libecore-file1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-file1:i386 Depends on libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore1:i386 11 as a solution to libecore-file1:i386 2
  Holding Back libecore-file1:i386 rather than change libecore1:i386
Investigating (0) console-setup-linux [ i386 ] < none -> 1.71 > ( utils )
Broken console-setup-linux:i386 Conflicts on console-terminus [ i386 ] < 4.30-2 > ( fonts )
  Considering console-terminus:i386 0 as a solution to console-setup-linux:i386 2
  Added console-terminus:i386 to the remove list
  Fixing console-setup-linux:i386 via remove of console-terminus:i386
Investigating (0) libecore-evas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libecore-evas-svn-06:i386 Depends on libecore-input-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libecore-input-svn-06:i386 6 as a solution to libecore-evas-svn-06:i386 1
  Removing libecore-evas-svn-06:i386 rather than change libecore-input-svn-06:i386
Investigating (0) libecore-input1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-input1:i386 Depends on libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore1:i386 11 as a solution to libecore-input1:i386 1
  Holding Back libecore-input1:i386 rather than change libecore1:i386
Investigating (0) libecore-con1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-con1:i386 Depends on libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore1:i386 11 as a solution to libecore-con1:i386 1
  Holding Back libecore-con1:i386 rather than change libecore1:i386
Investigating (0) libedbus-svn-06 [ i386 ] < 0.5.0.49898-1 > ( libs )
Broken libedbus-svn-06:i386 Depends on libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libevas-svn-06:i386 17 as a solution to libedbus-svn-06:i386 1
  Removing libedbus-svn-06:i386 rather than change libevas-svn-06:i386
Investigating (0) libedje-bin [ i386 ] < 0.9.99.49898-1 -> 1.0.0-1 > ( devel )
Broken libedje-bin:i386 Depends on libecore-file1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore-file1:i386 2 as a solution to libedje-bin:i386 1
  Removing libedje-bin:i386 rather than change libecore-file1:i386
Investigating (0) libecore-evas1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-evas1:i386 Depends on libecore-input1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore-input1:i386 1 as a solution to libecore-evas1:i386 1
  Holding Back libecore-evas1:i386 rather than change libecore-input1:i386
Investigating (0) libedje-svn-06 [ i386 ] < 0.9.99.49898-1 > ( libs )
Broken libedje-svn-06:i386 Depends on libecore-imf-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libecore-imf-svn-06:i386 3 as a solution to libedje-svn-06:i386 1
  Removing libedje-svn-06:i386 rather than change libecore-imf-svn-06:i386
Investigating (0) libevas-svn-06-engines-core [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libevas-svn-06-engines-core:i386 Depends on libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libevas-svn-06:i386 17 as a solution to libevas-svn-06-engines-core:i386 1
  Removing libevas-svn-06-engines-core:i386 rather than change libevas-svn-06:i386
Investigating (0) libedje1 [ i386 ] < none -> 1.0.0-1 > ( libs )
Broken libedje1:i386 Depends on libecore-file1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore-file1:i386 2 as a solution to libedje1:i386 1
  Holding Back libedje1:i386 rather than change libecore-file1:i386
Investigating (0) libecore-fb1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-fb1:i386 Depends on libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore1:i386 11 as a solution to libecore-fb1:i386 0
  Holding Back libecore-fb1:i386 rather than change libecore1:i386
Investigating (0) libecore-x1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-x1:i386 Depends on libecore-input1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore-input1:i386 1 as a solution to libecore-x1:i386 0
  Holding Back libecore-x1:i386 rather than change libecore-input1:i386
Investigating (0) libdb5.1-dev [ i386 ] < none -> 5.1.25-1 > ( libdevel )
Broken libdb5.1-dev:i386 Conflicts on libdb4.8-dev [ i386 ] < 4.8.30-5 > ( libdevel )
  Considering libdb4.8-dev:i386 1 as a solution to libdb5.1-dev:i386 0
  Holding Back libdb5.1-dev:i386 rather than change libdb4.8-dev:i386
Investigating (0) e17 [ i386 ] < 0.16.999.49898-1 > ( x11 )
Broken e17:i386 Depends on libecore-evas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libecore-evas-svn-06:i386 1 as a solution to e17:i386 0
  Removing e17:i386 rather than change libecore-evas-svn-06:i386
Investigating (0) libevas-svn-06-engines-x [ i386 ] < 0.9.9.49898-1 > ( libs )
Broken libevas-svn-06-engines-x:i386 Depends on libevas-svn-06 [ i386 ] < 0.9.9.49898-1 > ( libs ) (>= 0.9.9.49898)
  Considering libevas-svn-06:i386 17 as a solution to libevas-svn-06-engines-x:i386 0
  Removing libevas-svn-06-engines-x:i386 rather than change libevas-svn-06:i386
Investigating (0) libecore-imf1 [ i386 ] < none -> 1.0.0-2 > ( libs )
Broken libecore-imf1:i386 Depends on libecore1 [ i386 ] < none -> 1.0.0-2 > ( libs ) (>= 1.0.0)
  Considering libecore1:i386 11 as a solution to libecore-imf1:i386 0
  Holding Back libecore-imf1:i386 rather than change libecore1:i386
Investigating (0) gimp-plugin-registry [ i386 ] < 3.5.3-1 > ( graphics )
Broken gimp-plugin-registry:i386 Depends on gimp [ i386 ] < 2.6.11-1 > ( graphics ) (>= 2.6)
  Considering gimp:i386 15 as a solution to gimp-plugin-registry:i386 0
  Removing gimp-plugin-registry:i386 rather than change gimp:i386
Investigating (0) libevas1-engines-core [ i386 ] < none -> 1.0.0-1 > ( libs )
Broken libevas1-engines-core:i386 Depends on libeina1 [ i386 ] < none -> 1.0.0-1 > ( libs ) (>= 1.0.0~beta)
  Considering libeina1:i386 36 as a solution to libevas1-engines-core:i386 -1
  Holding Back libevas1-engines-core:i386 rather than change libeina1:i386
Investigating (0) libdb-dev [ i386 ] < 4.8 -> 5.1 > ( libdevel )
Broken libdb-dev:i386 Depends on libdb5.1-dev [ i386 ] < none -> 5.1.25-1 > ( libdevel )
  Considering libdb5.1-dev:i386 0 as a solution to libdb-dev:i386 -1
  Holding Back libdb-dev:i386 rather than change libdb5.1-dev:i386
Investigating (0) gimp-dcraw [ i386 ] < 1.31-1.1 > ( graphics )
Broken gimp-dcraw:i386 Depends on gimp [ i386 ] < 2.6.11-1 > ( graphics ) (>= 2.0)
  Considering gimp:i386 15 as a solution to gimp-dcraw:i386 -1
  Removing gimp-dcraw:i386 rather than change gimp:i386
 Try to Re-Instate (1) libeet1:i386
Investigating (1) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 3 as a solution to libxine1-misc-plugins:i386 7
  Added libgraphicsmagick3:i386 to the remove list
  Fixing libxine1-misc-plugins:i386 via keep of libgraphicsmagick3:i386
Investigating (1) gnome-icon-theme [ i386 ] < 2.30.3-2 > ( gnome )
Broken gnome-icon-theme:i386 Depends on librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
  Considering librsvg2-common:i386 4 as a solution to gnome-icon-theme:i386 5
  Added librsvg2-common:i386 to the remove list
  Fixing gnome-icon-theme:i386 via keep of librsvg2-common:i386
Investigating (1) librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
Broken librsvg2-common:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (= 2.26.3-1)
  Considering librsvg2-2:i386 24 as a solution to librsvg2-common:i386 4
  Removing librsvg2-common:i386 rather than change librsvg2-2:i386
Investigating (1) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 7 as a solution to libgraphicsmagick3:i386 3
  Removing libgraphicsmagick3:i386 rather than change libwmf0.2-7:i386
 Try to Re-Instate (1) libdb-dev:i386
Investigating (2) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 3 as a solution to libxine1-misc-plugins:i386 7
  Added libgraphicsmagick3:i386 to the remove list
  Fixing libxine1-misc-plugins:i386 via keep of libgraphicsmagick3:i386
Investigating (2) gnome-icon-theme [ i386 ] < 2.30.3-2 > ( gnome )
Broken gnome-icon-theme:i386 Depends on librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
  Considering librsvg2-common:i386 4 as a solution to gnome-icon-theme:i386 5
  Added librsvg2-common:i386 to the remove list
  Fixing gnome-icon-theme:i386 via keep of librsvg2-common:i386
Investigating (2) librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
Broken librsvg2-common:i386 Depends on librsvg2-2 [ i386 ] < 2.26.3-1 > ( libs ) (= 2.26.3-1)
  Considering librsvg2-2:i386 24 as a solution to librsvg2-common:i386 5
  Removing librsvg2-common:i386 rather than change librsvg2-2:i386
Investigating (2) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 7 as a solution to libgraphicsmagick3:i386 7
  Removing libgraphicsmagick3:i386 rather than change libwmf0.2-7:i386
Investigating (3) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 7 as a solution to libxine1-misc-plugins:i386 7
  Removing libxine1-misc-plugins:i386 rather than change libgraphicsmagick3:i386
Investigating (3) libxine1-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-plugins:i386 Depends on libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.19-3)
  Considering libxine1-misc-plugins:i386 7 as a solution to libxine1-plugins:i386 5
  Removing libxine1-plugins:i386 rather than change libxine1-misc-plugins:i386
Investigating (3) gnome-icon-theme [ i386 ] < 2.30.3-2 > ( gnome )
Broken gnome-icon-theme:i386 Depends on librsvg2-common [ i386 ] < 2.26.3-1 > ( libs )
  Considering librsvg2-common:i386 24 as a solution to gnome-icon-theme:i386 5
  Removing gnome-icon-theme:i386 rather than change librsvg2-common:i386
Investigating (3) xgnokii [ i386 ] < 0.6.29.dfsg-1 > ( comm )
Broken xgnokii:i386 Depends on gnome-icon-theme [ i386 ] < 2.30.3-2 > ( gnome )
  Considering gnome-icon-theme:i386 24 as a solution to xgnokii:i386 1
  Removing xgnokii:i386 rather than change gnome-icon-theme:i386
Investigating (3) system-config-printer [ i386 ] < 1.2.3-3 > ( python )
Broken system-config-printer:i386 Depends on gnome-icon-theme [ i386 ] < 2.30.3-2 > ( gnome )
  Considering gnome-icon-theme:i386 24 as a solution to system-config-printer:i386 0
  Removing system-config-printer:i386 rather than change gnome-icon-theme:i386
Investigating (3) gnokii [ i386 ] < 0.6.29.dfsg-1 > ( comm )
Broken gnokii:i386 Depends on xgnokii [ i386 ] < 0.6.29.dfsg-1 > ( comm ) (>= 0.6.29.dfsg-1)
  Considering xgnokii:i386 24 as a solution to gnokii:i386 0
  Removing gnokii:i386 rather than change xgnokii:i386
Investigating (4) libxine1 [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1:i386 Depends on libxine1-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-plugins:i386 7 as a solution to libxine1:i386 10
  Added libxine1-plugins:i386 to the remove list
Broken libxine1:i386 Depends on libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-misc-plugins:i386 7 as a solution to libxine1:i386 10
  Added libxine1-misc-plugins:i386 to the remove list
  Fixing libxine1:i386 via keep of libxine1-plugins:i386
  Fixing libxine1:i386 via keep of libxine1-misc-plugins:i386
Investigating (4) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 7 as a solution to libxine1-misc-plugins:i386 10
  Added libgraphicsmagick3:i386 to the remove list
  Fixing libxine1-misc-plugins:i386 via keep of libgraphicsmagick3:i386
Investigating (4) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 7 as a solution to libgraphicsmagick3:i386 10
  Added libwmf0.2-7:i386 to the remove list
  Fixing libgraphicsmagick3:i386 via keep of libwmf0.2-7:i386
Investigating (5) libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs )
Broken libgdk-pixbuf2.0-0:i386 Breaks on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (< 0.2.8.4-7)
  Considering libwmf0.2-7:i386 10 as a solution to libgdk-pixbuf2.0-0:i386 104
  Added libwmf0.2-7:i386 to the remove list
  Fixing libgdk-pixbuf2.0-0:i386 via remove of libwmf0.2-7:i386
Investigating (5) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 104 as a solution to libgraphicsmagick3:i386 10
  Removing libgraphicsmagick3:i386 rather than change libwmf0.2-7:i386
Investigating (6) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 104 as a solution to libxine1-misc-plugins:i386 10
  Removing libxine1-misc-plugins:i386 rather than change libgraphicsmagick3:i386
Investigating (6) libxine1-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-plugins:i386 Depends on libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.19-3)
  Considering libxine1-misc-plugins:i386 104 as a solution to libxine1-plugins:i386 10
  Removing libxine1-plugins:i386 rather than change libxine1-misc-plugins:i386
Investigating (7) libxine1 [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1:i386 Depends on libxine1-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-plugins:i386 104 as a solution to libxine1:i386 10
Broken libxine1:i386 Depends on libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-misc-plugins:i386 104 as a solution to libxine1:i386 10
  Or group remove for libxine1:i386
Investigating (7) dragonplayer [ i386 ] < 4:4.4.5-1 > ( video )
Broken dragonplayer:i386 Depends on libxine1 [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.8-1)
  Considering libxine1:i386 10 as a solution to dragonplayer:i386 4
  Removing dragonplayer:i386 rather than change libxine1:i386
Investigating (7) kde-standard [ i386 ] < 5:66 > ( kde )
Broken kde-standard:i386 Depends on dragonplayer [ i386 ] < 4:4.4.5-1 > ( video ) (>= 4:4.4.3)
  Considering dragonplayer:i386 10 as a solution to kde-standard:i386 1
  Removing kde-standard:i386 rather than change dragonplayer:i386
Investigating (7) kdemultimedia [ i386 ] < 4:4.4.5-1 > ( kde )
Broken kdemultimedia:i386 Depends on dragonplayer [ i386 ] < 4:4.4.5-1 > ( video ) (>= 4:4.4.5-1)
  Considering dragonplayer:i386 10 as a solution to kdemultimedia:i386 1
  Removing kdemultimedia:i386 rather than change dragonplayer:i386
Investigating (7) kaffeine [ i386 ] < 1.1-2 > ( video )
Broken kaffeine:i386 Depends on libxine1 [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.8-1)
  Considering libxine1:i386 10 as a solution to kaffeine:i386 0
  Removing kaffeine:i386 rather than change libxine1:i386
Investigating (7) kde-full [ i386 ] < 5:66 > ( kde )
Broken kde-full:i386 Depends on kdemultimedia [ i386 ] < 4:4.4.5-1 > ( kde ) (>= 4:4.4.3)
  Considering kdemultimedia:i386 10 as a solution to kde-full:i386 0
  Removing kde-full:i386 rather than change kdemultimedia:i386
Investigating (7) xine-ui [ i386 ] < 0.99.6-1 > ( video )
Broken xine-ui:i386 Depends on libxine1 [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.8)
  Considering libxine1:i386 10 as a solution to xine-ui:i386 0
  Removing xine-ui:i386 rather than change libxine1:i386
Investigating (7) libxine1-xvdr [ i386 ] < 1.0.6~cvs20100502.0851-3+b1 > ( video )
Broken libxine1-xvdr:i386 Depends on libxine1 [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.19)
  Considering libxine1:i386 10 as a solution to libxine1-xvdr:i386 -1
  Removing libxine1-xvdr:i386 rather than change libxine1:i386
Investigating (8) phonon-backend-xine [ i386 ] < 4:4.6.0really4.4.4-3 > ( sound )
Broken phonon-backend-xine:i386 Depends on libxine1 [ i386 ] < 1.1.19-3 > ( libs ) (>= 1.1.8-1)
  Considering libxine1:i386 10 as a solution to phonon-backend-xine:i386 170
  Added libxine1:i386 to the remove list
  Fixing phonon-backend-xine:i386 via keep of libxine1:i386
Investigating (8) libxine1 [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1:i386 Depends on libxine1-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-plugins:i386 104 as a solution to libxine1:i386 170
  Added libxine1-plugins:i386 to the remove list
Broken libxine1:i386 Depends on libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs ) (= 1.1.19-3)
  Considering libxine1-misc-plugins:i386 104 as a solution to libxine1:i386 170
  Added libxine1-misc-plugins:i386 to the remove list
  Fixing libxine1:i386 via keep of libxine1-plugins:i386
  Fixing libxine1:i386 via keep of libxine1-misc-plugins:i386
Investigating (8) libxine1-misc-plugins [ i386 ] < 1.1.19-3 > ( libs )
Broken libxine1-misc-plugins:i386 Depends on libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs ) (>= 1.3.5)
  Considering libgraphicsmagick3:i386 104 as a solution to libxine1-misc-plugins:i386 170
  Added libgraphicsmagick3:i386 to the remove list
  Fixing libxine1-misc-plugins:i386 via keep of libgraphicsmagick3:i386
Investigating (8) libgraphicsmagick3 [ i386 ] < 1.3.12-1+b1 > ( libs )
Broken libgraphicsmagick3:i386 Depends on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (>= 0.2.8.4)
  Considering libwmf0.2-7:i386 104 as a solution to libgraphicsmagick3:i386 170
  Added libwmf0.2-7:i386 to the remove list
  Fixing libgraphicsmagick3:i386 via keep of libwmf0.2-7:i386
Investigating (9) libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs )
Broken libgdk-pixbuf2.0-0:i386 Breaks on libwmf0.2-7 [ i386 ] < 0.2.8.4-6.1+b1 > ( libs ) (< 0.2.8.4-7)
  Considering libwmf0.2-7:i386 170 as a solution to libgdk-pixbuf2.0-0:i386 104
  Holding Back libgdk-pixbuf2.0-0:i386 rather than change libwmf0.2-7:i386
Investigating (9) libgail18 [ i386 ] < 2.20.1-2 -> 2.24.3-1~sid1 > ( libs )
Broken libgail18:i386 Depends on libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs ) (>= 2.22.0)
  Considering libgdk-pixbuf2.0-0:i386 104 as a solution to libgail18:i386 10
  Removing libgail18:i386 rather than change libgdk-pixbuf2.0-0:i386
Investigating (9) libwebkit-1.0-2 [ i386 ] < 1.2.7-1 > ( libs )
Broken libwebkit-1.0-2:i386 Depends on libgail18 [ i386 ] < 2.20.1-2 -> 2.24.3-1~sid1 > ( libs ) (>= 1.18.0)
  Considering libgail18:i386 104 as a solution to libwebkit-1.0-2:i386 9
  Removing libwebkit-1.0-2:i386 rather than change libgail18:i386
Investigating (9) gtk2-engines-pixbuf [ i386 ] < 2.20.1-2 -> 2.24.3-1~sid1 > ( graphics )
Broken gtk2-engines-pixbuf:i386 Depends on libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs ) (>= 2.22.0)
  Considering libgdk-pixbuf2.0-0:i386 104 as a solution to gtk2-engines-pixbuf:i386 2
  Removing gtk2-engines-pixbuf:i386 rather than change libgdk-pixbuf2.0-0:i386
Investigating (9) xtrkcad [ i386 ] < 1:4.0.2-2 > ( editors )
Broken xtrkcad:i386 Depends on libwebkit-1.0-2 [ i386 ] < 1.2.7-1 > ( libs ) (>= 1.1.1)
  Considering libwebkit-1.0-2:i386 104 as a solution to xtrkcad:i386 0
  Removing xtrkcad:i386 rather than change libwebkit-1.0-2:i386
Investigating (9) libgdk-pixbuf2.0-dev [ i386 ] < none -> 2.22.1-1+sid1 > ( libdevel )
Broken libgdk-pixbuf2.0-dev:i386 Depends on libgdk-pixbuf2.0-0 [ i386 ] < none -> 2.22.1-1+sid1 > ( libs ) (= 2.22.1-1+sid1)
  Considering libgdk-pixbuf2.0-0:i386 104 as a solution to libgdk-pixbuf2.0-dev:i386 0
  Holding Back libgdk-pixbuf2.0-dev:i386 rather than change libgdk-pixbuf2.0-0:i386
Done
The following packages have unmet dependencies:
 audacious : Depends: gtk2-engines-pixbuf but it is not going to be installed
 libgnomecanvas2-0 : Depends: libgail18 (>= 1.18.0) but it is not going to be installed
 libgtk2.0-0 : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
 libgtk2.0-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


I have only the following package set to hold:
      Code:
root@oink:~# dpkg --get-selections | grep hold
libxp6                                          hold


What should I do? My current strategy is to just wait some further days. After this I will try just an "upgrade" to see if this brings the system to another state that the resolver can work with.

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: dist-upgrade: pkgProblemResolver::Resolve generated brea  PostPosted: 24.03.2011, 09:14
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
The resolver hits its internal 10 tries limit. The best bet is as the error message says to try without holds (--ignore-holds). Why do you have libxp6 on hold anyway?

upgrade isn't able to move you forward as this properly involves new packages / remove of old packages. The "old" e-libraries api (libe*-svn-06) wants to leave for a better place (package nirvana)…

You can enable additional debugging (which will mention actions prevented by holds, too) if you add another debug option: -o Debug::pkgDepCache::Marker=1

Sorry, i can look at that deeper at the moment, but if you like you can backup your /var/lib/dpkg/status file and send it to me. I am maybe able to have a look next week after my exams. Smile

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arwaOffline
Post subject: Re: RE: dist-upgrade: pkgProblemResolver::Resolve generated  PostPosted: 25.03.2011, 07:01



Joined: 2010-09-11
Posts: 183

Status: Offline
      DonKult wrote:
The resolver hits its internal 10 tries limit. The best bet is as the error message says to try without holds (--ignore-holds).

Today the dependencies have repaired itself automatically. After an apt-get update the "-d dist-upgrade" does resolve everything fine.

      Quote:
Why do you have libxp6 on hold anyway?

IIRC this package is required by nedit. But because the packaged nedit has weird problems probably because it is compiled dynamically against lesstif2, I always installed the statically linked nedit version (that uses motif) from their homepage. Without the installed nedit package deborphan reported libxp6 to be removable what I do not want. So I set it to hold.

      Quote:
Sorry, i can look at that deeper at the moment, but if you like you can backup your /var/lib/dpkg/status file and send it to me. I am maybe able to have a look next week after my exams. Smile

I took a backup of the status file before doing further apt-get things. So if you are still interested, I can send it to you (bziped it is about 370k)

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: Re: RE: dist-upgrade: pkgProblemResolver::Resolve generated  PostPosted: 26.03.2011, 15:39
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
      arwa wrote:
I took a backup of the status file before doing further apt-get things. So if you are still interested, I can send it to you (bziped it is about 370k)

Thanks, but if it solves itself so quickly the motivation to look at it to understand why it failed is very low. Especially if as i would need to get the old Packages files then, which would be a trail and error - aka a big time sink.

Again, thanks & i promise i will try next time Wink

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 06.04.2011, 06:55



Joined: 2010-09-11
Posts: 183

Status: Offline
Today the problem shows up again. DonKult, if you are interested in investigating this, tell me. I can send you information about this if this still happens this evening or tomorrow morning. Otherwise I just will wait until the dependencies are fixed. (I have the experimental-snapshots active and installed.)
      Quote:
# apt-get -d dist-upgrade -t experimental-snapshots
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
libhttp-date-perl : Breaks: libwww-perl (< 6.00) but 5.837-1 is to be installed
liblwp-mediatypes-perl : Breaks: libwww-perl (< 6.00) but 5.837-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 06.04.2011, 06:57



Joined: 2010-09-11
Posts: 183

Status: Offline
Ah, I have now found http://aptosid.com/index.php?name=PNphp ... =7182#7182 , so this is already reported.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio