Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
pablokalOffline
Post subject: [Solved] cannot install python-gtk2  PostPosted: 05.04.2011, 14:57



Joined: 2011-04-05
Posts: 4

Status: Offline
error message:
The following packages have unmet dependencies:
python-gtk2 : Depends: python-numpy (< 1:1.5) but 1:1.5.1-2 is to be installed
E: Broken packages


Last edited by pablokal on 12.04.2011, 08:54; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: cannot install python-gtk2  PostPosted: 05.04.2011, 18:50



Joined: 2010-09-12
Posts: 325

Status: Offline
A new python-gtk2 has hit the repositories recently. Maybe you should try again...

      Code:

root@t510[/home/finotti]# apt-cache policy python-gtk2
python-gtk2:
  Installed: 2.17.0-4
  Candidate: 2.17.0-4+b1
  Version table:
     2.17.0-4+b1 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
 *** 2.17.0-4 0
        100 /var/lib/dpkg/status
 
 View user's profile Send private message  
Reply with quote Back to top
pablokalOffline
Post subject: RE: cannot install python-gtk2  PostPosted: 07.04.2011, 12:56



Joined: 2011-04-05
Posts: 4

Status: Offline
Now, tried it again and same error.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: cannot install python-gtk2  PostPosted: 07.04.2011, 18:33



Joined: 2010-09-12
Posts: 325

Status: Offline
That's odd. In my system I get:

      Code:

root@t510[~]# apt-get install -s python-gtk2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  python-numpy
Suggested packages:
  python-gtk2-doc python-numpy-doc python-numpy-dbg python-nose python-dev
The following packages will be upgraded:
  python-gtk2 python-numpy
2 upgraded, 0 newly installed, 0 to remove and 161 not upgraded.
Inst python-gtk2 [2.17.0-4] (2.17.0-4+b1 Debian:unstable [amd64]) []
Inst python-numpy [1:1.4.1-5] (1:1.5.1-2 Debian:unstable [amd64])
Conf python-numpy (1:1.5.1-2 Debian:unstable [amd64])
Conf python-gtk2 (2.17.0-4+b1 Debian:unstable [amd64])


What does "apt-cache policy python-gtk2 python-numpy" give? I get:

      Code:

root@t510[~]# apt-cache policy python-gtk2 python-numpy
python-gtk2:
  Installed: 2.17.0-4
  Candidate: 2.17.0-4+b1
  Version table:
     2.17.0-4+b1 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
 *** 2.17.0-4 0
        100 /var/lib/dpkg/status
python-numpy:
  Installed: 1:1.4.1-5
  Candidate: 1:1.5.1-2
  Version table:
     1:1.5.1-2 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
     1:1.5.1-1 0
         50 http://ftp.us.debian.org/debian/ experimental/main amd64 Packages
 *** 1:1.4.1-5 0
        100 /var/lib/dpkg/status
 
 View user's profile Send private message  
Reply with quote Back to top
pablokalOffline
Post subject:   PostPosted: 08.04.2011, 14:49



Joined: 2011-04-05
Posts: 4

Status: Offline
sudo apt-cache policy python-gtk2 python-numpy
[sudo] password for paul:
python-gtk2:
Installed: (none)
Candidate: 2.17.0-4
Version table:
2.17.0-4 0
500 http://cdn.debian.net/debian/ sid/main amd64 Packages
500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
python-numpy:
Installed: (none)
Candidate: 1:1.5.1-2
Version table:
1:1.5.1-2 0
500 http://cdn.debian.net/debian/ sid/main amd64 Packages
500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject:   PostPosted: 08.04.2011, 16:25



Joined: 2010-09-12
Posts: 325

Status: Offline
It seems that your repository is out of date. (python-gtk2 should have a 2.17.0-4+b1 candidate.) Did you do "apt-get update" before trying to install it? If so, try a different mirror.
 
 View user's profile Send private message  
Reply with quote Back to top
pablokalOffline
Post subject:   PostPosted: 12.04.2011, 08:58



Joined: 2011-04-05
Posts: 4

Status: Offline
Indeed getting some other mirrors and putting them in etc/apt/sources.list.d/debian.list solved this issue.
Thanks for your help.
new list looks like this:
deb http://cdn.debian.net/debian/ sid main
deb http://ftp.de.debian.org/debian unstable main contrib non-free
deb ftp://ftp.nl.debian.org/debian/ sid main contrib non-free
deb http://ftp.spline.de/pub/aptosid/debian/ sid main fix.main
deb http://ftp.us.debian.org/debian/ sid main
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio