Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LatOffline
Post subject: EXT4: multiple commits  PostPosted: 18.04.2011, 17:23



Joined: 2010-09-19
Posts: 162

Status: Offline
I want to pick up this post
      dibl wrote:
FIXED: The issue is triggered by a re-mount that happens during the boot process, and then the power management rule at /usr/lib/pm-utils/power.d/journal-commit is invoked. The default commit value for "AC" is commit=0, and that is appended to the existing mount. So, I edited the file and changed the value to commit=120 (same as I now have it set in /etc/fstab). Now the three ext4 filesystems on my system are mounted correctly at the end of the boot process.

FYI, this file is also invoked on resume from suspend, so the issue is seen in that situation also.

I have the below in dmesg in a latop, the "commit=0" are appended every time I suspend and switch to ctrl-alt-f*
      Code:
[55375.324278] EXT4-fs (sda8): re-mounted. Opts: errors=remount-ro,barrier=0,commit=0
[55375.328396] EXT4-fs (sda6): re-mounted. Opts: commit=0,commit=0,commit=600,commit=0,commit=0,commit=0,commit=0,coit=0,commit=600,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=600ommit=600,commit=0,commit=0,commit=0,commit=0,commit=0


I googled it and saw some mentions about laptop-mode-tools. It seems not my laptop or desktop has it
      Code:
cat /proc/sys/vm/laptop_mode ; [ -e /var/run/laptop-mode-enabled ] && echo "found" || echo "no found"
0
no found

This is what I have in fstab
      Code:
cat /etc/fstab|grep ext4
UUID=3a6ddef7-xxbf-48ed-96db-4d56f0aff5xx     /mnt/images/                   ext4            auto,users,rw,exec,noatime                 0      2
UUID=770b8e21-xx76-4d99-aed4-0756ed7478xx     /                              ext4            defaults,errors=remount-ro,noatime,barrier=0   0      1

and a bit more information
      Code:
aptp pm-utils ; uname -r
pm-utils:
  Installed: 1.4.1-8
  Candidate: 1.4.1-8
  Version table:
 *** 1.4.1-8 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.4.1-7 0
        500 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
2.6.38-3.slh.2-aptosid-amd64


I want to know if this is something to worry about, or not
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: EXT4: multiple commits  PostPosted: 18.04.2011, 18:17
Moderator


Joined: 2010-09-11
Posts: 468

You should read this thread from the begining? probably related problem:
http://aptosid.com/index.php?name=PNphp ... =7169#7169
(this link is the last post of the thread...)
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 18.04.2011, 18:33



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
It appears that the intended ACPI behavior, to control the commit=nn setting for ext4, for boots and resumes is set in the file /usr/lib/pm-utils/power.d/journal-commit. The default value for "AC" (plugged in to electric service) is "0", and the value for "BAT" (on battery power) is "600".

So, I wanted 120 seconds for my ext4 filesystems. I made a mistake by backing up the original installed file -- the backup was parsed after the edited file, and the values reset. The lesson is you must edit the original values and save the file and don't make a backup (or maybe use a much more creative name than "journal-commit_bak").

So Lat the only reason for concern is that if your laptop is running on battery, then it should be resetting to "commit=600" (write the journal every 10 minutes) but you are showing "commit=0" which means the journal is written every 5 seconds. You can change it -- of course the risk is a loss of power before a journal commit is written.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio