Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
labOffline
15 Post subject: KDE now takes a long time to log out  PostPosted: 18.09.2010, 09:56



Joined: 2010-09-18
Posts: 17

Status: Offline
Thanks to the devs for a smooth transition from sidux to aptosid. Really enjoy it. All went well, except for one new, fairly minor issue, but still annoying.

When I did the initial transition to aptosid, on Sept.12. everything vent fine. I have subsequently removed all '*sidux*' packages, and things run well. I have substituted the old sidux splashscreen for the aptosid splashscreen.

The hickup which started on this Sept.12. upgrade, was that KDE now takes a long time to logout. This is unchanged after the second aptosid D-U, which I have performed today.

The symptoms are:
I select 'log out', and then KDE just sits there for appr.7 seconds doing nothing. Then the desktop disappears, and I only have a black X screen with the mousecursor, nothing else. This lasts for an additional appr.7 seconds. And finally after that it completes the log out, and I get the login box.

The symptoms are the same if I do a 'shutdown' or 'reboot' from KDE. I should mention that I run KDE with 'automatic login' for convenience, in case it makes a difference.

I have looked through my $HOME/.xsession-errors file, and can't see anything really fishy, but that thing is always full of warnings and errors anyway, so who knows. I can post it if useful.

Output of infobash -v3:
      Code:

Host/Kernel/OS  "turbopixie" running Linux 2.6.35-4.slh.12-aptosid-686 i686 [ sidux 2009-03 Μώμος - kde-full - (200911110039) ]
CPU Info        (1) Intel Pentium 4 2048 KB cache flags( sse3 ht nx lm ) clocked at [ 2800.000 MHz ]
                (2) Intel Pentium 4 2048 KB cache flags( sse3 ht nx lm ) clocked at [ 2800.000 MHz ]
Videocard       ATI RV380 [Radeon X600 (PCIE)]  X.Org 1.7.7  [ 1280x1024@60.0hz ]
Network cards   Intel 82573L Gigabit
Processes 133 | Uptime 1:14 | Memory 325.4/1008.7MB | HDD ST3160023AS Size 160GB (58%used) | GLX Renderer Mesa DRI R300 (RV380 5B62) 20090101 x86/MMX/SSE2 TCL DRI2 | GLX Version 1.5 Mesa 7.7.1 | Client Shell | Infobash v3.34


Thanks for any help or clues offered, and keep going strong with aptosid. After many years with different distros, this is my happy resting place now. Thanks for a great distro.


Last edited by lab on 03.10.2010, 09:28; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
polycarpOffline
Post subject: Re: KDE now takes a long time to log out  PostPosted: 18.09.2010, 12:31



Joined: 2010-09-12
Posts: 3

Status: Offline
      lab wrote:

The symptoms are the same if I do a 'shutdown' or 'reboot' from KDE. I should mention that I run KDE with 'automatic login' for convenience, in case it makes a difference.


Same here but no auto-login, so it does not make a difference.
 
 View user's profile Send private message  
Reply with quote Back to top
BelaLugosiOffline
Post subject: RE: Re: KDE now takes a long time to log out  PostPosted: 18.09.2010, 17:48



Joined: 2010-09-11
Posts: 49
Location: Dresden / Germoney
Status: Offline
Do you have any remote connections or external hdds. Sometimes it can take a while to disconnect/unmount them.
Another thing which takes some time is to save the current KDE session (if activated in systemsettings). You may (un)check these and see if the logout speed increases.

_________________
i don't have hard drives. i just keep 30 chinese teenagers in my basement and force them to memorize numbers (bash.org)
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject: Re: RE: Re: KDE now takes a long time to log out  PostPosted: 19.09.2010, 07:38



Joined: 2010-09-18
Posts: 17

Status: Offline
      BelaLugosi wrote:
Do you have any remote connections or external hdds. Sometimes it can take a while to disconnect/unmount them.

No remote connections. This is a bog standard single-user desktop PC (5-year old Dell). It has a USB keyboard and mouse, but this has never been an issue before, only after the aptosid upgrade.
      BelaLugosi wrote:
Another thing which takes some time is to save the current KDE session (if activated in systemsettings). You may (un)check these and see if the logout speed increases.

I have always had this unchecked, and so I start with a fresh session at every login.
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject: Re: KDE now takes a long time to log out  PostPosted: 19.09.2010, 07:40



Joined: 2010-09-18
Posts: 17

Status: Offline
      polycarp wrote:
Same here but no auto-login, so it does not make a difference.

Always great to hear that you are not alone. Now I feel that it's not because I screwed something up Smile
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject: Re: RE: Re: KDE now takes a long time to log out  PostPosted: 19.09.2010, 07:43



Joined: 2010-09-18
Posts: 17

Status: Offline
      BelaLugosi wrote:
or external hdds

Ah, I just noticed you said hdd's not hid's. Nope, no external harddrives plugged in during boot, or logout.
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 19.09.2010, 07:55



Joined: 2010-09-18
Posts: 17

Status: Offline
A little more hardware info, in case it helps anyone.

Output of lsusb:
      Code:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0553:0002 STMicroelectronics Imaging Division (VLSI Vision) CPiA Webcam
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05f3:021f PI Engineering, Inc.
Bus 002 Device 002: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The 'PI Engineering, Inc.' thingy is my Contour Rollermouse mouse (highly recommended for avoiding mouse injuries).

Output of lspci:
      Code:


00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GH (ICH7DH) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
04:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller (rev 01)

Also, in case it helps someone, I have Nepomuk + Akonadi disabled, and don't use any of the KDE PIM apps.
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 19.09.2010, 14:00
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
Have you tested for the same situation with a new user account?

Seven seconds is enough time to view htop's output in a terminal. Before you log out of KDE, switch to a tty, log in as root, start htop, then back to KDE for log out. Switch to tty with htop. Any clues there?
--
Neal

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 21.09.2010, 19:52



Joined: 2010-09-18
Posts: 17

Status: Offline
      HeSaid wrote:
Seven seconds is enough time to view htop's output in a terminal. Before you log out of KDE, switch to a tty, log in as root, start htop, then back to KDE for log out. Switch to tty with htop. Any clues there?
--
Neal

It's 7 + 7 seconds, so appr. 14 seconds in all. I tested with htop on console, whilst logging out. Nothing, there's absolutely nothing going on in those 14 seconds. No process using cpu what so ever.

I'll try with a new user account and let you know how that goes.
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 21.09.2010, 20:21



Joined: 2010-09-18
Posts: 17

Status: Offline
      HeSaid wrote:
Have you tested for the same situation with a new user account?

So, I disengaged the autologin, and created a new user 'testuser'. Logging out from that user, or restarting, happens instantly, just like it's supposed to. My own user still has the same problem. Weird...

Any other good ideas?
Should I attempt to blow all kde related directories in my $HOME? Would that go well?
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 21.09.2010, 21:52
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
Before I would blow away the .kde directory, I would make an arbitrary change in systemsettings/advanced/session manager such as uncheck offer shutdown options and confirm logout.

Also, as far as I know, /home/user/.kde/shutdown should be empty.
--
Neal

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 22.09.2010, 06:01



Joined: 2010-09-18
Posts: 17

Status: Offline
      HeSaid wrote:
Before I would blow away the .kde directory, I would make an arbitrary change in systemsettings/advanced/session manager such as uncheck offer shutdown options and confirm logout.

I just tried this, doesn't make any difference.

      HeSaid wrote:
Also, as far as I know, /home/user/.kde/shutdown should be empty.

It's empty.

I just noticed something, which might be relevant or not. If I log out, then go to console and press alt-ctrl-delete to reboot, it says that KDM is not responding to the TERM signal. I do remember that this is something that sometimes happen during shutdown or reboot.
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 22.09.2010, 13:46
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
Log out, from terminal log in as root
      Code:
 init 3
exit

Log in as user
      Code:
mv ~/.kde  ~/.oldkde

log in as root
      Code:
init 5


Let us know if resolved.
--
Neal

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 26.09.2010, 10:20



Joined: 2010-09-18
Posts: 17

Status: Offline
      HeSaid wrote:
Log out, from terminal log in as root
      Code:
 init 3
exit

Log in as user
      Code:
mv ~/.kde  ~/.oldkde

log in as root
      Code:
init 5


Let us know if resolved.
--
Neal

Blowing $HOME/.kde resolves the issue. Now I will re-introduce all my settings, and see if it still sticks.
 
 View user's profile Send private message  
Reply with quote Back to top
labOffline
Post subject:   PostPosted: 26.09.2010, 12:57



Joined: 2010-09-18
Posts: 17

Status: Offline
I think I've caught the bug.

When I started to reconfigure KDE with my new .kde profile, at a certain point I triggered the 14 second logout delay. It seems that it's gtk-qt-engine at play. I have it installed otherwise I find gtk apps under KDE to be unbearable.

So, in system settings -> general -> appearence -> GTK styles and fonts, if you touch the settings, a file $HOME/.kde/env/gtk-qt-engine.rc.sh gets generated, and added to your autostart scripts (see attached). When this file is present the logout is delayed. If I remove the file, gtk-qt-engine is still functional, using it's default settings which are fine, and the logout delay is gone.

The contents of the file is:

      Code:

#!/bin/bash

# Make sure our customised gtkrc file is loaded.
export GTK2_RC_FILES=/home/user/.gtkrc-2.0-kde


The contents of /home/user/.gtkrc-2.0-kde is:

      Code:

# This file was written by KDE
# You can edit it in the KDE control center, under "GTK Styles and Fonts"

include "/usr/share/themes/Qt4/gtk-2.0/gtkrc"
include "/etc/gtk-2.0/gtkrc"

style "user-font"
{
    font_name="Bitstream Vera Sans"
}

gtk-theme-name="Qt4"
gtk-font-name="Bitstream Vera Sans 10"



kde-autostart.png
 Description:
KDE autostart
 Filesize:  30.3 KB
 Viewed:  8800 Time(s)

kde-autostart.png


 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio