Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
arwaOffline
Post subject: console keyboard setting has wrong layout  PostPosted: 04.06.2011, 10:26



Joined: 2010-09-11
Posts: 183

Status: Offline
I do not know since when this problem exists, but I think it is since the last dist-upgrade to kernel 2.6.39-1.slh.1-aptosid-686: The console has set up the wrong keyboard layout (english keyboard instead german that I have).

I already tried to
      Code:
dpkg-reconfigure keyboard-configuration
but this did not help.

In KDE (including KDM) the german keyboard layout is set up correctly.

What should I do to correct the layout in the console?

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: console keyboard setting has wrong layout  PostPosted: 04.06.2011, 10:49
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
Should be this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629180

Downgrade kbd to testing.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
jblOffline
Post subject: RE: console keyboard setting has wrong layout  PostPosted: 04.06.2011, 10:54



Joined: 2011-04-14
Posts: 11

Status: Offline
some times ago I changed KEYMAP=y in /etc/initramfs-tools/initramfs.conf
      Code:
# KEYMAP: [ y | n ]
#
# Load a keymap during the initramfs stage.
#

KEYMAP=y

this solved the problem for me
ciao. jbl
 
 View user's profile Send private message  
Reply with quote Back to top
aylaOffline
Post subject: Re: RE: console keyboard setting has wrong layout  PostPosted: 04.06.2011, 11:23



Joined: 2010-09-11
Posts: 50
Location: Germany
Status: Offline
      jbl wrote:
some times ago I changed KEYMAP=y in /etc/initramfs-tools/initramfs.conf
      Code:
# KEYMAP: [ y | n ]
#
# Load a keymap during the initramfs stage.
#

KEYMAP=y

this solved the problem for me
ciao. jbl


hmm, no change here trying this.

      Code:
kbd:
  Installiert: 1.15.3-2
uname -r
2.6.39-1.slh.1-aptosid-amd64

but I can live with that until it is fixed.
 
 View user's profile Send private message  
Reply with quote Back to top
jblOffline
Post subject: RE: console keyboard setting has wrong layout  PostPosted: 04.06.2011, 12:24



Joined: 2011-04-14
Posts: 11

Status: Offline
maybe helpful to you:

http://debianforum.de/forum/viewtopic.php?t=28377

      Quote:
1. dpkg-reconfigure locales (ist bei mir schon eingestellt kann also wegfallen)
2. dpkg-reconfigure console-data
=> OK
=> Wähle Keymap aus Liste
=> querz
=> German
=> Standard
=> latin1 - no dead keys
=> OK
3. dpkg-reconfigure console-common (die vorher mit *dpkg-reconfigure console-data* ausgewählte keymap wird automatisch gewählt, man hat keine Möglichkeit etwas auszuwählen)
4. dpkg-reconfigure console-tools
5. Erneutes Anmelden und die locales + keymap laufen.
 
 View user's profile Send private message  
Reply with quote Back to top
aylaOffline
Post subject:   PostPosted: 04.06.2011, 12:47



Joined: 2010-09-11
Posts: 50
Location: Germany
Status: Offline
That may solve the issue, too, because installing console-tools will remove kbd.
As I don't know what konsequences this may have for further upgrades I will wait for a fix insteed.

Thanks anyway

greets
ayla
 
 View user's profile Send private message  
Reply with quote Back to top
jblOffline
Post subject:   PostPosted: 04.06.2011, 13:26



Joined: 2011-04-14
Posts: 11

Status: Offline
on my system are console-data (2:1.10-9) and kbd (1.15.3-2)
don't install console-tools. only console-data should be there.
then dpkg-reconfigure console-data

some weeks ago I had the problem keyboard-us in tty and keyboard-de in xfce.
1. dpkg-reconfigure console-data
2. changing KEYMAP=y in initramfs.conf

that was the solution on my system
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 04.06.2011, 14:20



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
fixed by a fast maintainer: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629180

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
aylaOffline
Post subject:   PostPosted: 04.06.2011, 14:24



Joined: 2010-09-11
Posts: 50
Location: Germany
Status: Offline
tried again:

      Code:
dpkg-reconfigure console-data
Looking for keymap to install:
de-latin1-nodeadkeys
argc=3, optind=2
argc=3, optind=2
argc=3, optind=2

initramfs.conf:
      Code:
#
# KEYMAP: [ y | n ]
#
# Load a keymap during the initramfs stage.
#

KEYMAP=y

then
      Code:
update-initramfs -u
reboot


no change. Still uses us-layout in int 3.
Version of console-data and of kbd are matching yours.

greets
ayla
EDIT: read devils post after posting by myself, so I will try to upgrade again after next mirrorsync.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio