Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
arwaOffline
Post subject: intel onchip graphics HD-2000 / HD-3000 Sandy Bridge?  PostPosted: 14.06.2011, 17:16



Joined: 2010-09-11
Posts: 183

Status: Offline
Hello,

is anybody using a Sandy Bridge CPU i5 or i7 with the onchip graphics GPU HD-2000 or HD-3000? Is this hardware supported by the current debian/aptosid software versions like kernel 2.6.39, mesa 7.10, xserver-xorg-video-intel 2.15.0, etc?

Does it work reliable or do graphics errors or crashes, etc., occur?

The reason why I am asking: I think about buying such a PC and wonder if it is a good idea to try using this GPU. Some reports of Ubuntu users (with older kernel 2.6.37) and one of an OpenSuse user with 2.6.39 kernel sound not very good, as I have found in the web.

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: intel onchip graphics HD-2000 / HD-3000 Sandy Bridge?  PostPosted: 14.06.2011, 17:19



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
Devil has an i7 with HD-3000. It's supportet in aptosid.
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject: RE: intel onchip graphics HD-2000 / HD-3000 Sandy Bridge?  PostPosted: 14.06.2011, 17:32



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
as towo said, i built a box with a core i7 2600k with a HD 3000 onboard.
the only trouble i had in the beginning was with xserver-xorg-video-intel 2.12.x.
all menues were garbled and you had to know them by heart to be able to use them.
there was no other problems with 2.6.38 or 2.6.39.
for me the HD3000 is fully sufficient, no other card needed.

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
dieresOffline
Post subject:   PostPosted: 14.06.2011, 17:34



Joined: 2010-09-12
Posts: 30

Status: Offline
      Code:
root@aptosidbox:/home/didi# infobash -v3
Host/Kernel/OS  "aptosidbox" running Linux 2.6.39-1.slh.4-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-lite - (201009132215) ]
CPU Info        4x Intel Core i3 550 @ 4096 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2133.000 MHz ]
Videocard       Intel Core Processor Integrated Graphics Controller  X.Org 1.10.2  [ 1920x1080@60.0hz ]
Network cards   Realtek RTL8111/8168B PCI Express Gigabit
Processes 140 | Uptime 12min | Memory 898.7/11334.7MB | HDD SAMSUNG HD501LJ,OCZ-VERTEX2 Size 620GB (66%used) | Client Shell | Infobash v3.36


Is running without any problems, connected via hdmi to 24" display.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 14.06.2011, 17:46



Joined: 2010-09-11
Posts: 183

Status: Offline
Great to hear. Thank you for the quick response!

I think I will go for the i7-2600k, too. My last PC is about ten years old, so the new one can be a little bit faster than average.

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 14.06.2011, 18:23



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
arwa,
if you can, combine that with a SSD, for example a OCZ Vertex 3. that makes another real difference.

      Code:

Host/Kernel/OS  "aptosidbox" running Linux 2.6.39-1.slh.4-aptosid-amd64 x86_64 [ aptosid 2011-01 Γῆρας - kde-lite - (201102051540) ]
CPU Info        8x Intel Core i7-2600K @ 8192 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 3200.000 MHz ]                                                             
Videocard       Intel 2nd Generation Core Processor Family Integrated Graphics Controller  X.Org 1.10.2  [ 1920x1080@60.0hz ]                                             
Network cards   Realtek RTL8111/8168B PCI Express Gigabit                                                                                                                 
Processes 204 | Uptime 2days | Memory 1688.8/7921.2MB | HDD [color=red]OCZ-VERTEX3[/color],ST3160023AS,6400AAK External Size 920GB (32%used) | Client Shell | Infobash v3.36 


greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 14.06.2011, 20:03



Joined: 2010-09-11
Posts: 183

Status: Offline
devil, thanks for the affirmation. A friend suggested an SSD, too, that in my first plan I had left out because of the high price. But I will order one now, too.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 25.06.2011, 13:08



Joined: 2010-09-11
Posts: 183

Status: Offline
I now can give the feedback that the system really works very fine with intel HD-3000 graphics. It runs out of the box without any required tweaks. Also the graphic artifacts/noise on the logout screen and in freshly opened windows/menus before they are filled with the real content does not show up here, other than on the PC with the nouveau driver and and old Gforce 6200 card IIRC. KDE is really fast now using the OpenGL composite backend (Ok, the whole system is much faster because of its up to date hardware). All effects do work fine. Great.

But I also found two issues:

a) The game bloboats does work, but the letters in the menus are missing.

b) xmoto does run fine, but when quitting the game, the whole X-Server crashes and I get back to kdm. From the /var/log/Xorg.0.log:
      Code:
[  8530.518]
Backtrace:
[  8530.520] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a3836]
[  8530.520] 1: /usr/bin/X (0x400000+0x65049) [0x465049]
[  8530.520] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f78c6c0c000+0xf020) [0x7f78c6c1b020]
[  8530.520] 3: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x80521) [0x7f78c29f1521]
[  8530.520] 4: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x69fe6) [0x7f78c29dafe6]
[  8530.520] 5: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x5a244) [0x7f78c29cb244]
[  8530.520] 6: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x13fc63) [0x7f78c2ab0c63]
[  8530.520] 7: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x13dabc) [0x7f78c2aaeabc]
[  8530.520] 8: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x13dc9a) [0x7f78c2aaec9a]
[  8530.520] 9: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (0x7f78c2971000+0x1021db) [0x7f78c2a731db]
[  8530.520] 10: /usr/lib/xorg/modules/extensions/libglx.so (0x7f78c43b3000+0x22d17) [0x7f78c43d5d17]
[  8530.520] 11: /usr/lib/xorg/modules/extensions/libglx.so (0x7f78c43b3000+0x254d5) [0x7f78c43d84d5]
[  8530.520] 12: /usr/bin/X (0x400000+0x32d09) [0x432d09]
[  8530.520] 13: /usr/bin/X (0x400000+0x26fae) [0x426fae]
[  8530.520] 14: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xfd) [0x7f78c5945ead]
[  8530.520] 15: /usr/bin/X (0x400000+0x2729d) [0x42729d]
[  8530.520] Segmentation fault at address (nil)
[  8530.520]
Fatal server error:
[  8530.520] Caught signal 11 (Segmentation fault). Server aborting
[  8530.520]
[  8530.520]

Should I report this somewhere? If so, for which package?

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 25.06.2011, 13:19
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
@arwa, here: http://bugs.debian.org/cgi-bin/pkgrepor ... t=unstable
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 28.06.2011, 20:22



Joined: 2010-09-11
Posts: 183

Status: Offline
Hm, well, the intel HD-3000 drivers seem to have some problems. On normal use everything seems pretty ok. But after the issue with xmoto I have tried bzflag. On startup the game graphics did change to psychadelic colors and the system locked up. I had to reboot. In the /var/log/Xorg.0.log.old there was not that much information:
      Code:

[    87.925] (EE) intel(0): Detected a hung GPU, disabling acceleration.
[    87.925] (EE) intel(0): When reporting this, please include i915_error_state from debugfs and the full dmesg.


devil, is xmoto and bzflag running fine on your HD-3000 system?
 
 View user's profile Send private message  
Reply with quote Back to top
LanziOffline
Post subject:   PostPosted: 30.06.2011, 21:48



Joined: 2010-09-11
Posts: 126
Location: Hessen
Status: Offline
devil is no longer on this forum. You find him on aptosid.de. You can also state your posts in english, since he answerd you here

_________________
Urlaub im Harz? http://pension-grueneinsel.de
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 30.06.2011, 23:56
Team Member


Joined: 2010-08-26
Posts: 255

Status: Offline
I'd no problems with xmoto or bloboats on a hd3000. bzflag went a bit nuts though and while it didn't hang things I had to Ctrl-Alt-F1, "kill -KILL bzflag" and now some things (like this browser) look funny so I see an X restart coming up. I've a bit more info in dmesg but honestly it doesn't seem very useful to me (and I've no idea how to get more out of debugfs).

Sorry it took so long to have a look, but honestly your tales of hard lockups made me not want to bother looking until I didn't care about rebooting anyway Wink
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 01.07.2011, 07:21



Joined: 2010-09-11
Posts: 183

Status: Offline
I did not check this out yet, but it seems that for debugging intel GPU this package might be of interest: intel-gpu-tools

http://intellinuxgraphics.org/intel-gpu-dump.html
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio