Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [Solved] resolution on virtual terminals  PostPosted: 05.07.2011, 14:24



Joined: 2010-09-12
Posts: 316

Status: Offline
Dear all,

Recently the resolution of the virtual terminals ([Ctrl+Alt+Fn] for n=1..6) has decreased considerably, yielding large characters. It was working until recently.

Here is some info about my system: Lenovo T510, with proprietary nvidia driver (installed according to the manual) and fully up to date.

      Code:

root@t510[/home/finotti]# infobash -v3
Host/Kernel/OS  "t510" running Linux 2.6.39-2.slh.3-aptosid-amd64 x86_64 [ sidux 2010-01 Ύπνος - kde-full - (201006131622) ]
CPU Info        4x Intel Core i5 M 520 @ 3072 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 1199.000 MHz ]
Videocard       nVidia GT218 [NVS 3100M]  X.Org 1.10.2.902  [ 1366x768@50.0hz ]
Network cards   Intel 82577LM Gigabit
                Intel Centrino Advanced-N 6200
Processes 161 | Uptime 9min | Memory 968.3/3828.7MB | HDD C300-CTFDDAC128M Size 128GB (66%used) | GLX Renderer NVS 3100M/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 275.09.07 | Client Shell | Infobash v3.36


      Code:

root@t510[/home/finotti]# cat /etc/X11/xorg.conf.d/20-nvidia.conf
#
Section "Device"
         Identifier      "Device 0"
         Driver          "nvidia"
#         Driver          "nv"
         Option          "RegistryDwords" "EnableBrightnessControl=1"
EndSection
# This is a trailing line, it is needed so that End Section is not the last line


Xorg.0.log is here: http://paste.pocoo.org/show/430036/

Note: this last section was started with the deprecagted "vga=791" in grub, just for testing. (It did not work.) I am not sure this affects the log above.

Thanks,

Luis


Last edited by finotti on 09.08.2011, 20:28; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 12:50



Joined: 2010-09-12
Posts: 316

Status: Offline
I still have this problem, but only in my laptop. My desktop also runs nvidia proprietary driver and has no problems.

No one has any ideas on this?

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 19:25



Joined: 2010-09-11
Posts: 183

Status: Offline
I always have to look for the right package again. IIRC you can configure the console font by
      Code:
dpkg-reconfigure console-setup
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 19:34



Joined: 2010-09-12
Posts: 316

Status: Offline
Thanks, arwa. But I could not fix it. I guess a better way to phrase my problem is that the terminal is not using frame buffer anymore....

Thanks again,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 20:03



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Offline
cat /etc/default/grub
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 20:09



Joined: 2010-09-12
Posts: 316

Status: Offline
Sorry... I could swear I had it in my original post:

      Code:

root@t510[/home/finotti]# cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=a3a7552f-7b77-402f-a52a-e663c4a506c6"
GRUB_CMDLINE_LINUX="elevator=noop"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 20:11



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Offline
Use
      Code:

GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768

in /etc/default/grub and do update-grub after putting this in.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: resolution on virtual terminals  PostPosted: 09.08.2011, 20:27



Joined: 2010-09-12
Posts: 316

Status: Offline
Thanks, towo. That worked. (It didn't at first, but I think it was because I had messed up with console-setup. I've selected "do not change the boot/kernel font" and all is fine.

Thanks again,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio