Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
debabaOffline
15 Post subject: [Solved] Warning on d-u  PostPosted: 20.07.2011, 13:18



Joined: 2010-09-11
Posts: 34
Location: Hessen
Status: Offline
Moin everybody

when trying to dist-upgrade a little vdr-server from
2.6.38-3.slh.5-aptosid-686
to 2011-02 i get a huge list of packages to remove plus a warning:
      Code:


WARNUNG: Die folgenden essentiellen Pakete werden entfernt.
Dies sollte NICHT geschehen, außer Sie wissen genau, was Sie tun!
  sysvinit
260 aktualisiert, 70 neu installiert, 415 zu entfernen und 26 nicht aktualisiert.


So i wonder if you are trying to replace sysvinit in the new 2011-02 or if i have a real problem Confused

Thanks for the ongoing good work on aptosid to the team.

debaba


Last edited by debaba on 20.07.2011, 14:47; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 13:36
Team Member


Joined: 2010-08-26
Posts: 254

Status: Offline
Probably not much chance of anyone helping you without seeing the full output, particularly the packages being removed and held.

sysvinit certainly should not be let go though so I guess you have a "real problem".
 
 View user's profile Send private message  
Reply with quote Back to top
debabaOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 14:00



Joined: 2010-09-11
Posts: 34
Location: Hessen
Status: Offline
@bfree
      Code:

root@vdr:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  akonadiconsole akregator apache2 apache2-mpm-prefork apache2.2-common apt-xapian-index aptosid-art-kde aptosid-art-kde-apate
  aptosid-art-kdm-apate aptosid-art-ksplash-apate aptosid-irc aptosid-settings-kde ark blinken blogilo bluetooth bluez bluez-utils bomber bovo
  build-essential cantor capisuite cdbs cdfs-src ceni checkinstall chkrootkit cmake cups debconf-i18n debhelper denyhosts devscripts dict
  distcc dkms doc-base docbook2x dolphin dpkg-dev dvb-s2api-liplianin-headers dvb-s2api-liplianin-source equivs foo2zjs ftp
  gcj-4.4-jre-headless gcj-jre-headless gconf2 gij gnucash-common granatier gstreamer-tools gstreamer0.10-tools gwenview iceweasel infobash
  iotop irssi jackd jackd2 juk kaddressbook kalarm kalgebra kalzium kamera kanagram kapman kappfinder kate katomic kbattleship kblackbox
  kblocks kbounce kbreakout kbruch kcalc kcharselect kcolorchooser kde-config-cddb kde-config-cron kde-plasma-desktop kde-plasma-netbook
  kde-window-manager kdeadmin kdeartwork kdebase-apps kdebase-bin kdebase-runtime kdebase-runtime-data kdebase-workspace kdebase-workspace-bin
  kdeedu kdegames kdegraphics kdelibs5 kdelibs5-dev kdelibs5-plugins kdemultimedia-dev kdemultimedia-kio-plugins kdenetwork kdepasswd kdepim
  kdepim-groupware kdepim-kresources kdepim-runtime kdepim-strigi-plugins kdepim-wizards kdepimlibs-kio-plugins kdepimlibs5 kdeplasma-addons
  kdeutils kdf kdiamond kdiff3 kdm kdoctools kernel-package kfind kfloppy kfourinline kgeography kget kgoldrunner kgpg khangman kig kigo
  killbots kiriki kiten kjots kjumpingcube kleopatra klettres klines klipper kmahjongg kmail kmines kmix kmplot knetwalk knetworkconf knode
  knotes kolf kollision kolourpaint4 konqueror konquest konsole konsolekalendar kontact kopete korganizer kpat krdc kreversi krfb kruler ksame
  kscd kscreensaver kshisen ksirk ksnapshot kspaceduel ksquares kstars ksudoku ksysguard ksystemlog ktimer ktimetracker ktouch ktron ktuberling
  kturtle kubrick kuser kwalletmanager kwiki kwordquiz kwrite libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libapache2-mod-php5 libapt-pkg-perl libart-2.0-dev libartsc0-dev libatk1.0-dev libaudio-scrobbler-perl libavahi-client-dev libavcodec-dev
  libcairo-perl libcairo2-dev libcrypt-ssleay-perl libcurl4-openssl-dev libcurses-perl libcurses-ui-perl libdbus-1-dev libdbus-glib-1-dev
  libdigest-sha1-perl libdvdnav-dev libdvdread-dev libesd0-dev libexpect-perl libfile-libmagic-perl libfilter-perl libfinance-quote-perl
  libfontconfig1-dev libgcj-common libgcj10 libgd2-xpm-dev libgda-4.0-dev libgdk-pixbuf2.0-dev libglib-perl libglib2.0-dev libglibmm-2.4-dev
  libgnomevfs2-0 libgnomevfs2-common libgphoto2-2-dev libgtk2-perl libgtk2.0-dev libgtop2-dev libhildonmime0 libid3tag0-dev libidn11-dev
  libio-all-perl libio-pty-perl libio-socket-inet6-perl libipc-run-perl libjack-jackd2-0 libkabc4 libkblog4 libkcal4 libkcddb-dev libkcddb4
  libkde3support4 libkdeedu4 libkdegames5 libkdepim4 libkdewebkit5 libkfile4 libkhtml5 libkimproxy4 libkio5 libkipi7 libkleo4 libkmediaplayer4
  libknewstuff2-4 libknewstuff3-4 libknotificationitem-1-1 libknotifyconfig4 libkonq-common libkonq5 libkonqsidebarplugin4a
  libkontactinterface4 libkopete4 libkparts4 libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkrossui4 libksane0 libktexteditor4
  libktnef4 libktorrent2 libkutils4 libkwebkit1 libkwiki-perl libkwineffects1a libkworkspace4 libkxmlrpcclient4 liblocale-gettext-perl
  libmagick++-dev libmagickcore-dev libmagickwand-dev libmailtransport4 libmessagecore4 libmessagelist4 libmicroblog4 libmjpegtools-dev
  libmpeg2-4-dev libntfs-3g75 libogg-vorbis-perl libokularcore1 libpango-perl libpango1.0-dev libparse-debianchangelog-perl libperl5.10
  libplasma3 libplasmaclock4a libplasmagenericshell4 librsvg2-dev libsamplerate0-dev libschroedinger-dev libsigc++-2.0-dev libsndfile1-dev
  libsnmp15 libsocket6-perl libspiffy-perl libspoon-perl libsyndication4 libtar libtaskmanager4a libtemplate-perl libterm-readkey-perl
  libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libuuid-perl libweather-ion4a libwebservice-musicbrainz-perl libwww-perl
  libxft-dev libxine-dev libxine1-gnome libxml++2.6-dev libxml-libxml-perl libxml-parser-perl libxml-sax-expat-perl libxml-twig-perl libzen-dev 
  lintian linux-tools-2.6 linux-tools-2.6.38 lskat mailutils make marble mercurial mercurial-common module-assistant mp3cd nagios-plugins       
  nagios-plugins-basic nagios-plugins-standard netbase nfs-common nfs-kernel-server ntfsprogs ntp ntpdate okteta okular openprinting-ppds       
  openssh-server openssl-blacklist palapeli parley php5-gd php5-sqlite pkg-config plasma-dataengines-addons plasma-dataengines-workspace         
  plasma-desktop plasma-netbook plasma-runners-addons plasma-scriptengine-googlegadgets plasma-scriptengine-javascript                           
  plasma-scriptengine-qedje plasma-scriptengine-superkaramba plasma-scriptengine-webkit plasma-wallpapers-addons plasma-widget-folderview       
  plasma-widget-lancelot plasma-widgets-addons plasma-widgets-workspace postfix ppp pppconfig pppoeconf procps pulseaudio                       
  pulseaudio-esound-compat pulseaudio-module-x11 python python-apt python-apt-common python-central python-chardet python-dbus python-debian     
  python-gobject python-mysqldb python-openssl python-profiler python-pygments python-qt4 python-sip python-support python-tk python-xapian     
  qjackctl ripit rocs samba sendemail smbclient step svn-buildpackage sweeper systemsettings sysvinit telnet ufw vsftpd xinetd                   
Die folgenden NEUEN Pakete werden installiert:                                                                                                   
  cpp-4.6 fuse g++-4.6 gcc-4.6 gcj-4.6-base grub-pc-bin grub2-common iceape-browser jackd1 libavcodec53 libavdevice53 libavfilter2               
  libavformat53 libavutil51 libboost-filesystem1.46.1 libboost-regex1.46.1 libboost-system1.46.1 libcrystalhd3 libcv2.1 libdbusmenu-qt2         
  libdlrestrictions1 libdmtx0a libdvbpsi7 libjack0 libkcmutils4 libkephal4abi1 libkidletime4 libmaa3 libmatroska4 libmhash2 libmjpegtools-2.0-0 
  libmount1 libmozjs5d libmtp-common libnepomukutils4 liboktetacore4 liboktetagui4 libpam-modules-bin libperl5.12 libpoppler13                   
  libprocesscore4abi1 libquicktime2 libqzeitgeist0 libsane-common libsane-extras-common libsolidcontrol4abi1 libsolidcontrolifaces4abi1         
  libstdc++6-4.6-dev libswscale2 libtar0 libvo-aacenc0 libvo-amrwbenc0 libwireshark1 libwiretap1 libwsutil1 libx264-115 libx264-116             
  linux-headers-2.6.39-3.slh.2-aptosid-686 linux-headers-aptosid-686 linux-source-2.6.39 multiarch-support openbsd-inetd python3
  python3-minimal python3.1 python3.1-minimal qt4-linguist-tools weechat-core weechat-curses xulrunner-5.0
Die folgenden Pakete sind zurückgehalten worden:
  base-files dvdauthor kid3-qt libclamav6 libffado-dev libffado2 libgphoto2-2 libgphoto2-port0 libisofs6 libmailutils2 libogmrip1 librdf0
  libsmbclient linux-image-2.6-aptosid-686 ocaml-base-nox python-doc python-minimal resolvconf rpm-common rsyslog samba-common-bin samba-tools
  texmaker transcode vlc vlc-nox
Die folgenden Pakete werden aktualisiert (Upgrade):
  cpp cpp-4.4 cpp-4.5 ffmpeg fuse-utils g++ g++-4.4 g++-4.5 gcc gcc-4.4 gcc-4.4-base gcc-4.5 gcc-4.5-base gcc-4.6-base gcj-4.4-base
  gir1.2-atk-1.0 gir1.2-gdkpixbuf-2.0 gpac grub-common grub-pc grub2 kdebase-data kdebase-workspace-data kdebase-workspace-kgreet-plugins
  kdelibs-bin kdelibs5-data ksysguardd libassuan0 libatk1.0-0 libatk1.0-data libavahi-client3 libavahi-common-dev libavahi-common3
  libavahi-compat-libdnssd1 libavahi-glib1 libavcodec52 libavdevice52 libavfilter1 libavformat-dev libavformat52 libavutil-dev libavutil50
  libbs2b0 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libcfitsio3 libcompress-raw-bzip2-perl libcompress-raw-zlib-perl libcrystalhd-dev
  libcups2 libcups2-dev libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libdatrie1 libdb4.8
  libdb4.8-dev libdb5.1 libdbus-1-3 libdbus-glib-1-2 libdrm-dev libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2 **removed** libegl1-mesa
  libegl1-mesa-dev libfaac-dev libfaac0 libfame-0.9-1 libfame-dev libffms2-2 libfreetype6 libfreetype6-dev libfuse2 libgcc1 libgcrypt11
  libgcrypt11-dev libgdk-pixbuf2.0-0 libgfortran3 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev libgomp1
  libgpac0.4.6 libgudev-1.0-0 libhtml-parser-perl libice-dev libice6 libidn11 libio-compress-perl libkdecorations4 libkdecore5 libkdesu5
  libkdeui5 libkdnssd4 libkeyutils1 libkjsapi4 libkjsembed4 libkms1 libkntlm4 libkpty4 libkrosscore4 libksba8 libkscreensaver5 libksgrd4
  libksignalplotter4 libkunitconversion4 libmediainfo0 libmp3lame-dev libmp3lame0 libmp4v2-1 libmp4v2-dev libmtp8 libnepomuk4 libnepomukquery4a
  libnspr4-0d libnss3-1d libpam-modules libpam0g libphonon-dev libphonon4 libpipeline1 libpixman-1-0 libpixman-1-dev
  libplasma-geolocation-interface4 libpng12-0 libpng12-dev libpostproc-dev libpostproc51 libproc-processtable-perl libprocessui4a
  libpulse-browse0 libpulse-mainloop-glib0 libpulse0 libqt4-core libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-gui
  libqt4-help libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite
  libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libquadmath0 libquicktime-dev librasqal3 libsane libsane-extras
  libselinux1 libsensors4 libsm-dev libsm6 libsolid4 libssh-4 libstdc++6 libstdc++6-4.4-dev libstdc++6-4.5-dev libsub-name-perl libsvn-perl
  libswscale-dev libswscale0 libtasn1-3 libtasn1-3-dev libthai0 libthreadweaver4 libtirpc1 libudev0 libwbclient0 libx11-6 libx11-dev
  libx11-xcb1 libx264-dev libxcb-dri2-0 libxcb-randr0 libxcb-render0 libxcb-render0-dev libxcb-shape0 libxcb-shm0 libxcb-shm0-dev
  libxcb-xfixes0 libxcb-xv0 libxcb1 libxcb1-dev libxcomposite-dev libxcomposite1 libxcursor-dev libxcursor1 libxdmcp-dev libxdmcp6 libxext-dev
  libxext6 libxft2 libxi-dev libxi6 libxinerama-dev libxinerama1 libxrandr-dev libxrandr2 libxt-dev libxt6 libxvidcore4 libxvidcore4-dev
  libxxf86vm-dev libxxf86vm1 libyaml-syck-perl libzen0 linux-headers-2.6-aptosid-686 linux-source-2.6 mediainfo mediainfo-gui mencoder
  mesa-common-dev mjpegtools mkvtoolnix mount **removed** ntfs-3g perl perl-base perl-modules phonon pulseaudio-utils qt4-designer qt4-dev-tools
  qt4-qmake qt4-qtconfig quicktime-utils samba-common sfftobmp tshark udev wireshark wireshark-common x264 xserver-xorg-core
  xserver-xorg-video-radeon y4mscaler
WARNUNG: Die folgenden essentiellen Pakete werden entfernt.
Dies sollte NICHT geschehen, außer Sie wissen genau, was Sie tun!
  sysvinit
260 aktualisiert, 70 neu installiert, 415 zu entfernen und 26 nicht aktualisiert.
Es müssen 401 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 473 MB Plattenplatz freigegeben.
Sie sind im Begriff, etwas potentiell Schädliches zu tun.
Zum Fortfahren geben Sie bitte »Ja, tue was ich sage!« ein.
 ?] n
Abbruch.
root@vdr:~#


believe it's a real problem too

thanks
debaba
 
 View user's profile Send private message  
Reply with quote Back to top
debabaOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 14:33



Joined: 2010-09-11
Posts: 34
Location: Hessen
Status: Offline
Excuse
had an entry in /etc/apt/preferences.d
which pointed some packages to a stable version.
So...

thanks again
debaba

don't know how to set this thread to status solved
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 14:36
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
EDIT: Ok, that's done then. Edit your first entry.

---------
Original text:
That's a real problem. Could you give the output of
      Code:
dpkg --get-selections | grep hold
hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
debabaOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 14:49



Joined: 2010-09-11
Posts: 34
Location: Hessen
Status: Offline
@ hubi

D-U is already running. do you want the output after d-u?

debaba
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: Warning on d-u  PostPosted: 20.07.2011, 15:09
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
If everything is ok there is no need to continue this thread. In case of a new problem just open a new thread.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio