Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
barbasla
Post subject: libc6-dev_2.13-8_i386.deb can not be installed in DU  PostPosted: 03.07.2011, 15:18



Joined: 2011-01-27
Posts: 41

# apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev : Depends: libc6 (= 2.13-7) but 2.13-8 is installed
Depends: libc-dev-bin (= 2.13-7) but 2.13-8 is installed
E: Unmet dependencies. Try using -f.

# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libc6-dev
Suggested packages:
glibc-doc manpages-dev
The following packages will be upgraded:
libc6-dev
1 upgraded, 0 newly installed, 0 to remove and 375 not upgraded.
9 not fully installed or removed.
Need to get 0 B/4866 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 398915 files and directories currently installed.)
Preparing to replace libc6-dev 2.13-7 (using .../libc6-dev_2.13-8_i386.deb) ...
Unpacking replacement libc6-dev ...
dpkg-deb (subprocess): failed to read on buffer copy for failed to write to pipe in copy: Input/output error
dpkg-deb: error: subprocess paste returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libc6-dev_2.13-8_i386.deb (--unpack):
short read on buffer copy for backend dpkg-deb during `./usr/lib/i386-linux-gnu/xen/libc.a'
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libc6-dev_2.13-8_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


How can you fix it?


Thank you.

Hello. Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: libc6-dev_2.13-8_i386.deb can not be installed in DU  PostPosted: 03.07.2011, 15:27



Joined: 2010-09-19
Posts: 169

Status: Offline
Looks to me libc6-dev_2.13-8_i386.deb is corrupted. I'd suggest to run
      Code:
apt-get clean
apt-get update && apt-get -install -f

I'm using "&&" because sometimes apt-get update gives errors and we want to make sure apt-get knows about what's available in the repos

Another cause may be that the installation is running out of space
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject: RE: libc6-dev_2.13-8_i386.deb can not be installed in DU  PostPosted: 03.07.2011, 15:58
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
The libc6 conversion to the new multiarch structures is happening. Please be patient a couple of days.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
barbasla
Post subject: Re: RE: libc6-dev_2.13-8_i386.deb can not be installed in DU  PostPosted: 03.07.2011, 16:19



Joined: 2011-01-27
Posts: 41

      slam wrote:
The libc6 conversion to the new multiarch structures is happening. Please be patient a couple of days.
Greetings,
Chris



Ok.
Thank you.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio