Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
beppe_rmOffline
Post subject: [SOLVED] very slow UMTS connection  PostPosted: 03.08.2011, 20:42



Joined: 2010-09-23
Posts: 41
Location: rome
Status: Offline
Hi friends,

I have this modem:
Bus 001 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270 HSDPA/HSUPA Modem

the provider is the first italian provider (TIM), and I have a good signal; but the connection is very very slow; a test indicated to me the speed to be 0.09 Mb!

this is my wvdial.conf
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","ibox.tim.it"
Password = 0
Phone = *99#
Idle Seconds = 10000
Modem Type = Analog Modem
Stupid Mode = 1
Compuserve = 0
Baud = 9600
New PPPD = yes
Dial Command = ATDT
Modem = /dev/ttyUSB0
ISDN = 0
Username = 0

do you have any idea to speed up the connection?
many thanks

beppe


Last edited by beppe_rm on 04.08.2011, 21:41; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: very slow UMTS connection  PostPosted: 03.08.2011, 20:55



Joined: 2010-08-25
Posts: 731

Status: Offline
I changed your topic name from "very slow modem connection" to "very slow UMTS connection", because this has nothing to do with analogue modems as we know them from the past.

While I have no experience with UMTS myself, your configured baud rate looks like a smoking gun.
 
 View user's profile Send private message  
Reply with quote Back to top
muchan
Post subject: RE: very slow UMTS connection  PostPosted: 04.08.2011, 08:44
Moderator


Joined: 2010-09-11
Posts: 468

your previous wvdial.conf had baud = 7200000, now 9600?
http://aptosid.com/index.php?name=PNphp ... amp;t=1267
 
 View user's profile Send private message  
Reply with quote Back to top
dptOffline
Post subject: RE: very slow UMTS connection  PostPosted: 04.08.2011, 13:36



Joined: 2010-09-11
Posts: 281
Location: New Delhi
Status: Offline
What is and why
stupid mode = 1 ?

_________________
In a lunatic asylum, everyone thinks that he is the doctor.
 
 View user's profile Send private message AIM Address  
Reply with quote Back to top
bfreeOffline
Post subject: RE: very slow UMTS connection  PostPosted: 04.08.2011, 13:43
Team Member


Joined: 2010-08-26
Posts: 250

Status: Offline
      man wvdial.conf wrote:

Stupid Mode
When wvdial is in Stupid Mode, it does not attempt to interpret any prompts from the terminal server. It starts pppd immediately after the modem connects. Apparently there are ISP's that actually give you a login prompt, but work only if you start PPP, rather than logging in. Go figure. Stupid Mode is (naturally) disabled by default.

I've yet to hear of someone who _needed_ to _not_ use stupid mode for a umts/3g connection, but the simple fact is that every ISP can be as wierd as they want to be as long as they can make their "software" for windows (and instructions for Mac I guess) handle it.
 
 View user's profile Send private message  
Reply with quote Back to top
beppe_rmOffline
Post subject:   PostPosted: 04.08.2011, 13:45



Joined: 2010-09-23
Posts: 41
Location: rome
Status: Offline
thanks slh for the change of title.
I followed muchan advice, so I put 7.2 kb, and now speed is better (speedtest.net gave 0.2 kb aganist the last 0.08 kb).
I really don't know why stupid mode is 1: what means?

beppe
 
 View user's profile Send private message  
Reply with quote Back to top
beppe_rmOffline
Post subject:   PostPosted: 04.08.2011, 13:48



Joined: 2010-09-23
Posts: 41
Location: rome
Status: Offline
so. stupid mode has to be 1 or other?
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject:   PostPosted: 04.08.2011, 14:05
Team Member


Joined: 2010-08-26
Posts: 250

Status: Offline
If it is working with stupid mode as 1 then I wouldn't think you need to change it. You can try of course but I doubt it will make any difference to the speed.

Just to confirm, you now have:

      Code:
Baud = 7200000
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 04.08.2011, 14:20
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Try with this /etc/wvdial.conf:
      Code:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Dial Command = ATD
Carrier Check = no
Phone = *99#
Password = 0
Username = 0
Stupid Mode = 1
Init4 = AT+CGDCONT=1,"IP","ibox.tim.it"

Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
beppe_rmOffline
Post subject:   PostPosted: 04.08.2011, 21:40



Joined: 2010-09-23
Posts: 41
Location: rome
Status: Offline
thanks friends;

I have Baud=7200000, but I don't think this is important, I suspect that I have a top speed limit set up by provider;

slam: thanks, your wvdial works, but two tests showed me it is slower than mine.

the best thing I think is to consider solved this topic.

thanks again
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio