Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
effoOffline
15 Post subject: (solved) System time not stored  PostPosted: 09.08.2011, 16:40



Joined: 2010-09-11
Posts: 22
Location: Linköping, Sweden
Status: Offline
Hi all,
A d-u this weekend (after not du-ing for a while) seem to have messed up the handling of system time. Problem: clock is two hour behind.

Here is the full story:

During boot I enter BIOS to check clock is correct. Clock shows 17:09:56

After booting into init 3, let’s check date:

      Code:
$ date
Tue Aug  9 15:11:46 CEST 2011


Ok, let’s correct date using ntpdate-debian:

      Code:
$ ntpdate-debian
 9 Aug 17:12:23 ntpdate[7625]: step time server 130.236.254.17 offset 7199.910742 sec


Verify with date:

      Code:
$ date
Tue Aug  9 17:13:57 CEST 2011


Now take eth0 down/up to get something into log

      Code:
$ ifdown eth0
$ ifup eth0


Log shows
      Code:
Aug  9 17:17:05 siduxbox kernel: [  448.385247] via-rhine 0000:00:12.0: eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1


Seems ok. Now reboot.
After reboot, check date again:

      Code:
$ date
Tue Aug  9 15:21:46 CEST 2011


Back to point A again.. Sad

Anything interesting in /var/log/messages? Well, to me this look strange, but maybe it is not?

      Code:
Aug  9 17:18:55 siduxbox shutdown[2600]: shutting down for system reboot
Aug  9 17:18:00 siduxbox exiting on signal 15
Aug  9 17:19:52 siduxbox syslogd 1.5.0#6.1: restart.
Aug  9 15:20:47 siduxbox /usr/sbin/gpm[6626]: *** info [daemon/startup.c(131)]:
Aug  9 15:20:47 siduxbox /usr/sbin/gpm[6626]: Started gpm successfully. Entered daemon mode.
Aug  9 15:20:48 siduxbox kernel: Inspecting /boot/System.map-3.0-1.slh.4-aptosid-686


It seems like the date/time is correct at boot time but then gets changed.

Can anybody explain what is going on? Any ideas on how this can be resolved?
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: System time not stored  PostPosted: 09.08.2011, 20:38
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Try in konsole

      Code:
sux (root password)

dbus-launch systemsettings

system administration --> date & time


and reboot

has always been 100% reliable for me
 
 View user's profile Send private message  
Reply with quote Back to top
effoOffline
Post subject:   PostPosted: 10.08.2011, 04:11



Joined: 2010-09-11
Posts: 22
Location: Linköping, Sweden
Status: Offline
Thanks for the suggestion, but it doesn't work.

      Code:
Aug 10 03:59:51 siduxbox -- MARK --
Aug 10 06:03:53 siduxbox kernel: [ 2656.463663] via-rhine 0000:00:12.0: eth0: link up, 100Mbps, full-duplex, lpa 0xCD$
Aug 10 06:04:09 siduxbox kernel: Kernel logging (proc) stopped.
Aug 10 06:04:09 siduxbox kernel: Kernel log daemon terminating.
Aug 10 06:04:10 siduxbox exiting on signal 15
Aug 10 06:04:59 siduxbox syslogd 1.5.0#6.1: restart.
Aug 10 04:05:52 siduxbox kernel: Inspecting /boot/System.map-3.0-1.slh.4-aptosid-686
Aug 10 04:05:53 siduxbox /usr/sbin/gpm[6609]: *** info [daemon/startup.c(131)]:
Aug 10 04:05:53 siduxbox /usr/sbin/gpm[6609]: Started gpm successfully. Entered daemon mode.
Aug 10 04:05:53 siduxbox kernel: Cannot find map file.
Aug 10 04:05:53 siduxbox kernel: Loaded 28616 symbols from 80 modules.

As you can see, time gets changed and survives a reboot, but once kernel starts talking, time is two hour off again Sad
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 10.08.2011, 06:14



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
Make sure, you have set UTC in /etc/default/rcS.
Make sure, you have configured tzdata to your country.
Use ntpd for syncronizing the time.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 10.08.2011, 14:56
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Also make sure in system settings > date & time > time zone > that you select your current local time and that under time zone your using europe.pool.ntp.org

If still having problems, I would maybe check your battery on the motherboard

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
effoOffline
Post subject:   PostPosted: 10.08.2011, 21:09



Joined: 2010-09-11
Posts: 22
Location: Linköping, Sweden
Status: Offline
Thanks Towo! I looked at /etc/default/rcS and it contained the row

UTC=no

changing that to 'yes' and doing a ntpdate-debian solved the issue. Even after a reboot time is correct! Once again, thanks!

The original file was created March 16, 2007. Maybe time to reinstal...?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio