Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
manulOffline
Post subject: [solved] virtual machine manager fails, permission denied  PostPosted: 17.08.2011, 16:11



Joined: 2010-09-13
Posts: 96

Status: Offline
Hi,

I use Virtual Machine Manager on my aptosid desktop, to connect to production servers (running CentOS 5.6).

I now get the following error when attempting to connect:

      Code:
Unable to open a connection to the libvirt management daemon.

Libvirt URI is: qemu+ssh://root@voip.gurulink.ca:122/system

Verify that:
 - The 'libvirtd' daemon has been started


Cannot recv data: Permission denied, please try again.

Permission denied, please try again.

Permission denied (publickey,gssapi-with-mic,password).
: Connection reset by peer

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1146, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1130, in _try_open
    flags)
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Cannot recv data: Permission denied, please try again.

Permission denied, please try again.

Permission denied (publickey,gssapi-with-mic,password).
: Connection reset by peer


It was working before, I guess the issue appeared with one of the latest upgrades.

The issue is with client: I am able to connect to the same host using another aptosid laptop (not upgraded since two months).

The laptop which works without issues, has Virtual Machine Manager installed version 0.8.7 (help->about)

The desktop which raises the above error, virt-manager is version 0.9.0 (help->about):
      Code:
root@siduxbox:/home/manul# apt-cache policy virt-manager
virt-manager:
  Installed: 0.9.0-1
  Candidate: 0.9.0-1
  Version table:
 *** 0.9.0-1 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
root@siduxbox:/home/manul#


I'd appreciate any clues.

Thanks!


Last edited by manul on 17.08.2011, 22:49; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject:   PostPosted: 17.08.2011, 22:33



Joined: 2010-09-13
Posts: 96

Status: Offline
I found some additional hints it may be a bug in current release:

http://lists.alioth.debian.org/pipermail/pkg-libvirt-maintainers/2011-July/002754.html

http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=e0a21dfef4a6ba9d09386cbedd2322aede0114dc

is it possible the package in sid is currently hit by this bug?

Anyone else experiencing this (and any clues how to cure)?

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject:   PostPosted: 17.08.2011, 22:48



Joined: 2010-09-13
Posts: 96

Status: Offline
Found the solution: temporarily enabled experimental, and installed libvirt0 and python-libvirt from experimental:

      Code:
apt-get update && apt-get -t experimental install libvirt0 python-libvirt


Marking the topic as solved.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio