Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ckosloffOffline
Post subject: Mounting ntfs drive as writable [SOLVED!]  PostPosted: 29.08.2011, 10:36



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
I need to mount on boot a storage internal drive, which is formatted in ntfs, as writable.
I have read the Debian wiki page, but it is not clear for me, I think that I should modify /etc/fstab.
This is my fstab:
      Code:
UUID=51cf3db3-7d1b-4d0c-891d-efe0f46a791d     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
UUID=53fe12d8-74ea-42c5-89b0-abaa53dc03fb     none                 swap         sw                                            0    0   
UUID=EAE4971EE496EBD7                         /media/disk2part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   

At present I can only access it read-only.
Also, for the ext4 bootable drive, shouldn't it be "realtime", instead of "relatime"?
I think this is just developer typo, should not be modified, right?


Last edited by ckosloff on 30.08.2011, 15:26; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
x-un-i
Post subject: Re: Mounting ntfs drive as writable  PostPosted: 29.08.2011, 10:55
Team Member


Joined: 2010-08-26
Posts: 170

      ckosloff wrote:
....
Also, for the ext4 bootable drive, shouldn't it be "realtime", instead of "relatime"?
I think this is just developer typo, should not be modified, right?



WRONG

      Quote:
relatime - Update inode access times relative to modify or change time. Access time is only updated if the previous access time was earlier than the current modify or change time. (Similar to noatime, but doesn't break mutt or other applications that need to know if a file has been read since the last time it was modified.) Can help performance

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: Mounting ntfs drive as writable  PostPosted: 29.08.2011, 15:40



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
Thanks for clarification, but that is only incidental to the question.
How can I make this ntfs drive mount on boot as writable?

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject: RE: Re: Mounting ntfs drive as writable  PostPosted: 29.08.2011, 15:41



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
use ntfs-3g
 
 View user's profile Send private message  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: Mounting ntfs drive as writable  PostPosted: 29.08.2011, 16:15



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
Package ntfs-3g installed, BTW it conflicts with ntfs-progs, it is one or the other.
Instructions from Debian wiki (for ntfs-3g) are:
      Code:
# mkdir /mnt/windows
# mount -t ntfs-3g /dev/sda1 /mnt/windows

Dir created successfully but getting this error, also in init 3:
      Code:
ckosloff@aptosiddino:~$ sux
Password:
root@aptosiddino:/home/ckosloff# mount -t ntfs /dev/sdb1 /mnt/windows
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.
root@aptosiddino:/home/ckosloff#

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 03:19



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
These are instructions from tuxera website to mount NTFS volume on boot:
      Code:
You can also make NTFS to be mounted during boot by adding the following line to the end of the /etc/fstab file:
/dev/sda1 /mnt/windows ntfs-3g defaults 0 0

http://www.tuxera.com/community/ntfs-3g-download/
I of course replaced sda1 with sdb1.
Here is my modified fstab:
      Code:
UUID=66E700D429DAEEEE                         /media/disk1part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
UUID=067be746-2ded-411c-ba21-1d1d7e4597aa     none                 swap         sw                                            0    0   
UUID=b3b2bbdf-e402-4930-be57-98330fa9dca7     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
UUID=658BC7AE41BE5506                         /media/disk3part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
/dev/sdb1 /mnt/windows ntfs-3g defaults 0 0

But, same error on boot: Mount is denied because the NTFS volume is already exclusively opened.
Some process is blocking the mount.
Please help, I really need this.

EDIT: I was writing this on different computers, first one has only one ntfs drive, second one has two, hence the dfference in numbering, but error is the same.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ghstryderOffline
Post subject: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 04:27



Joined: 2010-09-12
Posts: 95
Location: Detroit
Status: Offline
Erase the stuff you added.

Let's pretend that top line is your actual NTFS drive.

Change
      Code:
UUID=66E700D429DAEEEE    /media/disk1part1    ntfs    auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0

to read
      Code:
UUID=66E700D429DAEEEE    /media/disk1part1    ntfs-3g         defaults    0    0

and reboot.
 
 View user's profile Send private message  
Reply with quote Back to top
der_budOffline
Post subject: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 06:08



Joined: 2010-09-13
Posts: 18
Location: DE
Status: Offline
      ckosloff wrote:
... Some process is blocking the mount...
Yes, that happened because you tried to mount your device twice. What happened in your last two posts? When you entered the "mount -t" command in terminal to mount /dev/sdb1 to /mnt/windows, that device has already been mounted to /media/disk2part1 from your fstab furing boot. You should have entered "umount /dev/sdb1" first, like described here in Aptosid-Manual.
The same with your modified fstab, the first line mounted the same device to /media/disk1part1 that the last line wanted to mount to /mnt/windows. Remember to comment the line for mounting as ntfs with '#' before you enter the line ghstryder gave you, do not try to mount ntfs-devices twice.

_________________
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.
 
 View user's profile Send private message  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 15:23



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
OK, dudes, thanks so much for answer but...
after a night of sleeping with the problem spinning in my head, I figured it out.
So I just commented out offending lines, and voila!
This is what my new fstab looks like:
      Code:
# UUID=66E700D429DAEEEE                         /media/disk1part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
UUID=067be746-2ded-411c-ba21-1d1d7e4597aa     none                 swap         sw                                            0    0   
UUID=b3b2bbdf-e402-4930-be57-98330fa9dca7     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
# UUID=658BC7AE41BE5506                         /media/disk3part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
/dev/sdb1 /mnt/windows ntfs-3g defaults 0 0
/dev/sdc1 /mnt/windows ntfs-3g defaults 0 0

Maybe it is not the most elegant solution, because I see /mnt/windows in Dolphin's address bar, but, what the heck? it works!
Will test further later on and perfect the solution.
Vielen dank!

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
dptOffline
Post subject: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 15:27



Joined: 2010-09-11
Posts: 281
Location: New Delhi
Status: Offline
I had changed the ro to rw.
It works. rw-read/write.

simple, is not it?

Have a nice day.

dpt

_________________
In a lunatic asylum, everyone thinks that he is the doctor.
 
 View user's profile Send private message AIM Address  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 30.08.2011, 16:25



Joined: 2010-09-12
Posts: 326

Status: Offline
      ckosloff wrote:
OK, dudes, thanks so much for answer but...
after a night of sleeping with the problem spinning in my head, I figured it out.
So I just commented out offending lines, and voila!
This is what my new fstab looks like:
      Code:
# UUID=66E700D429DAEEEE                         /media/disk1part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
UUID=067be746-2ded-411c-ba21-1d1d7e4597aa     none                 swap         sw                                            0    0   
UUID=b3b2bbdf-e402-4930-be57-98330fa9dca7     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
# UUID=658BC7AE41BE5506                         /media/disk3part1    ntfs         auto,users,ro,dmask=0022,fmask=0133,nls=utf8  0    0   
/dev/sdb1 /mnt/windows ntfs-3g defaults 0 0
/dev/sdc1 /mnt/windows ntfs-3g defaults 0 0

Maybe it is not the most elegant solution, because I see /mnt/windows in Dolphin's address bar, but, what the heck? it works!
Will test further later on and perfect the solution.
Vielen dank!


It seems that you are pointing two disks (sdb1 and sdc1) to mount at the same point (/mnt/windows). This might give you troubles...

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 31.08.2011, 00:35



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
OK dudes, those suggestions are really great and I will try both.
If changing to rw does the trick, then no ntfs-3g is needed.
Regarding the mount points, I will take that into consideration too.
What I did is only a preliminary fix to get the ball rolling.
Thank you all very much, I will sleep better tonight...

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 31.08.2011, 02:29



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
Luis was right, having two drives mount at the same point did cause strange behaviours.
Good catch, Luis!
Apparently instructions on Tuxera's website are for only one drive.
Anyway, followed ghstryder's advice, commented out two last lines and modified the ones with the ntfs UUID to reflect ntfs-3g defaults 0 0
No more /mnt/windows and no more conflicts.
Not sure that to set drives to rw without ntfs-3g is good solution, everybody recommends using ntfs-3g instead, but have not tested that yet.
Maybe sometime later, too busy now finishing setting up systems on aptosid.

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
dptOffline
Post subject: RE: Re: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 04.09.2011, 16:08



Joined: 2010-09-11
Posts: 281
Location: New Delhi
Status: Offline
In new machinefor kid (Acer Aspire TimeLineX 5830T) I am also unable to write to NTFS partitions.Installed latest kde-Lite 64 bit today.
The rw works on my other ACERs and I do not remember doing anything
except the change to rw, with ntfs-3g.
Other machines have AMD boards, this has intel chips (with i3-2310M).

Funny, for the 1st time in my experience, no sound. And no kmix. Installing kmix.

_________________
In a lunatic asylum, everyone thinks that he is the doctor.
 
 View user's profile Send private message AIM Address  
Reply with quote Back to top
ckosloffOffline
Post subject: RE: Re: RE: Re: RE: Re: Mounting ntfs drive as writable  PostPosted: 05.09.2011, 00:34



Joined: 2011-08-16
Posts: 118
Location: Florida, USA
Status: Offline
      Code:
UUID=067be746-2ded-411c-ba21-1d1d7e4597aa     none                 swap         sw                                            0    0   
UUID=b3b2bbdf-e402-4930-be57-98330fa9dca7     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
UUID=66E700D429DAEEEE                         /media/disk1part1    ntfs-3g         defaults  0    0
UUID=658BC7AE41BE5506                         /media/disk3part1    ntfs-3g         defaults  0    0

This my new fstab.
As you can see what I did is simply change the file system from ntfs to ntfs-3g, and set defaults to 0 0.
Of course you need ntfs-3g installed.
ntfs-3g is used by live Linux CDs to mount ntfs file systems, so I think that it is the way to go, not just changing ro to rw.

_________________
http://www.flux.org/members.php?id=94
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio