Rootserver Sponsor



Please support your operating system's further development:


Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Post subject: [SOLVED] pavucontrol -- input device freeze  PostPosted: 24.09.2011, 19:11

Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
It has been several days (and kernels) since I last tried to use a microphone, so I cannot say for sure when this odd behavior began. And, I've only tested on one machine so far, but it happens with either a USB webcam (used as mic), or a desktop mic plugged into front audio jack.

Open pavucontrol, click the "Input Devices" tab, and I see the correct configuration, with a "pulsing" of the volume indicator that shows the mic is sensitive to sound -- it responds to noise. In about 5 seconds, the pulsing movement stops, and the mic is dead. Close pavucontrol, then immediately open pavucontrol, and the mic is alive .... for 5 seconds, and then dies again.

This is repeatable (on this hardware) with kernels 3.0.4.slh.5 and slh.6. I no longer have an older one Embarassed

Audio output is fine -- music players, flash, etc. all work great. Appropriate kernel modules are all loaded (snd_hda_intel, snd_usb_audio, etc. etc.) Google isn't helping. Does anyone else see this?

don@aptosidbox:~$ infobash -v3
Host/Kernel/OS  "aptosidbox" running Linux 3.0-4.slh.6-aptosid-amd64 x86_64 [ aptosid 2011-02 Ἡμέρα - kde-lite - (201107131633) ]
CPU Info        8x Intel Core i7 950 @ 8192 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 1600.000 MHz ]
Videocard       nVidia GF100 [GeForce GTX 480]  X.Org 1.11.0  [ 1920x1200@50.0hz ]
Network cards   Marvell 88E8056 PCI-E Gigabit
Processes 296 | Uptime 2:45 | Memory 1401.6/5978.7MB | HDD OCZ-REVODRIVE,OCZ-REVODRIVE,WDC WD1002FAEX-0,WDC WD1002FAEX-0,KINGSTON SS100S2 Size 2140GB (2%used) | GLX Renderer GeForce GTX 480/PCI/SSE2 | GLX Version 4.1.0 NVIDIA 275.28 | Client Shell | Infobash v3.37

UPDATE 26 SEP: Upon further investigation, it looks like I wrongly associated the visual indication described above with a skype test call failure. The visual "freeze" of the Input Device volume indicator on pavucontrol does still occur -- tested on both 64-bit and 32-bit systems, fully updated. However, skype test call works correctly on both systems today, so it is not correct that the mic function fails, only that pavucontrol makes it look like a failure. So I will mark this solved, although I still think there is something "not expected" going on with pavucontrol.
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio